CVE-2023-28447
CVE-2023-28447 · Cross site scripting vulnerability in Javascript escaping in smarty/smarty
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Smarty is a template engine for PHP. In affected versions smarty did not properly escape javascript code. An attacker could exploit this vulnerability to execute arbitrary JavaScript code in the context of the user's browser session. This may lead to unauthorized access to sensitive user data, manipulation of the web application's behavior, or unauthorized actions performed on behalf of the user. Users are advised to upgrade to either version 3.1.48 or to 4.3.1 to resolve this issue. There are no known workarounds for this vulnerability.
CVSS 7.1 · Hoch · EPSS 1,0% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · php
Betroffene Produkte und Versionen
smarty
- Softwareversionen
- >= 4.0.0, < 4.3.1: Betroffen
- < 3.1.48: Betroffen
Keine Korrektur veröffentlicht
smarty3 Debian:12
- Softwareversionen
- 3.1.47-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.1.47-2+deb12u1
Auf 3.1.47-2+deb12u1 aktualisieren
smarty3 Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.1.48-1
Auf 3.1.48-1 aktualisieren
smarty3 Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.1.48-1
Auf 3.1.48-1 aktualisieren
smarty4 Debian:12
- Softwareversionen
- 4.3.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.3.0-1+deb12u1
Auf 4.3.0-1+deb12u1 aktualisieren
smarty4 Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.3.1-1
Auf 4.3.1-1 aktualisieren
smarty4 Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.3.1-1
Auf 4.3.1-1 aktualisieren
smarty/smarty Packagist
- Softwareversionen
- v4.0.0
- v4.0.1
- v4.0.2
- v4.0.3
- v4.0.4
- v4.1.0
- v4.1.1
- v4.2.0
- v4.2.1
- v4.3.0
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 4.0.0, < 4.3.1
Auf 4.3.1 aktualisieren
smarty/smarty Packagist
- Softwareversionen
- v2.6.24
- v2.6.25
- v2.6.26
- v2.6.27
- v2.6.28
- v2.6.29
- v2.6.30
- v2.6.31
- v2.6.33
- v3.1.11
- v3.1.12
- v3.1.13
- v3.1.14
- v3.1.15
- v3.1.16
- v3.1.17
- v3.1.18
- v3.1.19
- v3.1.20
- v3.1.21
- v3.1.23
- v3.1.24
- v3.1.25
- v3.1.26
- v3.1.27
- v3.1.28
- v3.1.29
- v3.1.30
- v3.1.31
- v3.1.32
- v3.1.33
- v3.1.34
- v3.1.35
- v3.1.36
- v3.1.37
- v3.1.37.1
- v3.1.38
- v3.1.39
- v3.1.40
- v3.1.41
- v3.1.42
- v3.1.43
- v3.1.44
- v3.1.45
- v3.1.46
- v3.1.47
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.1.48
Auf 3.1.48 aktualisieren
civicrm Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 4.7.1+dfsg-1
- 4.7.1+dfsg-2
- 4.7.1+dfsg-2ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.7.1+dfsg-2ubuntu1+esm1
Auf 4.7.1+dfsg-2ubuntu1+esm1 aktualisieren
smarty3 Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 3.1.21-1
- 3.1.21-1ubuntu1
- 3.1.21-1ubuntu1+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.1.21-1ubuntu1+esm2
Auf 3.1.21-1ubuntu1+esm2 aktualisieren
civicrm Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 4.7.23+dfsg-1ubuntu1
- 4.7.24+dfsg-1ubuntu1
- 4.7.30+dfsg-1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 4.7.30+dfsg-1ubuntu1+esm1
Auf 4.7.30+dfsg-1ubuntu1+esm1 aktualisieren
postfixadmin Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 3.0.2-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.0.2-2ubuntu0.1~esm1
Auf 3.0.2-2ubuntu0.1~esm1 aktualisieren
smarty3 Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 3.1.31+20161214.1.c7d42e4+selfpack1-2
- 3.1.31+20161214.1.c7d42e4+selfpack1-3
- 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1+esm1
Auf 3.1.31+20161214.1.c7d42e4+selfpack1-3ubuntu0.1+esm1 aktualisieren
smarty3 Ubuntu:20.04:LTS
- Softwareversionen
- 3.1.33+20180830.1.3a78a21f+selfpack1-1
- 3.1.34+20190228.1.c9f0de05+selfpack1-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.1.34+20190228.1.c9f0de05+selfpack1-1ubuntu0.1
Auf 3.1.34+20190228.1.c9f0de05+selfpack1-1ubuntu0.1 aktualisieren
civicrm Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 5.11.0+dfsg-1
- 5.18.1+dfsg-1
- 5.20.3+dfsg-1
- 5.21.0+dfsg-1
- 5.21.1+dfsg-1
- 5.21.2+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.21.2+dfsg-1ubuntu0.1~esm1
Auf 5.21.2+dfsg-1ubuntu0.1~esm1 aktualisieren
postfixadmin Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 3.2.1-2
- 3.2.1-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.2.1-3ubuntu0.1~esm1
Auf 3.2.1-3ubuntu0.1~esm1 aktualisieren
smarty3 Ubuntu:22.04:LTS
- Softwareversionen
- 3.1.39-2
- 3.1.39-2ubuntu1
- 3.1.39-2ubuntu1.22.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.1.39-2ubuntu1.22.04.2
Auf 3.1.39-2ubuntu1.22.04.2 aktualisieren
civicrm Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 5.33.2+dfsg1-1
- 5.33.2+dfsg1-1build1
- 5.33.2+dfsg1-1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.33.2+dfsg1-1ubuntu1+esm1
Auf 5.33.2+dfsg1-1ubuntu1+esm1 aktualisieren
postfixadmin Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 3.3.7-1
- 3.3.10-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.3.10-2ubuntu0.1~esm1
Auf 3.3.10-2ubuntu0.1~esm1 aktualisieren
smarty3 Ubuntu:24.04:LTS
- Softwareversionen
- 3.1.48-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.1.48-1ubuntu0.24.04.1
Auf 3.1.48-1ubuntu0.24.04.1 aktualisieren
postfixadmin Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 3.3.13-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.3.13-1ubuntu0.1~esm1
Auf 3.3.13-1ubuntu0.1~esm1 aktualisieren
Originalquellen
- https://github.com/smarty-php/smarty/security/advisories/GHSA-7j98-h7fp-4vwj
- https://github.com/smarty-php/smarty/commit/685662466f653597428966d75a661073104d713d
- https://lists.fedoraproject.org/archives/list/[email protected]/message/HSAUM3YHWHO4UCJXRGRLQGPJAO3MFOZZ/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/JBB35GLYTL6JL6EOM6BOZNYP47JKNNHT/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/P7O7SKTATM6GAP45S64QFXNLWIY5I7HP/
- https://lists.debian.org/debian-lts-announce/2024/11/msg00013.html
- https://nvd.nist.gov/vuln/detail/CVE-2023-28447