p PatchFirst

CVE-2023-28755

CVE-2023-28755

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A ReDoS issue was discovered in the URI component through 0.12.0 in Ruby through 3.2.1. The URI parser mishandles invalid URLs that have specific characters. It causes an increase in execution time for parsing strings to URI objects. The fixed versions are 0.12.1, 0.11.1, 0.10.2 and 0.10.0.1.

CVSS 5.3 · Mittel · EPSS 2,6% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • n/a

    Softwareversionen
    • n/a: Betroffen

    Keine Korrektur veröffentlicht

  • jruby Debian:12

    Softwareversionen
    • 10.1.1.0+ds-1~exp1
    • 10.1.1.0+ds-1~exp2
    • 10.1.2.0+ds-1
    • 9.3.9.0+ds-8
    • 9.4.12.0+ds-1~exp1
    • 9.4.14.0+ds-1
    • 9.4.14.0+ds-1~exp1
    • 9.4.3.0+ds-1~exp1
    • 9.4.3.0+ds-1~exp2
    • 9.4.5.0+ds-1
    • 9.4.5.0+ds-1~exp1
    • 9.4.6.0+ds-1
    • 9.4.6.0+ds-1.1
    • 9.4.8.0+ds-1
    • 9.4.8.0+ds-2
    • 9.4.8.0+ds-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • jruby Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 9.4.5.0+ds-1

    Auf 9.4.5.0+ds-1 aktualisieren

  • jruby Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 9.4.5.0+ds-1

    Auf 9.4.5.0+ds-1 aktualisieren

  • ruby3.1 Debian:12

    Softwareversionen
    • 3.1.2-7
    • 3.1.2-7+deb12u1
    • 3.1.2-7+hurd.1
    • 3.1.2-8
    • 3.1.2-8.1~exp1
    • 3.1.2-8.3
    • 3.1.2-8.4
    • 3.1.2-8.5
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • rubygems Debian:12

    Softwareversionen
    • 3.3.15-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.3.15-2+deb12u1

    Auf 3.3.15-2+deb12u1 aktualisieren

  • rubygems Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.4.20-1

    Auf 3.4.20-1 aktualisieren

  • rubygems Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.4.20-1

    Auf 3.4.20-1 aktualisieren

  • ruby2.3 Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 2.3.0-1
    • 2.3.0-2
    • 2.3.0-4ubuntu2
    • 2.3.0-4ubuntu3
    • 2.3.0-5ubuntu1
    • 2.3.1-2~16.04
    • 2.3.1-2~16.04.2
    • 2.3.1-2~16.04.4
    • 2.3.1-2~16.04.5
    • 2.3.1-2~16.04.6
    • 2.3.1-2~16.04.7
    • 2.3.1-2~16.04.9
    • 2.3.1-2~16.04.10
    • 2.3.1-2~16.04.11
    • 2.3.1-2~16.04.12
    • 2.3.1-2~ubuntu16.04.13
    • 2.3.1-2~ubuntu16.04.14
    • 2.3.1-2~ubuntu16.04.15
    • 2.3.1-2~ubuntu16.04.16
    • 2.3.1-2~ubuntu16.04.16+esm1
    • 2.3.1-2~ubuntu16.04.16+esm2
    • 2.3.1-2~ubuntu16.04.16+esm3
    • 2.3.1-2~ubuntu16.04.16+esm4
    • 2.3.1-2~ubuntu16.04.16+esm5
    • 2.3.1-2~ubuntu16.04.16+esm6
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.3.1-2~ubuntu16.04.16+esm7

    Auf 2.3.1-2~ubuntu16.04.16+esm7 aktualisieren

  • jruby Ubuntu:16.04:LTS

    Softwareversionen
    • 1.7.21-2ubuntu4
    • 1.7.22-1ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ruby2.5 Ubuntu:18.04:LTS

    Softwareversionen
    • 2.5.0~preview1-1ubuntu2
    • 2.5.0-4ubuntu1
    • 2.5.0-4ubuntu4
    • 2.5.0-5ubuntu1
    • 2.5.0-6ubuntu1
    • 2.5.1-1ubuntu1
    • 2.5.1-1ubuntu1.1
    • 2.5.1-1ubuntu1.2
    • 2.5.1-1ubuntu1.4
    • 2.5.1-1ubuntu1.5
    • 2.5.1-1ubuntu1.6
    • 2.5.1-1ubuntu1.7
    • 2.5.1-1ubuntu1.8
    • 2.5.1-1ubuntu1.9
    • 2.5.1-1ubuntu1.10
    • 2.5.1-1ubuntu1.11
    • 2.5.1-1ubuntu1.12
    • 2.5.1-1ubuntu1.13
    • 2.5.1-1ubuntu1.14
    • 2.5.1-1ubuntu1.15
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.5.1-1ubuntu1.16

    Auf 2.5.1-1ubuntu1.16 aktualisieren

  • jruby Ubuntu:18.04:LTS

    Softwareversionen
    • 9.1.13.0-1
    • 9.1.17.0-1~18.04
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ruby2.7 Ubuntu:20.04:LTS

    Softwareversionen
    • 2.7.0-1
    • 2.7.0-2
    • 2.7.0-3
    • 2.7.0-4
    • 2.7.0-4ubuntu1
    • 2.7.0-5ubuntu1
    • 2.7.0-5ubuntu1.1
    • 2.7.0-5ubuntu1.2
    • 2.7.0-5ubuntu1.3
    • 2.7.0-5ubuntu1.4
    • 2.7.0-5ubuntu1.5
    • 2.7.0-5ubuntu1.6
    • 2.7.0-5ubuntu1.7
    • 2.7.0-5ubuntu1.8
    • 2.7.0-5ubuntu1.9
    • 2.7.0-5ubuntu1.10
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2.7.0-5ubuntu1.11

    Auf 2.7.0-5ubuntu1.11 aktualisieren

  • jruby Ubuntu:20.04:LTS

    Softwareversionen
    • 9.1.17.0-3
    • 9.1.17.0-3build5
    • 9.1.17.0-3build6
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • ruby3.0 Ubuntu:22.04:LTS

    Softwareversionen
    • 3.0.2-5ubuntu1
    • 3.0.2-7
    • 3.0.2-7ubuntu2
    • 3.0.2-7ubuntu2.1
    • 3.0.2-7ubuntu2.2
    • 3.0.2-7ubuntu2.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.0.2-7ubuntu2.4

    Auf 3.0.2-7ubuntu2.4 aktualisieren

  • rubygems Ubuntu:22.04:LTS

    Softwareversionen
    • 3.2.5-2
    • 3.2.27-2
    • 3.2.27-3
    • 3.3.5-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.3.5-2ubuntu1.1

    Auf 3.3.5-2ubuntu1.1 aktualisieren

  • jruby Ubuntu:24.04:LTS

    Softwareversionen
    • 9.3.9.0+ds-1
    • 9.4.5.0+ds-1
    • 9.4.5.0+ds-1ubuntu1
    • 9.4.6.0+ds-1ubuntu3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • jruby Ubuntu:25.10

    Softwareversionen
    • 9.4.8.0+ds-2ubuntu1
    • 9.4.8.0+ds-3ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • jruby Ubuntu:26.10

    Softwareversionen
    • 9.4.8.0+ds-3ubuntu1
    • 9.4.14.0+ds-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • jruby Ubuntu:26.04:LTS

    Softwareversionen
    • 9.4.8.0+ds-3ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →