CVE-2023-28836
CVE-2023-28836 · Wagtail vulnerable to stored Cross-site Scripting attack via ModelAdmin views
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Wagtail is an open source content management system built on Django. Starting in version 1.5 and prior to versions 4.1.4 and 4.2.2, a stored cross-site scripting (XSS) vulnerability exists on ModelAdmin views within the Wagtail admin interface. A user with a limited-permission editor account for the Wagtail admin could potentially craft pages and documents that, when viewed by a user with higher privileges, could perform actions with that user's credentials. The vulnerability is not exploitable by an ordinary site visitor without access to the Wagtail admin, and only affects sites with ModelAdmin enabled. For page, the vulnerability is in the "Choose a parent page" ModelAdmin view (`ChooseParentView`), available when managing pages via ModelAdmin. For documents, the vulnerability is in the ModelAdmin Inspect view (`InspectView`) when displaying document fields. Patched versions have been released as Wagtail 4.1.4 and Wagtail 4.2.2. Site owners who are unable to upgrade to the new versions can disable or override the corresponding functionality.
CVSS 6.4 · Mittel · EPSS 0,8% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
wagtail
- Softwareversionen
- ≥ 1.5, < 1.5*: Betroffen (custom)
- ≥ 4.1.1, < 4.1.1: Betroffen (custom)
- ≥ 4.2, < 4.2*: Betroffen (custom)
- ≥ 4.2.2, < 4.2.2: Betroffen (custom)
Keine Korrektur veröffentlicht
wagtail PyPI
- Softwareversionen
- 1.10
- 1.10.1
- 1.10rc1
- 1.11
- 1.11.1
- 1.11rc1
- 1.12
- 1.12.1
- 1.12.2
- 1.12.3
- 1.12.4
- 1.12.5
- 1.12.6
- 1.12rc1
- 1.13
- 1.13.1
- 1.13.2
- 1.13.3
- 1.13.4
- 1.13rc1
- 1.5
- 1.5.1
- 1.5.2
- 1.5.3
- 1.6
- 1.6.1
- 1.6.2
- 1.6.3
- 1.6rc1
- 1.7
- 1.7rc1
- 1.8
- 1.8.1
- 1.8.2
- 1.8rc1
- 1.9
- 1.9.1
- 1.9rc1
- 2.0
- 2.0.1
- 2.0.2
- 2.0b1
- 2.0rc1
- 2.1
- 2.1.1
- 2.1.2
- 2.1.3
- 2.10
- 2.10.1
- 2.10.2
- 2.10rc1
- 2.10rc2
- 2.11
- 2.11.1
- 2.11.2
- 2.11.3
- 2.11.4
- 2.11.5
- 2.11.6
- 2.11.7
- 2.11.8
- 2.11.9
- 2.11rc1
- 2.12
- 2.12.1
- 2.12.2
- 2.12.3
- 2.12.4
- 2.12.5
- 2.12.6
- 2.12rc1
- 2.13
- 2.13.1
- 2.13.2
- 2.13.3
- 2.13.4
- 2.13.5
- 2.13rc1
- 2.13rc2
- 2.13rc3
- 2.14
- 2.14.1
- 2.14.2
- 2.14rc1
- 2.15
- 2.15.1
- 2.15.2
- 2.15.3
- 2.15.4
- 2.15.5
- 2.15.6
- 2.15rc1
- 2.15rc2
- 2.16
- 2.16.1
- 2.16.2
- 2.16.3
- 2.16rc1
- 2.16rc2
- 2.1rc1
- 2.1rc2
- 2.2
- 2.2.1
- 2.2.2
- 2.2rc1
- 2.2rc2
- 2.3
- 2.3rc1
- 2.3rc2
- 2.4
- 2.4rc1
- 2.5
- 2.5.1
- 2.5.2
- 2.5rc1
- 2.6
- 2.6.1
- 2.6.2
- 2.6.3
- 2.6rc1
- 2.7
- 2.7.1
- 2.7.2
- 2.7.3
- 2.7.4
- 2.7rc1
- 2.7rc2
- 2.8
- 2.8.1
- 2.8.2
- 2.8rc1
- 2.9
- 2.9.1
- 2.9.2
- 2.9.3
- 2.9rc1
- 3.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.0rc1
- 3.0rc2
- 3.0rc3
- 4.0
- 4.0.1
- 4.0.2
- 4.0.3
- 4.0.4
- 4.0rc1
- 4.0rc2
- 4.1
- 4.1.1
- 4.1.2
- 4.1.3
- 4.1rc1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 1.5, < 4.1.4
Auf 4.1.4 aktualisieren
wagtail PyPI
- Softwareversionen
- 4.2
- 4.2.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 4.2, < 4.2.2
Auf 4.2.2 aktualisieren
wagtail PyPI
- Softwareversionen
- 1.10
- 1.10.1
- 1.10rc1
- 1.11
- 1.11.1
- 1.11rc1
- 1.12
- 1.12.1
- 1.12.2
- 1.12.3
- 1.12.4
- 1.12.5
- 1.12.6
- 1.12rc1
- 1.13
- 1.13.1
- 1.13.2
- 1.13.3
- 1.13.4
- 1.13rc1
- 1.5
- 1.5.1
- 1.5.2
- 1.5.3
- 1.6
- 1.6.1
- 1.6.2
- 1.6.3
- 1.6rc1
- 1.7
- 1.7rc1
- 1.8
- 1.8.1
- 1.8.2
- 1.8rc1
- 1.9
- 1.9.1
- 1.9rc1
- 2.0
- 2.0.1
- 2.0.2
- 2.0b1
- 2.0rc1
- 2.1
- 2.1.1
- 2.1.2
- 2.1.3
- 2.10
- 2.10.1
- 2.10.2
- 2.10rc1
- 2.10rc2
- 2.11
- 2.11.1
- 2.11.2
- 2.11.3
- 2.11.4
- 2.11.5
- 2.11.6
- 2.11.7
- 2.11.8
- 2.11.9
- 2.11rc1
- 2.12
- 2.12.1
- 2.12.2
- 2.12.3
- 2.12.4
- 2.12.5
- 2.12.6
- 2.12rc1
- 2.13
- 2.13.1
- 2.13.2
- 2.13.3
- 2.13.4
- 2.13.5
- 2.13rc1
- 2.13rc2
- 2.13rc3
- 2.14
- 2.14.1
- 2.14.2
- 2.14rc1
- 2.15
- 2.15.1
- 2.15.2
- 2.15.3
- 2.15.4
- 2.15.5
- 2.15.6
- 2.15rc1
- 2.15rc2
- 2.16
- 2.16.1
- 2.16.2
- 2.16.3
- 2.16rc1
- 2.16rc2
- 2.1rc1
- 2.1rc2
- 2.2
- 2.2.1
- 2.2.2
- 2.2rc1
- 2.2rc2
- 2.3
- 2.3rc1
- 2.3rc2
- 2.4
- 2.4rc1
- 2.5
- 2.5.1
- 2.5.2
- 2.5rc1
- 2.6
- 2.6.1
- 2.6.2
- 2.6.3
- 2.6rc1
- 2.7
- 2.7.1
- 2.7.2
- 2.7.3
- 2.7.4
- 2.7rc1
- 2.7rc2
- 2.8
- 2.8.1
- 2.8.2
- 2.8rc1
- 2.9
- 2.9.1
- 2.9.2
- 2.9.3
- 2.9rc1
- 3.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.0rc1
- 3.0rc2
- 3.0rc3
- 4.0
- 4.0.1
- 4.0.2
- 4.0.3
- 4.0.4
- 4.0rc1
- 4.0rc2
- 4.1
- 4.1.1
- 4.1.2
- 4.1.3
- 4.1rc1
- 4.2
- 4.2.1
- v4.2.1
- v4.2
- v4.2rc1
- v4.1rc1
- v2.16rc1
- v2.11.rc1
- v2.8rc1
- v2.2rc1
- v1.10rc1
- v1.8rc1
- v1.6rc1
- v1.5rc1
- v1.4rc1
- v1.3rc1
- v1.2rc1
- v1.1rc1
- v1.0rc1
- v1.0b2
- v0.8.1
- v0.8
- v0.7
- v0.6
- v0.5
- v0.4
- v0.2
- v0.1
- Betroffene Versionsbereiche
- {"events": [{"introduced": "0"}, {"fixed": "eefc3381d37b476791610e5d30594fae443f33af"}, {"fixed": "bc84bf9815610cfbf8db3b6050c7ddcbaa4b9713"}, {"fixed": "5be2b1ed55fd7259dfdf2c82e7701dba407b8b62"}, {"fixed": "ff806ab173a504395fdfb3139eb0a29444ab4b91"}], "repo": "https://github.com/wagtail/wagtail", "type": "GIT"}
- ECOSYSTEM: ≥ 1.5, < 4.1.4 ∪ ≥ 4.2, < 4.2.2
Auf 4.1.4 aktualisieren; Auf 4.2.2 aktualisieren
Originalquellen
- https://github.com/wagtail/wagtail/commit/bc84bf9815610cfbf8db3b6050c7ddcbaa4b9713
- https://github.com/wagtail/wagtail/commit/eefc3381d37b476791610e5d30594fae443f33af
- https://docs.wagtail.org/en/stable/reference/contrib/modeladmin/chooseparentview.html#customising-chooseparentview
- https://docs.wagtail.org/en/stable/reference/contrib/modeladmin/inspectview.html#enabling-customising-inspectview
- https://github.com/wagtail/wagtail/releases/tag/v4.2.2
- https://github.com/wagtail/wagtail/security/advisories/GHSA-5286-f2rf-35c2
- https://github.com/wagtail/wagtail/commit/5be2b1ed55fd7259dfdf2c82e7701dba407b8b62
- https://github.com/wagtail/wagtail/commit/ff806ab173a504395fdfb3139eb0a29444ab4b91
- https://nvd.nist.gov/vuln/detail/CVE-2023-28836