p PatchFirst

CVE-2023-2905

CVE-2023-2905 · Cesanta Mongoose MQTT Message Parsing Heap Overflow

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Due to a failure in validating the length of a provided MQTT_CMD_PUBLISH parsed message with a variable length header, Cesanta Mongoose, an embeddable web server, version 7.10 is susceptible to a heap-based buffer overflow vulnerability in the default configuration. Version 7.9 and prior does not appear to be vulnerable. This issue is resolved in version 7.11.

CVSS 8.8 · Hoch · EPSS 1,0% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • mongoose

    Softwareversionen
    • 7.10: Betroffen
    • 7.11: Nicht betroffen

    Auf 7.11 aktualisieren

  • swupdate Debian:12

    Softwareversionen
    • 2022.12+dfsg-4
    • 2022.12+dfsg-4+deb12u1
    • 2022.12+dfsg-4+deb12u1~bpo11+1
    • 2022.12+dfsg-4+deb12u2
    • 2022.12+dfsg-4+deb12u3
    • 2023.05+dfsg-1
    • 2023.05+dfsg-2
    • 2023.05+dfsg-2~bpo12+1
    • 2023.05+dfsg-3
    • 2023.05+dfsg-4
    • 2023.05+dfsg-5
    • 2023.05+dfsg-5~bpo12+1
    • 2023.12+dfsg-1
    • 2023.12+dfsg-1~bpo12+1
    • 2023.12.1+dfsg-1
    • 2023.12.1+dfsg-1~bpo12+1
    • 2023.12.1+dfsg-2
    • 2023.12.1+dfsg-2~bpo12+1
    • 2024.05+dfsg-1
    • 2024.05.2+dfsg-1
    • 2024.05.2+dfsg-2
    • 2024.05.2+dfsg-2~bpo12+1
    • 2024.12+dfsg-1
    • 2024.12+dfsg-2
    • 2024.12+dfsg-2~bpo12+1
    • 2024.12.1+dfsg-1
    • 2024.12.1+dfsg-1~bpo12+1
    • 2024.12.1+dfsg-2
    • 2024.12.1+dfsg-3
    • 2024.12.1+dfsg-3~bpo12+1
    • 2025.05+dfsg-1
    • 2025.05+dfsg-2
    • 2025.05+dfsg-2~bpo13+1
    • 2025.05+dfsg-3
    • 2025.05+dfsg-3~bpo13+1
    • 2025.12+dfsg-1
    • 2025.12+dfsg-10
    • 2025.12+dfsg-10~bpo13+1
    • 2025.12+dfsg-10~bpo13+2
    • 2025.12+dfsg-2
    • 2025.12+dfsg-2~bpo13+1
    • 2025.12+dfsg-3
    • 2025.12+dfsg-4
    • 2025.12+dfsg-5
    • 2025.12+dfsg-6
    • 2025.12+dfsg-7
    • 2025.12+dfsg-7~bpo13+1
    • 2025.12+dfsg-8
    • 2025.12+dfsg-9
    • 2026.05+dfsg-1
    • 2026.05+dfsg-2
    • 2026.05+dfsg-3
    • 2026.05+dfsg-3~bpo13+1
    • 2026.05+dfsg-4
    • 2026.05.1+dfsg-1
    • 2026.05.1+dfsg-1~bpo13+1
    • 2026.05.1+git20261001+dfsg-1
    • 2026.05.1+git20261001+dfsg-2
    • 2026.05.1+git20261001+dfsg-2~bpo13+1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • swupdate Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2024.12+dfsg-1

    Auf 2024.12+dfsg-1 aktualisieren

  • swupdate Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2024.12+dfsg-1

    Auf 2024.12+dfsg-1 aktualisieren

  • swupdate Ubuntu:22.04:LTS

    Softwareversionen
    • 2020.11-2
    • 2021.04-1.1
    • 2021.04-2
    • 2021.04-2build1
    • 2021.11-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • swupdate Ubuntu:24.04:LTS

    Softwareversionen
    • 2023.05+dfsg-3
    • 2023.05+dfsg-4
    • 2023.05+dfsg-4build1
    • 2023.05+dfsg-5
    • 2023.12+dfsg-1
    • 2023.12.1+dfsg-1ubuntu1
    • 2023.12.1+dfsg-1ubuntu4
    • 2023.12.1+dfsg-1ubuntu5
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →