CVE-2023-29529
CVE-2023-29529 · matrix-js-sdk vulnerable to invisible eavesdropping in group calls
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
matrix-js-sdk is the Matrix Client-Server SDK for JavaScript and TypeScript. An attacker present in a room where an MSC3401 group call is taking place can eavesdrop on the video and audio of participants using matrix-js-sdk, without their knowledge. To affected matrix-js-sdk users, the attacker will not appear to be participating in the call. This attack is possible because matrix-js-sdk's group call implementation accepts incoming direct calls from other users, even if they have not yet declared intent to participate in the group call, as a means of resolving a race condition in call setup. Affected versions do not restrict access to the user's outbound media in this case. Legacy 1:1 calls are unaffected. This is fixed in matrix-js-sdk 24.1.0. As a workaround, users may hold group calls in private rooms where only the exact users who are expected to participate in the call are present.
CVSS 5.0 · Mittel · EPSS 0,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
matrix-js-sdk
- Softwareversionen
- < 24.1.0: Betroffen
Keine Korrektur veröffentlicht
node-matrix-js-sdk Debian:11
- Softwareversionen
- 9.11.0+~cs9.9.16-1
- 9.11.0+~cs9.9.16-2
- 9.3.0+~cs9.9.16-2
- 9.7.0~~rc1+~cs9.9.16-1
- 9.7.0~~rc1+~cs9.9.16-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
matrix-js-sdk npm
- Betroffene Versionsbereiche
- SEMVER: < 24.1.0
Auf 24.1.0 aktualisieren
node-matrix-js-sdk Ubuntu:20.04:LTS
- Softwareversionen
- 0.9.2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-matrix-js-sdk Ubuntu:22.04:LTS
- Softwareversionen
- 9.3.0+~cs9.9.16-2
- 9.11.0+~cs9.9.16-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-matrix-js-sdk Ubuntu:24.04:LTS
- Softwareversionen
- 9.11.0+~cs9.9.16-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht