p PatchFirst

CVE-2023-2975

CVE-2023-2975 · AES-SIV implementation ignores empty associated data entries

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Issue summary: The AES-SIV cipher implementation contains a bug that causes it to ignore empty associated data entries which are unauthenticated as a consequence. Impact summary: Applications that use the AES-SIV algorithm and want to authenticate empty data entries as associated data can be misled by removing, adding or reordering such empty entries as these are ignored by the OpenSSL implementation. We are currently unaware of any such applications. The AES-SIV algorithm allows for authentication of multiple associated data entries along with the encryption. To authenticate empty data the application has to call EVP_EncryptUpdate() (or EVP_CipherUpdate()) with NULL pointer as the output buffer and 0 as the input buffer length. The AES-SIV implementation in OpenSSL just returns success for such a call instead of performing the associated data authentication operation. The empty data thus will not be authenticated. As this issue does not affect non-empty associated data authentication and we expect it to be rare for an application to use empty associated data entries this is qualified as Low severity issue.

CVSS 5.3 · Mittel · EPSS 0,6% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · network

Betroffene Produkte und Versionen

  • openssl

    Softwareversionen
    • ≥ 3.1.0, < 3.1.2: Betroffen (semver)
    • ≥ 3.0.0, < 3.0.10: Betroffen (semver)

    Auf 3.0.10 aktualisieren; Auf 3.1.2 aktualisieren

  • openssl Debian:12

    Softwareversionen
    • 3.0.9-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.0.10-1~deb12u1

    Auf 3.0.10-1~deb12u1 aktualisieren

  • openssl Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.0.10-1

    Auf 3.0.10-1 aktualisieren

  • openssl Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.0.10-1

    Auf 3.0.10-1 aktualisieren

  • openssl Ubuntu:22.04:LTS

    Softwareversionen
    • 1.1.1l-1ubuntu1
    • 3.0.0-1ubuntu1
    • 3.0.1-0ubuntu1
    • 3.0.2-0ubuntu1
    • 3.0.2-0ubuntu1.1
    • 3.0.2-0ubuntu1.2
    • 3.0.2-0ubuntu1.4
    • 3.0.2-0ubuntu1.5
    • 3.0.2-0ubuntu1.6
    • 3.0.2-0ubuntu1.7
    • 3.0.2-0ubuntu1.8
    • 3.0.2-0ubuntu1.9
    • 3.0.2-0ubuntu1.10
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.0.2-0ubuntu1.12

    Auf 3.0.2-0ubuntu1.12 aktualisieren

  • nodejs Ubuntu:Pro:22.04:LTS

    Softwareversionen
    • 12.22.5~dfsg-5ubuntu1
    • 12.22.7~dfsg-2ubuntu1
    • 12.22.7~dfsg-2ubuntu3
    • 12.22.9~dfsg-1ubuntu2
    • 12.22.9~dfsg-1ubuntu3
    • 12.22.9~dfsg-1ubuntu3.1
    • 12.22.9~dfsg-1ubuntu3.2
    • 12.22.9~dfsg-1ubuntu3.3
    • 12.22.9~dfsg-1ubuntu3.4
    • 12.22.9~dfsg-1ubuntu3.5
    • 12.22.9~dfsg-1ubuntu3.6
    • 12.22.9~dfsg-1ubuntu3.6+esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • openssl Ubuntu:Pro:FIPS-preview:22.04:LTS

    Softwareversionen
    • 3.0.2-0ubuntu1.10+Fips1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.0.2-0ubuntu1.12+Fips1

    Auf 3.0.2-0ubuntu1.12+Fips1 aktualisieren

  • openssl Ubuntu:Pro:FIPS-updates:22.04:LTS

    Softwareversionen
    • 3.0.2-0ubuntu1.10+Fips1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.0.2-0ubuntu1.12+Fips1

    Auf 3.0.2-0ubuntu1.12+Fips1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →