p PatchFirst

CVE-2023-32058

CVE-2023-32058 · Vyper vulnerable to integer overflow in loop

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Vyper is a Pythonic smart contract language for the Ethereum virtual machine. Prior to version 0.3.8, due to missing overflow check for loop variables, by assigning the iterator of a loop to a variable, it is possible to overflow the type of the latter. The issue seems to happen only in loops of type `for i in range(a, a + N)` as in loops of type `for i in range(start, stop)` and `for i in range(stop)`, the compiler is able to raise a `TypeMismatch` when trying to overflow the variable. The problem has been patched in version 0.3.8.

CVSS 7.5 · Hoch · EPSS 0,9% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • vyper

    Softwareversionen
    • < 0.3.8: Betroffen

    Keine Korrektur veröffentlicht

  • vyper PyPI

    Softwareversionen
    • 0.1.0b1
    • 0.1.0b10
    • 0.1.0b11
    • 0.1.0b12
    • 0.1.0b13
    • 0.1.0b14
    • 0.1.0b15
    • 0.1.0b16
    • 0.1.0b17
    • 0.1.0b2
    • 0.1.0b3
    • 0.1.0b4
    • 0.1.0b5
    • 0.1.0b6
    • 0.1.0b7
    • 0.1.0b8
    • 0.1.0b9
    • 0.2.1
    • 0.2.10
    • 0.2.11
    • 0.2.12
    • 0.2.13
    • 0.2.14
    • 0.2.15
    • 0.2.16
    • 0.2.2
    • 0.2.3
    • 0.2.4
    • 0.2.5
    • 0.2.6
    • 0.2.7
    • 0.2.8
    • 0.2.9
    • 0.3.0
    • 0.3.1
    • 0.3.2
    • 0.3.3
    • 0.3.4
    • 0.3.5
    • 0.3.6
    • 0.3.7
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 0.3.8

    Auf 0.3.8 aktualisieren

  • vyper PyPI

    Softwareversionen
    • 0.1.0b1
    • 0.1.0b10
    • 0.1.0b11
    • 0.1.0b12
    • 0.1.0b13
    • 0.1.0b14
    • 0.1.0b15
    • 0.1.0b16
    • 0.1.0b17
    • 0.1.0b2
    • 0.1.0b3
    • 0.1.0b4
    • 0.1.0b5
    • 0.1.0b6
    • 0.1.0b7
    • 0.1.0b8
    • 0.1.0b9
    • 0.2.1
    • 0.2.10
    • 0.2.11
    • 0.2.12
    • 0.2.13
    • 0.2.14
    • 0.2.15
    • 0.2.16
    • 0.2.2
    • 0.2.3
    • 0.2.4
    • 0.2.5
    • 0.2.6
    • 0.2.7
    • 0.2.8
    • 0.2.9
    • 0.3.0
    • 0.3.1
    • 0.3.2
    • 0.3.3
    • 0.3.4
    • 0.3.5
    • 0.3.6
    • 0.3.7
    Betroffene Versionsbereiche
    • GIT: < 3de1415ee77a9244eb04bdb695e249d3ec9ed868
    • ECOSYSTEM: < 0.3.8

    Auf 0.3.8 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →