p PatchFirst

CVE-2023-32067

CVE-2023-32067 · 0-byte UDP payload DoS in c-ares

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

c-ares is an asynchronous resolver library. c-ares is vulnerable to denial of service. If a target resolver sends a query, the attacker forges a malformed UDP packet with a length of 0 and returns them to the target resolver. The target resolver erroneously interprets the 0 length as a graceful shutdown of the connection. This issue has been patched in version 1.19.1.

CVSS 7.5 · Hoch · EPSS 1,6% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • c-ares

    Softwareversionen
    • < 1.19.1: Betroffen

    Keine Korrektur veröffentlicht

  • c-ares Debian:12

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.18.1-3

    Auf 1.18.1-3 aktualisieren

  • c-ares Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.18.1-3

    Auf 1.18.1-3 aktualisieren

  • c-ares Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.18.1-3

    Auf 1.18.1-3 aktualisieren

  • c-ares Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 1.10.0-2
    • 1.10.0-3
    • 1.10.0-3ubuntu0.1
    • 1.10.0-3ubuntu0.2
    • 1.10.0-3ubuntu0.2+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.10.0-3ubuntu0.2+esm2

    Auf 1.10.0-3ubuntu0.2+esm2 aktualisieren

  • c-ares Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 1.13.0-2
    • 1.13.0-3
    • 1.14.0-1
    • 1.14.0-1ubuntu0.1
    • 1.14.0-1ubuntu0.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.14.0-1ubuntu0.2+esm1

    Auf 1.14.0-1ubuntu0.2+esm1 aktualisieren

  • c-ares Ubuntu:20.04:LTS

    Softwareversionen
    • 1.15.0-1build1
    • 1.15.0-1ubuntu0.1
    • 1.15.0-1ubuntu0.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.15.0-1ubuntu0.3

    Auf 1.15.0-1ubuntu0.3 aktualisieren

  • c-ares Ubuntu:22.04:LTS

    Softwareversionen
    • 1.17.1-1ubuntu1
    • 1.18.1-1
    • 1.18.1-1build1
    • 1.18.1-1ubuntu0.22.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.18.1-1ubuntu0.22.04.2

    Auf 1.18.1-1ubuntu0.22.04.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →