p PatchFirst

CVE-2023-32314

CVE-2023-32314 · Sandbox Escape

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

vm2 is a sandbox that can run untrusted code with Node's built-in modules. A sandbox escape vulnerability exists in vm2 for versions up to and including 3.9.17. It abuses an unexpected creation of a host object based on the specification of `Proxy`. As a result a threat actor can bypass the sandbox protections to gain remote code execution rights on the host running the sandbox. This vulnerability was patched in the release of version `3.9.18` of `vm2`. Users are advised to upgrade. There are no known workarounds for this vulnerability.

CVSS 9.8 · Kritisch · EPSS 8,1% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • vm2

    Softwareversionen
    • < 3.9.18: Betroffen

    Keine Korrektur veröffentlicht

  • vm2 npm

    Betroffene Versionsbereiche
    • SEMVER: < 3.9.18

    Auf 3.9.18 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →