p PatchFirst

CVE-2023-37271

CVE-2023-37271 · RestrictedPython vulnerable to arbitrary code execution via stack frame sandbox escape

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

RestrictedPython is a tool that helps to define a subset of the Python language which allows users to provide a program input into a trusted environment. RestrictedPython does not check access to stack frames and their attributes. Stack frames are accessible within at least generators and generator expressions, which are allowed inside RestrictedPython. Prior to versions 6.1 and 5.3, an attacker with access to a RestrictedPython environment can write code that gets the current stack frame in a generator and then walk the stack all the way beyond the RestrictedPython invocation boundary, thus breaking out of the restricted sandbox and potentially allowing arbitrary code execution in the Python interpreter. All RestrictedPython deployments that allow untrusted users to write Python code in the RestrictedPython environment are at risk. In terms of Zope and Plone, this would mean deployments where the administrator allows untrusted users to create and/or edit objects of type `Script (Python)`, `DTML Method`, `DTML Document` or `Zope Page Template`. This is a non-default configuration and likely to be extremely rare. The problem has been fixed in versions 6.1 and 5.3.

CVSS 8.4 · Hoch · EPSS 0,8% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • restrictedpython

    Softwareversionen
    • >= 6.0a1.dev0, < 6.1: Betroffen
    • < 5.3: Betroffen

    Keine Korrektur veröffentlicht

  • restrictedpython Debian:12

    Softwareversionen
    • 4.0~b3-3
    • 6.2-1
    • 8.0-1
    • 8.1-1
    • 8.4-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • restrictedpython Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 6.2-1

    Auf 6.2-1 aktualisieren

  • restrictedpython Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 6.2-1

    Auf 6.2-1 aktualisieren

  • restrictedpython PyPI

    Softwareversionen
    • 3.4.2
    • 3.4.3
    • 3.5.0
    • 3.5.1
    • 3.5.2
    • 3.6.0
    • 3.6.0a1
    • 4.0
    • 4.0a1
    • 4.0a2
    • 4.0a3
    • 4.0b1
    • 4.0b2
    • 4.0b3
    • 4.0b4
    • 4.0b5
    • 4.0b6
    • 4.0b7
    • 4.0b8
    • 5.0
    • 5.1
    • 5.2
    • 5.2a1.dev0
    • 5.3a1.dev0
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.3

    Auf 5.3 aktualisieren

  • restrictedpython PyPI

    Softwareversionen
    • 6.0
    • 6.0a1.dev0
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 6.0a1.dev0, < 6.1

    Auf 6.1 aktualisieren

  • restrictedpython PyPI

    Softwareversionen
    • 3.4.2
    • 3.4.3
    • 3.5.0
    • 3.5.1
    • 3.5.2
    • 3.6.0
    • 3.6.0a1
    • 4.0
    • 4.0a1
    • 4.0a2
    • 4.0a3
    • 4.0b1
    • 4.0b2
    • 4.0b3
    • 4.0b4
    • 4.0b5
    • 4.0b6
    • 4.0b7
    • 4.0b8
    • 5.0
    • 5.1
    • 5.2
    • 5.2a1.dev0
    • 5.3a1.dev0
    Betroffene Versionsbereiche
    • GIT: < c8eca66ae49081f0016d2e1f094c3d72095ef531
    • ECOSYSTEM: < 5.3

    Auf 5.3 aktualisieren

  • restrictedpython Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 4.0~b3-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.0~b3-2ubuntu0.1~esm1

    Auf 4.0~b3-2ubuntu0.1~esm1 aktualisieren

  • restrictedpython Ubuntu:Pro:22.04:LTS

    Softwareversionen
    • 4.0~b3-2
    • 4.0~b3-2ubuntu1
    • 4.0~b3-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 4.0~b3-3ubuntu0.1~esm1

    Auf 4.0~b3-3ubuntu0.1~esm1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →