p PatchFirst

CVE-2023-37901

CVE-2023-37901 · Cross-Site-Scripting via confirmation prompts

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Indico is an open source a general-purpose, web based event management tool. There is a Cross-Site-Scripting vulnerability in confirmation prompts commonly used when deleting content from Indico. Exploitation requires someone with at least submission privileges (such as a speaker) and then someone else to attempt to delete this content. Considering that event organizers may want to delete suspicious-looking content when spotting it, there is a non-negligible risk of such an attack to succeed. The risk of this could be further increased when combined with some some social engineering pointing the victim towards this content. Users need to update to Indico 3.2.6 as soon as possible. See the docs for instructions on how to update. Users who cannot upgrade should only let trustworthy users manage categories, create events or upload materials ("submission" privileges on a contribution/event). This should already be the case in a properly-configured setup when it comes to category/event management. Note that a conference doing a Call for Abstracts actively invites external speakers (who the organizers may not know and thus cannot fully trust) to submit content, hence the need to update to a a fixed version ASAP in particular when using such workflows.

CVSS 5.4 · Mittel · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • indico

    Softwareversionen
    • < 3.2.6: Betroffen

    Keine Korrektur veröffentlicht

  • indico PyPI

    Softwareversionen
    • 0.98-rc1
    • 0.98.0
    • 0.98.1
    • 0.98.2
    • 0.99
    • 1.0
    • 1.1
    • 1.1.1
    • 1.1.2
    • 1.2
    • 1.2.1
    • 1.2.1rc10
    • 1.2.1rc11
    • 1.2.1rc2
    • 1.2.1rc4
    • 1.2.1rc5
    • 1.2.1rc6
    • 1.2.1rc7
    • 1.2.1rc9
    • 1.2.2
    • 1.2.2rc1
    • 1.9.11.dev10
    • 1.9.11.dev11
    • 1.9.11.dev12
    • 1.9.11.dev13
    • 1.9.11.dev14
    • 1.9.11.dev15
    • 1.9.11.dev16
    • 1.9.11.dev17
    • 1.9.11.dev3
    • 1.9.11.dev4
    • 1.9.11.dev6
    • 1.9.11.dev7
    • 1.9.11.dev8
    • 1.9.11.dev9
    • 2.0
    • 2.0.1
    • 2.0.2
    • 2.0.3
    • 2.0a1
    • 2.0rc1
    • 2.0rc2
    • 2.1
    • 2.1.1
    • 2.1.10
    • 2.1.11
    • 2.1.2
    • 2.1.3
    • 2.1.4
    • 2.1.5
    • 2.1.6
    • 2.1.7
    • 2.1.8
    • 2.1.9
    • 2.2
    • 2.2.1
    • 2.2.2
    • 2.2.3
    • 2.2.4
    • 2.2.5
    • 2.2.6
    • 2.2.7
    • 2.2.8
    • 2.3
    • 2.3.1
    • 2.3.2
    • 2.3.3
    • 2.3.4
    • 2.3.5
    • 3.0
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.0rc1
    • 3.0rc2
    • 3.1
    • 3.1.1
    • 3.2
    • 3.2.1
    • 3.2.2
    • 3.2.3
    • 3.2.4
    • 3.2.5
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.2.6

    Auf 3.2.6 aktualisieren

  • indico PyPI

    Softwareversionen
    • 0.98-rc1
    • 0.98.0
    • 0.98.1
    • 0.98.2
    • 0.99
    • 1.0
    • 1.1
    • 1.1.1
    • 1.1.2
    • 1.2
    • 1.2.1
    • 1.2.1rc10
    • 1.2.1rc11
    • 1.2.1rc2
    • 1.2.1rc4
    • 1.2.1rc5
    • 1.2.1rc6
    • 1.2.1rc7
    • 1.2.1rc9
    • 1.2.2
    • 1.2.2rc1
    • 1.9.11.dev10
    • 1.9.11.dev11
    • 1.9.11.dev12
    • 1.9.11.dev13
    • 1.9.11.dev14
    • 1.9.11.dev15
    • 1.9.11.dev16
    • 1.9.11.dev17
    • 1.9.11.dev3
    • 1.9.11.dev4
    • 1.9.11.dev6
    • 1.9.11.dev7
    • 1.9.11.dev8
    • 1.9.11.dev9
    • 2.0
    • 2.0.1
    • 2.0.2
    • 2.0.3
    • 2.0a1
    • 2.0rc1
    • 2.0rc2
    • 2.1
    • 2.1.1
    • 2.1.10
    • 2.1.11
    • 2.1.2
    • 2.1.3
    • 2.1.4
    • 2.1.5
    • 2.1.6
    • 2.1.7
    • 2.1.8
    • 2.1.9
    • 2.2
    • 2.2.1
    • 2.2.2
    • 2.2.3
    • 2.2.4
    • 2.2.5
    • 2.2.6
    • 2.2.7
    • 2.2.8
    • 2.3
    • 2.3.1
    • 2.3.2
    • 2.3.3
    • 2.3.4
    • 2.3.5
    • 3.0
    • 3.0.1
    • 3.0.2
    • 3.0.3
    • 3.0rc1
    • 3.0rc2
    • 3.1
    • 3.1.1
    • 3.2
    • 3.2.1
    • 3.2.2
    • 3.2.3
    • 3.2.4
    • 3.2.5
    Betroffene Versionsbereiche
    • GIT: < 2ee636d318653fb1ab193803dafbfe3e371d4130
    • ECOSYSTEM: < 3.2.6

    Auf 3.2.6 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →