p PatchFirst

CVE-2023-39956

CVE-2023-39956 · Electron: Out-of-package code execution when launched with arbitrary cwd

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Electron is a framework which lets you write cross-platform desktop applications using JavaScript, HTML and CSS. Electron apps that are launched as command line executables are impacted. Specifically this issue can only be exploited if the following conditions are met: 1. The app is launched with an attacker-controlled working directory and 2. The attacker has the ability to write files to that working directory. This makes the risk quite low, in fact normally issues of this kind are considered outside of our threat model as similar to Chromium we exclude Physically Local Attacks but given the ability for this issue to bypass certain protections like ASAR Integrity it is being treated with higher importance. This issue has been fixed in versions:`26.0.0-beta.13`, `25.4.1`, `24.7.1`, `23.3.13`, and `22.3.19`. There are no app side workarounds, users must update to a patched version of Electron.

CVSS 6.1 · Mittel · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • electron

    Softwareversionen
    • < 22.3.19: Betroffen
    • >= 23.0.0, < 23.3.13: Betroffen
    • >= 24.0.0, < 24.7.1: Betroffen
    • >= 25.0.0, < 25.4.1: Betroffen
    • >= 26.0.0-beta.1, < 26.0.0-beta.13: Betroffen

    Keine Korrektur veröffentlicht

  • electron npm

    Betroffene Versionsbereiche
    • SEMVER: < 22.3.19

    Auf 22.3.19 aktualisieren

  • electron npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 23.0.0-alpha.1, < 23.3.13

    Auf 23.3.13 aktualisieren

  • electron npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 24.0.0-alpha.1, < 24.7.1

    Auf 24.7.1 aktualisieren

  • electron npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 25.0.0-alpha.1, < 25.5.0

    Auf 25.5.0 aktualisieren

  • electron npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 26.0.0-alpha.1, < 26.0.0-beta.13

    Auf 26.0.0-beta.13 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →