p PatchFirst

CVE-2023-42817

CVE-2023-42817 · Cross-site Scripting (XSS) in pimcore admin-ui-classic-bundle translations

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Pimcore admin-ui-classic-bundle provides a Backend UI for Pimcore. The translation value with text including “%s” (from “%suggest%) is parsed by sprintf() even though it’s supposed to be output literally to the user. The translations may be accessible by a user with comparatively lower overall access (as the translation permission cannot be scoped to certain “modules”) and a skilled attacker might be able to exploit the parsing of the translation string in the dialog box. This issue has been patched in commit `abd77392` which is included in release 1.1.2. Users are advised to update to version 1.1.2 or apply the patch manually.

CVSS 5.4 · Mittel · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: php

Betroffene Produkte und Versionen

  • admin-ui-classic-bundle

    Softwareversionen
    • < 1.1.2: Betroffen

    Keine Korrektur veröffentlicht

  • pimcore/admin-ui-classic-bundle Packagist

    Softwareversionen
    • v1.0.0
    • v1.0.0-BETA1
    • v1.0.0-RC1
    • v1.0.0-RC2
    • v1.0.1
    • v1.0.2
    • v1.0.3
    • v1.0.4
    • v1.0.5
    • v1.0.6
    • v1.1.0
    • v1.1.0-RC1
    • v1.1.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.1.2

    Auf 1.1.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →