CVE-2023-4504
CVE-2023-4504 · OpenPrinting CUPS/libppd Postscript Parsing Heap Overflow
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Due to failure in validating the length provided by an attacker-crafted PPD PostScript document, CUPS and libppd are susceptible to a heap-based buffer overflow and possibly code execution. This issue has been fixed in CUPS version 2.4.7, released in September of 2023.
CVSS 7.0 · Hoch · EPSS 0,6% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
cups
- Softwareversionen
- ≥ 0, < 2.4.6: Betroffen (semver)
Auf 2.4.6 aktualisieren
libppd
- Softwareversionen
- ≥ 0, < d09348b: Betroffen (git)
Keine Korrektur veröffentlicht
cups Debian:12
- Softwareversionen
- 2.4.2-3
- 2.4.2-3+deb12u1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.4.2-3+deb12u2
Auf 2.4.2-3+deb12u2 aktualisieren
cups Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.4.2-6
Auf 2.4.2-6 aktualisieren
cups Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.4.2-6
Auf 2.4.2-6 aktualisieren
cups Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 2.1.0-4ubuntu3
- 2.1.0-5
- 2.1.0-6
- 2.1.0-6ubuntu1
- 2.1.0-7
- 2.1.2-1
- 2.1.2-2
- 2.1.3-1
- 2.1.3-1build1
- 2.1.3-3
- 2.1.3-4
- 2.1.3-4ubuntu0.2
- 2.1.3-4ubuntu0.3
- 2.1.3-4ubuntu0.4
- 2.1.3-4ubuntu0.5
- 2.1.3-4ubuntu0.6
- 2.1.3-4ubuntu0.7
- 2.1.3-4ubuntu0.8
- 2.1.3-4ubuntu0.9
- 2.1.3-4ubuntu0.10
- 2.1.3-4ubuntu0.11
- 2.1.3-4ubuntu0.11+esm1
- 2.1.3-4ubuntu0.11+esm2
- 2.1.3-4ubuntu0.11+esm3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.1.3-4ubuntu0.11+esm4
Auf 2.1.3-4ubuntu0.11+esm4 aktualisieren
libppd Ubuntu:16.04:LTS
- Softwareversionen
- 2:0.10-7.2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
cups Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 2.2.4-7ubuntu2
- 2.2.5-2
- 2.2.6-2
- 2.2.6-3
- 2.2.6-4
- 2.2.6-5
- 2.2.7-1ubuntu1
- 2.2.7-1ubuntu2
- 2.2.7-1ubuntu2.1
- 2.2.7-1ubuntu2.2
- 2.2.7-1ubuntu2.3
- 2.2.7-1ubuntu2.4
- 2.2.7-1ubuntu2.5
- 2.2.7-1ubuntu2.6
- 2.2.7-1ubuntu2.7
- 2.2.7-1ubuntu2.8
- 2.2.7-1ubuntu2.9
- 2.2.7-1ubuntu2.10
- 2.2.7-1ubuntu2.10+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.2.7-1ubuntu2.10+esm2
Auf 2.2.7-1ubuntu2.10+esm2 aktualisieren
libppd Ubuntu:18.04:LTS
- Softwareversionen
- 2:0.10-7.3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
cups Ubuntu:20.04:LTS
- Softwareversionen
- 2.2.12-2ubuntu1
- 2.3.0-6
- 2.3.0-7
- 2.3.0-7ubuntu1
- 2.3.1-1ubuntu1
- 2.3.1-2
- 2.3.1-4
- 2.3.1-7
- 2.3.1-9ubuntu1
- 2.3.1-9ubuntu1.1
- 2.3.1-9ubuntu1.2
- 2.3.1-9ubuntu1.3
- 2.3.1-9ubuntu1.4
- 2.3.1-9ubuntu1.5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.3.1-9ubuntu1.6
Auf 2.3.1-9ubuntu1.6 aktualisieren
libppd Ubuntu:20.04:LTS
- Softwareversionen
- 2:0.10-7.3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
cups Ubuntu:22.04:LTS
- Softwareversionen
- 2.3.3op2-7ubuntu2
- 2.4.1op1-1ubuntu1
- 2.4.1op1-1ubuntu2
- 2.4.1op1-1ubuntu3
- 2.4.1op1-1ubuntu4
- 2.4.1op1-1ubuntu4.1
- 2.4.1op1-1ubuntu4.2
- 2.4.1op1-1ubuntu4.4
- 2.4.1op1-1ubuntu4.6
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.4.1op1-1ubuntu4.7
Auf 2.4.1op1-1ubuntu4.7 aktualisieren
libppd Ubuntu:22.04:LTS
- Softwareversionen
- 2:0.10-7.3
- 2:0.10-8
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://takeonme.org/cves/CVE-2023-4504.html
- https://github.com/OpenPrinting/libppd/security/advisories/GHSA-4f65-6ph5-qwh6
- https://github.com/OpenPrinting/cups/security/advisories/GHSA-pf5r-86w9-678h
- https://github.com/OpenPrinting/cups/releases/tag/v2.4.7
- https://lists.fedoraproject.org/archives/list/[email protected]/message/AMYDKIE4PSJDEMC5OWNFCDMHFGLJ57XG/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/5WVS4I7JG3LISFPKTM6ADKJXXEPEEWBQ/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/5WHEJIYMMAIXU2EC35MGTB5LGGO2FFJE/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/T2GSPQAFK2Z6L57TRXEKZDF42K2EVBH7/
- https://lists.debian.org/debian-lts-announce/2023/09/msg00041.html
- https://lists.fedoraproject.org/archives/list/[email protected]/message/PXPVADB56NMLJWG4IZ3OZBNJ2ZOLPQJ6/
- http://seclists.org/fulldisclosure/2024/Sep/33
- https://nvd.nist.gov/vuln/detail/CVE-2023-4504