CVE-2023-50248
CVE-2023-50248 · CKAN out of memory error when submitting the dataset form with a specially-crafted field
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
CKAN is an open-source data management system for powering data hubs and data portals. Starting in version 2.0.0 and prior to versions 2.9.10 and 2.10.3, when submitting a POST request to the `/dataset/new` endpoint (including either the auth cookie or the `Authorization` header) with a specially-crafted field, an attacker can create an out-of-memory error in the hosting server. To trigger this error, the attacker need to have permissions to create or edit datasets. This vulnerability has been patched in CKAN 2.10.3 and 2.9.10.
CVSS 4.5 · Mittel · EPSS 0,6% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: python
Betroffene Produkte und Versionen
ckan
- Softwareversionen
- >= 2.0.0, < 2.9.10: Betroffen
- >= 2.10.0, < 2.10.3: Betroffen
Keine Korrektur veröffentlicht
ckan PyPI
- Softwareversionen
- 2.0
- 2.0.1
- 2.0.7
- 2.0.8
- 2.1
- 2.1.1
- 2.1.5
- 2.1.6
- 2.2
- 2.2.1
- 2.2.3
- 2.2.4
- 2.3
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.3.5
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.4.5
- 2.4.8
- 2.4.9
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.5.4
- 2.5.6
- 2.5.7
- 2.5.8
- 2.5.9
- 2.6.0
- 2.6.1
- 2.6.3
- 2.6.4
- 2.6.5
- 2.6.6
- 2.6.7
- 2.6.8
- 2.6.9
- 2.7.0
- 2.7.1
- 2.7.10
- 2.7.11
- 2.7.12
- 2.7.2
- 2.7.3
- 2.7.4
- 2.7.5
- 2.7.6
- 2.7.7
- 2.7.8
- 2.7.9
- 2.8.0
- 2.8.1
- 2.8.10
- 2.8.11
- 2.8.12
- 2.8.2
- 2.8.3
- 2.8.4
- 2.8.5
- 2.8.6
- 2.8.7
- 2.8.8
- 2.8.9
- 2.9.0
- 2.9.1
- 2.9.2
- 2.9.3
- 2.9.4
- 2.9.5
- 2.9.6
- 2.9.7
- 2.9.8
- 2.9.9
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.0, < 2.9.10
Auf 2.9.10 aktualisieren
ckan PyPI
- Softwareversionen
- 2.10.0
- 2.10.1
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.10.0, < 2.10.3
Auf 2.10.3 aktualisieren
ckan PyPI
- Softwareversionen
- 2.0
- 2.0.1
- 2.0.7
- 2.0.8
- 2.1
- 2.1.1
- 2.1.5
- 2.1.6
- 2.10.0
- 2.10.1
- 2.2
- 2.2.1
- 2.2.3
- 2.2.4
- 2.3
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.3.5
- 2.4.0
- 2.4.1
- 2.4.2
- 2.4.3
- 2.4.4
- 2.4.5
- 2.4.8
- 2.4.9
- 2.5.0
- 2.5.1
- 2.5.2
- 2.5.3
- 2.5.4
- 2.5.6
- 2.5.7
- 2.5.8
- 2.5.9
- 2.6.0
- 2.6.1
- 2.6.3
- 2.6.4
- 2.6.5
- 2.6.6
- 2.6.7
- 2.6.8
- 2.6.9
- 2.7.0
- 2.7.1
- 2.7.10
- 2.7.11
- 2.7.12
- 2.7.2
- 2.7.3
- 2.7.4
- 2.7.5
- 2.7.6
- 2.7.7
- 2.7.8
- 2.7.9
- 2.8.0
- 2.8.1
- 2.8.10
- 2.8.11
- 2.8.12
- 2.8.2
- 2.8.3
- 2.8.4
- 2.8.5
- 2.8.6
- 2.8.7
- 2.8.8
- 2.8.9
- 2.9.0
- 2.9.1
- 2.9.2
- 2.9.3
- 2.9.4
- 2.9.5
- 2.9.6
- 2.9.7
- 2.9.8
- 2.9.9
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 2.0, < 2.9.10 ∪ ≥ 2.10.0, < 2.10.3
Auf 2.9.10 aktualisieren; Auf 2.10.3 aktualisieren