CVE-2024-12243
CVE-2024-12243 · Gnutls: gnutls impacted by inefficient der decoding in libtasn1 leading to remote dos
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
A flaw was found in GnuTLS, which relies on libtasn1 for ASN.1 data processing. Due to an inefficient algorithm in libtasn1, decoding certain DER-encoded certificate data can take excessive time, leading to increased resource consumption. This flaw allows a remote attacker to send a specially crafted certificate, causing GnuTLS to become unresponsive or slow, resulting in a denial-of-service condition.
CVSS 5.3 · Mittel · EPSS 1,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
red hat enterprise linux 8
- Softwareversionen
- ≥ 0:3.6.16-8.el8_10.3: Nicht betroffen (rpm)
Keine Korrektur veröffentlicht
red hat enterprise linux 9
- Softwareversionen
- ≥ 0:3.8.3-6.el9: Nicht betroffen (rpm)
Keine Korrektur veröffentlicht
red hat enterprise linux 9.2 update services for sap solutions
- Softwareversionen
- ≥ 0:3.7.6-21.el9_2.4: Nicht betroffen (rpm)
Keine Korrektur veröffentlicht
red hat enterprise linux 9.4 extended update support
- Softwareversionen
- ≥ 0:3.8.3-4.el9_4.2: Nicht betroffen (rpm)
Keine Korrektur veröffentlicht
red hat discovery 1.14
- Softwareversionen
- ≥ 1.14.3-1748529279: Nicht betroffen (rpm)
Keine Korrektur veröffentlicht
red hat discovery 1.14
- Softwareversionen
- ≥ 1.14.2-1748467619: Nicht betroffen (rpm)
Keine Korrektur veröffentlicht
red hat enterprise linux 10
Keine Korrektur veröffentlicht
red hat enterprise linux 6
Keine Korrektur veröffentlicht
red hat enterprise linux 7
Keine Korrektur veröffentlicht
red hat openshift container platform 4
Keine Korrektur veröffentlicht
gnutls28 Debian:12
- Softwareversionen
- 3.7.9-2
- 3.7.9-2+deb12u1
- 3.7.9-2+deb12u2
- 3.7.9-2+deb12u3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.7.9-2+deb12u4
Auf 3.7.9-2+deb12u4 aktualisieren
gnutls28 Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.8.9-2
Auf 3.8.9-2 aktualisieren
gnutls28 Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.8.9-2
Auf 3.8.9-2 aktualisieren
gnutls28 Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 3.5.8-6ubuntu3
- 3.5.17-1ubuntu1
- 3.5.17-1ubuntu3
- 3.5.18-1ubuntu1
- 3.5.18-1ubuntu1.1
- 3.5.18-1ubuntu1.2
- 3.5.18-1ubuntu1.3
- 3.5.18-1ubuntu1.4
- 3.5.18-1ubuntu1.5
- 3.5.18-1ubuntu1.6
- 3.5.18-1ubuntu1.6+esm1
- 3.5.18-1ubuntu1.6+esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.5.18-1ubuntu1.6+esm3
Auf 3.5.18-1ubuntu1.6+esm3 aktualisieren
gnutls28 Ubuntu:20.04:LTS
- Softwareversionen
- 3.6.9-5ubuntu1
- 3.6.9-5ubuntu2
- 3.6.10-5
- 3.6.11.1-2
- 3.6.11.1-2ubuntu2
- 3.6.13-2ubuntu1
- 3.6.13-2ubuntu1.1
- 3.6.13-2ubuntu1.2
- 3.6.13-2ubuntu1.3
- 3.6.13-2ubuntu1.6
- 3.6.13-2ubuntu1.7
- 3.6.13-2ubuntu1.8
- 3.6.13-2ubuntu1.9
- 3.6.13-2ubuntu1.10
- 3.6.13-2ubuntu1.11
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.6.13-2ubuntu1.12
Auf 3.6.13-2ubuntu1.12 aktualisieren
gnutls28 Ubuntu:22.04:LTS
- Softwareversionen
- 3.7.1-5ubuntu1
- 3.7.2-2ubuntu1
- 3.7.2-4ubuntu1
- 3.7.2-5ubuntu1
- 3.7.3-4ubuntu1
- 3.7.3-4ubuntu1.1
- 3.7.3-4ubuntu1.2
- 3.7.3-4ubuntu1.3
- 3.7.3-4ubuntu1.4
- 3.7.3-4ubuntu1.5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.7.3-4ubuntu1.6
Auf 3.7.3-4ubuntu1.6 aktualisieren
gnutls28 Ubuntu:Pro:FIPS-preview:22.04:LTS
- Softwareversionen
- 3.7.3-4ubuntu1.2+Fips1.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
gnutls28 Ubuntu:Pro:FIPS-updates:22.04:LTS
- Softwareversionen
- 3.7.3-4ubuntu1.2+Fips1.1
- 3.7.3-4ubuntu1.3+Fips1.1
- 3.7.3-4ubuntu1.4+Fips1
- 3.7.3-4ubuntu1.5+Fips1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.7.3-4ubuntu1.6+Fips1
Auf 3.7.3-4ubuntu1.6+Fips1 aktualisieren
gnutls28 Ubuntu:24.04:LTS
- Softwareversionen
- 3.8.1-4ubuntu1
- 3.8.1-4ubuntu6
- 3.8.1-4ubuntu7
- 3.8.3-1ubuntu1
- 3.8.3-1.1ubuntu2
- 3.8.3-1.1ubuntu3
- 3.8.3-1.1ubuntu3.1
- 3.8.3-1.1ubuntu3.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.8.3-1.1ubuntu3.3
Auf 3.8.3-1.1ubuntu3.3 aktualisieren
gnutls28 Ubuntu:Pro:FIPS-updates:24.04:LTS
- Softwareversionen
- 3.8.3-1.1ubuntu3.1+Fips1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.8.3-1.1ubuntu3.4+Fips1
Auf 3.8.3-1.1ubuntu3.4+Fips1 aktualisieren
Originalquellen
- https://access.redhat.com/errata/RHSA-2025:17361
- https://access.redhat.com/errata/RHSA-2025:4051
- https://access.redhat.com/errata/RHSA-2025:7076
- https://access.redhat.com/errata/RHSA-2025:8020
- https://access.redhat.com/errata/RHSA-2025:8385
- https://access.redhat.com/security/cve/CVE-2024-12243
- https://bugzilla.redhat.com/show_bug.cgi?id=2344615
- https://gitlab.com/gnutls/gnutls/-/issues/1553
- https://gitlab.com/gnutls/libtasn1/-/issues/52
- https://lists.debian.org/debian-lts-announce/2025/02/msg00027.html
- https://security.netapp.com/advisory/ntap-20250523-0002/
- https://cert-portal.siemens.com/productcert/html/ssa-082556.html
- https://cert-portal.siemens.com/productcert/html/ssa-202008.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-12243