p PatchFirst

CVE-2024-23653

CVE-2024-23653 · BuildKit interactive containers API does not validate entitlements check

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

BuildKit is a toolkit for converting source code to build artifacts in an efficient, expressive and repeatable manner. In addition to running containers as build steps, BuildKit also provides APIs for running interactive containers based on built images. It was possible to use these APIs to ask BuildKit to run a container with elevated privileges. Normally, running such containers is only allowed if special `security.insecure` entitlement is enabled both by buildkitd configuration and allowed by the user initializing the build request. The issue has been fixed in v0.12.5 . Avoid using BuildKit frontends from untrusted sources.

CVSS 9.8 · Kritisch · EPSS 3,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • buildkit

    Softwareversionen
    • < 0.12.5: Betroffen

    Keine Korrektur veröffentlicht

  • docker.io Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 1.13.1-0ubuntu6
    • 17.03.2-0ubuntu1
    • 17.03.2-0ubuntu3
    • 17.03.2-0ubuntu5
    • 17.12.1-0ubuntu1
    • 18.06.1-0ubuntu1~18.04.1
    • 18.06.1-0ubuntu1.2~18.04.1
    • 18.09.2-0ubuntu1~18.04.1
    • 18.09.5-0ubuntu1~18.04.2
    • 18.09.7-0ubuntu1~18.04.1
    • 18.09.7-0ubuntu1~18.04.3
    • 18.09.7-0ubuntu1~18.04.4
    • 19.03.6-0ubuntu1~18.04.1
    • 19.03.6-0ubuntu1~18.04.2
    • 19.03.6-0ubuntu1~18.04.3
    • 20.10.2-0ubuntu1~18.04.2
    • 20.10.2-0ubuntu1~18.04.3
    • 20.10.7-0ubuntu1~18.04.1
    • 20.10.7-0ubuntu1~18.04.2
    • 20.10.7-0ubuntu5~18.04.2
    • 20.10.7-0ubuntu5~18.04.3
    • 20.10.12-0ubuntu2~18.04.1
    • 20.10.21-0ubuntu1~18.04.2
    • 20.10.21-0ubuntu1~18.04.3
    • 20.10.21-0ubuntu1~18.04.3+esm1
    • 20.10.21-0ubuntu1~18.04.3+esm2
    • 20.10.21-0ubuntu1~18.04.3+esm3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • docker.io Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 19.03.2-0ubuntu1
    • 19.03.6-0ubuntu1
    • 19.03.8-0ubuntu1
    • 19.03.8-0ubuntu1.20.04
    • 19.03.8-0ubuntu1.20.04.1
    • 19.03.8-0ubuntu1.20.04.2
    • 20.10.2-0ubuntu1~20.04.2
    • 20.10.2-0ubuntu1~20.04.3
    • 20.10.7-0ubuntu1~20.04.1
    • 20.10.7-0ubuntu1~20.04.2
    • 20.10.7-0ubuntu5~20.04.1
    • 20.10.7-0ubuntu5~20.04.2
    • 20.10.12-0ubuntu2~20.04.1
    • 20.10.21-0ubuntu1~20.04.1
    • 20.10.21-0ubuntu1~20.04.2
    • 20.10.21-0ubuntu1~20.04.4
    • 20.10.21-0ubuntu1~20.04.5
    • 20.10.21-0ubuntu1~20.04.6
    • 20.10.21-0ubuntu1~20.04.6+esm1
    • 20.10.21-0ubuntu1~20.04.6+esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • docker.io-app Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 20.10.25-0ubuntu1~20.04.1
    • 20.10.25-0ubuntu1~20.04.2
    • 24.0.5-0ubuntu1~20.04.1
    • 24.0.7-0ubuntu2~20.04.1
    • 26.1.3-0ubuntu1~20.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 26.1.3-0ubuntu1~20.04.1+esm1

    Auf 26.1.3-0ubuntu1~20.04.1+esm1 aktualisieren

  • docker.io-app Ubuntu:22.04:LTS

    Softwareversionen
    • 20.10.25-0ubuntu1~22.04.1
    • 20.10.25-0ubuntu1~22.04.2
    • 24.0.5-0ubuntu1~22.04.1
    • 24.0.7-0ubuntu2~22.04.1
    • 26.1.3-0ubuntu1~22.04.1
    • 27.5.1-0ubuntu3~22.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 27.5.1-0ubuntu3~22.04.2

    Auf 27.5.1-0ubuntu3~22.04.2 aktualisieren

  • docker.io Ubuntu:Pro:22.04:LTS

    Softwareversionen
    • 20.10.7-0ubuntu5
    • 20.10.7-0ubuntu7
    • 20.10.12-0ubuntu1
    • 20.10.12-0ubuntu2
    • 20.10.12-0ubuntu3
    • 20.10.12-0ubuntu3+gke1.24.1
    • 20.10.12-0ubuntu4
    • 20.10.21-0ubuntu1~22.04.2
    • 20.10.21-0ubuntu1~22.04.3
    • 20.10.21-0ubuntu1~22.04.5
    • 20.10.21-0ubuntu1~22.04.6
    • 20.10.21-0ubuntu1~22.04.7
    • 20.10.21-0ubuntu1~22.04.7+esm1
    • 20.10.21-0ubuntu1~22.04.7+esm2
    • 20.10.21-0ubuntu1~22.04.8
    • 20.10.21-0ubuntu1~22.04.8+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • docker.io-app Ubuntu:24.04:LTS

    Softwareversionen
    • 24.0.5-0ubuntu1
    • 24.0.7-0ubuntu1
    • 24.0.7-0ubuntu2
    • 24.0.7-0ubuntu3
    • 24.0.7-0ubuntu4
    • 24.0.7-0ubuntu4.1
    • 26.1.3-0ubuntu1~24.04.1
    • 27.5.1-0ubuntu3~24.04.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 27.5.1-0ubuntu3~24.04.2

    Auf 27.5.1-0ubuntu3~24.04.2 aktualisieren

  • docker.io Ubuntu:Pro:24.04:LTS

    Softwareversionen
    • 20.10.24+dfsg1-1ubuntu2
    • 20.10.25+dfsg1-2ubuntu1
    • 20.10.25+dfsg1-2ubuntu1+esm1
    • 20.10.25+dfsg1-2ubuntu1+esm2
    • 20.10.25+dfsg1-2ubuntu1.24.04.1
    • 20.10.25+dfsg1-2ubuntu1.24.04.1+esm1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →