p PatchFirst

CVE-2024-24758

CVE-2024-24758 · Proxy-Authorization header not cleared on cross-origin redirect in fetch in Undici

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Undici is an HTTP/1.1 client, written from scratch for Node.js. Undici already cleared Authorization headers on cross-origin redirects, but did not clear `Proxy-Authentication` headers. This issue has been patched in versions 5.28.3 and 6.6.1. Users are advised to upgrade. There are no known workarounds for this vulnerability.

CVSS 3.9 · Niedrig · EPSS 0,8% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · node

Betroffene Produkte und Versionen

  • undici

    Softwareversionen
    • < 5.28.3: Betroffen
    • >= 6.0.0, < 6.6.1: Betroffen

    Keine Korrektur veröffentlicht

  • node-undici Debian:12

    Softwareversionen
    • 5.15.0+dfsg1+~cs20.10.9.3-1
    • 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u1
    • 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u2
    • 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u3
    • 5.15.0+dfsg1+~cs20.10.9.3-1+deb12u4
    • 5.19.1+dfsg1+~cs20.10.9.5-1
    • 5.19.1+dfsg1+~cs20.10.9.5-2
    • 5.22.1+dfsg1+~cs20.10.10.2-1
    • 5.26.3+dfsg1+~cs23.10.12-1
    • 5.26.3+dfsg1+~cs23.10.12-2
    • 5.26.3+dfsg1+~cs23.10.12-3
    • 5.28.0+dfsg1+~cs23.11.12.3-1
    • 5.28.0+dfsg1+~cs23.11.12.3-2
    • 5.28.2+dfsg1+~cs23.11.12.3-1
    • 5.28.2+dfsg1+~cs23.11.12.3-2
    • 5.28.2+dfsg1+~cs23.11.12.3-3
    • 5.28.2+dfsg1+~cs23.11.12.3-4
    • 5.28.2+dfsg1+~cs23.11.12.3-5
    • 5.28.2+dfsg1+~cs23.11.12.3-6
    • 5.28.4+dfsg1+~cs23.12.11-1
    • 5.28.4+dfsg1+~cs23.12.11-2
    • 7.1.0+dfsg1+~cs24.12.10-1
    • 7.15.0+dfsg+~cs3.2.0-1
    • 7.15.0+dfsg+~cs3.2.0-3
    • 7.16.0+dfsg+~cs3.2.0-1
    • 7.16.0+dfsg+~cs3.2.0-2
    • 7.18.2+dfsg+~cs3.2.0-1
    • 7.2.3+dfsg1+~cs24.12.11-1
    • 7.2.3+dfsg1+~cs24.12.11-2
    • 7.24.5+dfsg+~cs3.2.0-1
    • 7.24.6+dfsg+~cs3.2.0-1
    • 7.24.6+dfsg+~cs3.2.0-2
    • 7.24.6+dfsg+~cs3.2.0-3
    • 7.3.0+dfsg1+~cs24.12.11-1
    • 7.3.0+dfsg1+~cs24.12.11-2
    • 8.10.2+dfsg+~cs3.2.2-1
    • 8.5.0+dfsg+~cs3.2.0-1
    • 8.5.0+dfsg+~cs3.2.0-2
    • 8.5.0+dfsg+~cs3.2.0-3
    • 8.9.0+dfsg+~cs3.2.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-undici Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.28.4+dfsg1+~cs23.12.11-1

    Auf 5.28.4+dfsg1+~cs23.12.11-1 aktualisieren

  • node-undici Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 5.28.4+dfsg1+~cs23.12.11-1

    Auf 5.28.4+dfsg1+~cs23.12.11-1 aktualisieren

  • undici npm

    Betroffene Versionsbereiche
    • SEMVER: < 5.28.3

    Auf 5.28.3 aktualisieren

  • undici npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 6.0.0, < 6.6.1

    Auf 6.6.1 aktualisieren

  • node-undici Ubuntu:24.04:LTS

    Softwareversionen
    • 5.22.1+dfsg1+~cs20.10.10.2-1ubuntu1
    • 5.26.3+dfsg1+~cs23.10.12-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-undici Ubuntu:25.10

    Softwareversionen
    • 7.3.0+dfsg1+~cs24.12.11-1
    • 7.3.0+dfsg1+~cs24.12.11-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-undici Ubuntu:26.10

    Softwareversionen
    • 7.18.2+dfsg+~cs3.2.0-1build1
    • 7.24.6+dfsg+~cs3.2.0-3
    • 8.5.0+dfsg+~cs3.2.0-2
    • 8.5.0+dfsg+~cs3.2.0-3
    • 8.9.0+dfsg+~cs3.2.0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • node-undici Ubuntu:26.04:LTS

    Softwareversionen
    • 7.3.0+dfsg1+~cs24.12.11-2
    • 7.16.0+dfsg+~cs3.2.0-2
    • 7.18.2+dfsg+~cs3.2.0-1
    • 7.18.2+dfsg+~cs3.2.0-1build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →