CVE-2024-27281
CVE-2024-27281
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
An issue was discovered in RDoc 6.3.3 through 6.6.2, as distributed in Ruby 3.x through 3.3.0. When parsing .rdoc_options (used for configuration in RDoc) as a YAML file, object injection and resultant remote code execution are possible because there are no restrictions on the classes that can be restored. (When loading the documentation cache, object injection and resultant remote code execution are also possible if there were a crafted cache.) The main fixed version is 6.6.3.1. For Ruby 3.0 users, a fixed version is rdoc 6.3.4.1. For Ruby 3.1 users, a fixed version is rdoc 6.4.1.1. For Ruby 3.2 users, a fixed version is rdoc 6.5.1.1.
CVSS 4.5 · Mittel · EPSS 1,6% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
n/a
- Softwareversionen
- n/a: Betroffen
Keine Korrektur veröffentlicht
ruby3.1 Debian:12
- Softwareversionen
- 3.1.2-7
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.1.2-7+deb12u1
Auf 3.1.2-7+deb12u1 aktualisieren
jruby Ubuntu:Pro:14.04:LTS
- Softwareversionen
- 1.5.6-5ubuntu1
- 1.5.6-6
- 1.5.6-7
- 1.5.6-9+deb8u2build0.14.04.1~esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby2.3 Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 2.3.0-1
- 2.3.0-2
- 2.3.0-4ubuntu2
- 2.3.0-4ubuntu3
- 2.3.0-5ubuntu1
- 2.3.1-2~16.04
- 2.3.1-2~16.04.2
- 2.3.1-2~16.04.4
- 2.3.1-2~16.04.5
- 2.3.1-2~16.04.6
- 2.3.1-2~16.04.7
- 2.3.1-2~16.04.9
- 2.3.1-2~16.04.10
- 2.3.1-2~16.04.11
- 2.3.1-2~16.04.12
- 2.3.1-2~ubuntu16.04.13
- 2.3.1-2~ubuntu16.04.14
- 2.3.1-2~ubuntu16.04.15
- 2.3.1-2~ubuntu16.04.16
- 2.3.1-2~ubuntu16.04.16+esm1
- 2.3.1-2~ubuntu16.04.16+esm2
- 2.3.1-2~ubuntu16.04.16+esm3
- 2.3.1-2~ubuntu16.04.16+esm4
- 2.3.1-2~ubuntu16.04.16+esm5
- 2.3.1-2~ubuntu16.04.16+esm6
- 2.3.1-2~ubuntu16.04.16+esm7
- 2.3.1-2~ubuntu16.04.16+esm8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.3.1-2~ubuntu16.04.16+esm9
Auf 2.3.1-2~ubuntu16.04.16+esm9 aktualisieren
jruby Ubuntu:16.04:LTS
- Softwareversionen
- 1.7.21-2ubuntu4
- 1.7.22-1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby2.5 Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 2.5.0~preview1-1ubuntu2
- 2.5.0-4ubuntu1
- 2.5.0-4ubuntu4
- 2.5.0-5ubuntu1
- 2.5.0-6ubuntu1
- 2.5.1-1ubuntu1
- 2.5.1-1ubuntu1.1
- 2.5.1-1ubuntu1.2
- 2.5.1-1ubuntu1.4
- 2.5.1-1ubuntu1.5
- 2.5.1-1ubuntu1.6
- 2.5.1-1ubuntu1.7
- 2.5.1-1ubuntu1.8
- 2.5.1-1ubuntu1.9
- 2.5.1-1ubuntu1.10
- 2.5.1-1ubuntu1.11
- 2.5.1-1ubuntu1.12
- 2.5.1-1ubuntu1.13
- 2.5.1-1ubuntu1.14
- 2.5.1-1ubuntu1.15
- 2.5.1-1ubuntu1.16
- 2.5.1-1ubuntu1.16+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.5.1-1ubuntu1.16+esm3
Auf 2.5.1-1ubuntu1.16+esm3 aktualisieren
jruby Ubuntu:18.04:LTS
- Softwareversionen
- 9.1.13.0-1
- 9.1.17.0-1~18.04
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby2.7 Ubuntu:20.04:LTS
- Softwareversionen
- 2.7.0-1
- 2.7.0-2
- 2.7.0-3
- 2.7.0-4
- 2.7.0-4ubuntu1
- 2.7.0-5ubuntu1
- 2.7.0-5ubuntu1.1
- 2.7.0-5ubuntu1.2
- 2.7.0-5ubuntu1.3
- 2.7.0-5ubuntu1.4
- 2.7.0-5ubuntu1.5
- 2.7.0-5ubuntu1.6
- 2.7.0-5ubuntu1.7
- 2.7.0-5ubuntu1.8
- 2.7.0-5ubuntu1.9
- 2.7.0-5ubuntu1.10
- 2.7.0-5ubuntu1.11
- 2.7.0-5ubuntu1.12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.7.0-5ubuntu1.13
Auf 2.7.0-5ubuntu1.13 aktualisieren
jruby Ubuntu:20.04:LTS
- Softwareversionen
- 9.1.17.0-3
- 9.1.17.0-3build5
- 9.1.17.0-3build6
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby3.0 Ubuntu:22.04:LTS
- Softwareversionen
- 3.0.2-5ubuntu1
- 3.0.2-7
- 3.0.2-7ubuntu2
- 3.0.2-7ubuntu2.1
- 3.0.2-7ubuntu2.2
- 3.0.2-7ubuntu2.3
- 3.0.2-7ubuntu2.4
- 3.0.2-7ubuntu2.5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.0.2-7ubuntu2.6
Auf 3.0.2-7ubuntu2.6 aktualisieren
jruby Ubuntu:24.04:LTS
- Softwareversionen
- 9.3.9.0+ds-1
- 9.4.5.0+ds-1
- 9.4.5.0+ds-1ubuntu1
- 9.4.6.0+ds-1ubuntu3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
ruby3.2 Ubuntu:24.04:LTS
- Softwareversionen
- 3.2.3-1
- 3.2.3-1build2
- 3.2.3-1build3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.2.3-1ubuntu0.24.04.1
Auf 3.2.3-1ubuntu0.24.04.1 aktualisieren
jruby Ubuntu:25.10
- Softwareversionen
- 9.4.8.0+ds-2ubuntu1
- 9.4.8.0+ds-3ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jruby Ubuntu:26.10
- Softwareversionen
- 9.4.8.0+ds-3ubuntu1
- 9.4.14.0+ds-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
jruby Ubuntu:26.04:LTS
- Softwareversionen
- 9.4.8.0+ds-3ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://hackerone.com/reports/1187477
- https://www.ruby-lang.org/en/news/2024/03/21/rce-rdoc-cve-2024-27281/
- https://lists.debian.org/debian-lts-announce/2024/09/msg00000.html
- https://lists.fedoraproject.org/archives/list/[email protected]/message/27LUWREIFTP3MQAW7QE4PJM4DPAQJWXF/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/XYDHPHEZI7OQXTQKTDZHGZNPIJH7ZV5N/
- https://nvd.nist.gov/vuln/detail/CVE-2024-27281