CVE-2024-27306
CVE-2024-27306 · aiohttp vulnerable to XSS on index pages for static file handling
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
aiohttp is an asynchronous HTTP client/server framework for asyncio and Python. A XSS vulnerability exists on index pages for static file handling. This vulnerability is fixed in 3.9.4. We have always recommended using a reverse proxy server (e.g. nginx) for serving static files. Users following the recommendation are unaffected. Other users can disable `show_index` if unable to upgrade.
CVSS 6.1 · Mittel · EPSS 0,7% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
aiohttp
- Softwareversionen
- < 3.9.4: Betroffen
Keine Korrektur veröffentlicht
python-aiohttp Debian:12
- Softwareversionen
- 3.10.0-1
- 3.10.1-1
- 3.10.10-1
- 3.10.10-2
- 3.10.11-1
- 3.10.3-1
- 3.10.3-2
- 3.10.3-3
- 3.10.4-1
- 3.10.5-1
- 3.10.6-1
- 3.10.8-1
- 3.11.15-1
- 3.11.16-1
- 3.12.15-1
- 3.13.0-1
- 3.13.1-1
- 3.13.3-1
- 3.13.3-2
- 3.13.3-3
- 3.13.5-1
- 3.14.0-1
- 3.14.1-1
- 3.14.1-2
- 3.14.1-3
- 3.14.1-4
- 3.14.1-5
- 3.14.3-1
- 3.8.4-1
- 3.8.4-1+deb12u1
- 3.8.5-1
- 3.8.6-1
- 3.9.1-1
- 3.9.5-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-aiohttp Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.9.5-1
Auf 3.9.5-1 aktualisieren
python-aiohttp Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.9.5-1
Auf 3.9.5-1 aktualisieren
aiohttp PyPI
- Softwareversionen
- 0.1
- 0.10.0
- 0.10.1
- 0.10.2
- 0.11.0
- 0.12.0
- 0.13.0
- 0.13.1
- 0.14.0
- 0.14.1
- 0.14.2
- 0.14.3
- 0.14.4
- 0.15.0
- 0.15.1
- 0.15.2
- 0.15.3
- 0.16.0
- 0.16.1
- 0.16.2
- 0.16.3
- 0.16.4
- 0.16.5
- 0.16.6
- 0.17.0
- 0.17.1
- 0.17.2
- 0.17.3
- 0.17.4
- 0.18.0
- 0.18.1
- 0.18.2
- 0.18.3
- 0.18.4
- 0.19.0
- 0.2
- 0.20.0
- 0.20.1
- 0.20.2
- 0.21.0
- 0.21.1
- 0.21.2
- 0.21.4
- 0.21.5
- 0.21.6
- 0.22.0
- 0.22.0a0
- 0.22.0b0
- 0.22.0b1
- 0.22.0b2
- 0.22.0b3
- 0.22.0b4
- 0.22.0b5
- 0.22.0b6
- 0.22.1
- 0.22.2
- 0.22.3
- 0.22.4
- 0.22.5
- 0.3
- 0.4
- 0.4.1
- 0.4.2
- 0.4.3
- 0.4.4
- 0.5.0
- 0.6.0
- 0.6.1
- 0.6.2
- 0.6.3
- 0.6.4
- 0.6.5
- 0.7.0
- 0.7.1
- 0.7.2
- 0.7.3
- 0.8.0
- 0.8.1
- 0.8.2
- 0.8.3
- 0.8.4
- 0.9.0
- 0.9.1
- 0.9.2
- 0.9.3
- 1.0.0
- 1.0.1
- 1.0.2
- 1.0.3
- 1.0.5
- 1.1.0
- 1.1.1
- 1.1.2
- 1.1.3
- 1.1.4
- 1.1.5
- 1.1.6
- 1.2.0
- 1.3.0
- 1.3.1
- 1.3.2
- 1.3.3
- 1.3.4
- 1.3.5
- 2.0.0
- 2.0.0rc1
- 2.0.1
- 2.0.2
- 2.0.3
- 2.0.4
- 2.0.5
- 2.0.6
- 2.0.7
- 2.1.0
- 2.2.0
- 2.2.1
- 2.2.2
- 2.2.3
- 2.2.4
- 2.2.5
- 2.3.0
- 2.3.0a1
- 2.3.0a2
- 2.3.0a3
- 2.3.0a4
- 2.3.1
- 2.3.10
- 2.3.1a1
- 2.3.2
- 2.3.2b2
- 2.3.2b3
- 2.3.3
- 2.3.4
- 2.3.5
- 2.3.6
- 2.3.7
- 2.3.8
- 2.3.9
- 3.0.0
- 3.0.0b0
- 3.0.0b1
- 3.0.0b2
- 3.0.0b3
- 3.0.0b4
- 3.0.1
- 3.0.2
- 3.0.3
- 3.0.4
- 3.0.5
- 3.0.6
- 3.0.7
- 3.0.8
- 3.0.9
- 3.1.0
- 3.1.1
- 3.1.2
- 3.1.3
- 3.2.0
- 3.2.1
- 3.3.0
- 3.3.0a0
- 3.3.1
- 3.3.2
- 3.3.2a0
- 3.4.0
- 3.4.0a0
- 3.4.0a3
- 3.4.0b1
- 3.4.0b2
- 3.4.1
- 3.4.2
- 3.4.3
- 3.4.4
- 3.5.0
- 3.5.0a1
- 3.5.0b1
- 3.5.0b2
- 3.5.0b3
- 3.5.1
- 3.5.2
- 3.5.3
- 3.5.4
- 3.6.0
- 3.6.0a0
- 3.6.0a1
- 3.6.0a11
- 3.6.0a12
- 3.6.0a2
- 3.6.0a3
- 3.6.0a4
- 3.6.0a5
- 3.6.0a6
- 3.6.0a7
- 3.6.0a8
- 3.6.0a9
- 3.6.0b0
- 3.6.1
- 3.6.1b3
- 3.6.1b4
- 3.6.2
- 3.6.2a0
- 3.6.2a1
- 3.6.2a2
- 3.6.3
- 3.7.0
- 3.7.0b0
- 3.7.0b1
- 3.7.1
- 3.7.2
- 3.7.3
- 3.7.4
- 3.7.4.post0
- 3.8.0
- 3.8.0a7
- 3.8.0b0
- 3.8.1
- 3.8.2
- 3.8.3
- 3.8.4
- 3.8.5
- 3.8.6
- 3.9.0
- 3.9.0b0
- 3.9.0b1
- 3.9.0rc0
- 3.9.1
- 3.9.2
- 3.9.3
- 3.9.4rc0
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.9.4
Auf 3.9.4 aktualisieren
python-aiohttp Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 2.2.3-1build1
- 2.2.3-2
- 2.3.6-1
- 3.0.1-1
- 3.0.1-1ubuntu0.1~esm1
- 3.0.1-1ubuntu0.1~esm4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.0.1-1ubuntu0.1~esm5
Auf 3.0.1-1ubuntu0.1~esm5 aktualisieren
python-aiohttp Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 3.7.4-1
- 3.7.4-1build2
- 3.8.1-3
- 3.8.1-4
- 3.8.1-4build1
- 3.8.1-4ubuntu0.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.8.1-4ubuntu0.2+esm1
Auf 3.8.1-4ubuntu0.2+esm1 aktualisieren
python-aiohttp Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 3.8.4-1
- 3.9.1-1
- 3.9.1-1build1
- 3.9.1-1ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.9.1-1ubuntu0.1+esm1
Auf 3.9.1-1ubuntu0.1+esm1 aktualisieren
Originalquellen
- https://github.com/aio-libs/aiohttp/security/advisories/GHSA-7gpw-8wmc-pm8g
- https://github.com/aio-libs/aiohttp/pull/8319
- https://github.com/aio-libs/aiohttp/commit/28335525d1eac015a7e7584137678cbb6ff19397
- https://lists.fedoraproject.org/archives/list/[email protected]/message/2EXRGTN2WG7VZLUZ7WOXU5GQJKCPPHKP/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/NWEI6NIHZ3G7DURDZVMRK7ZEFC2BTD3U/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/ZIVBMPEY7WWOFMC3CWXFBRQPFECV4SW3/
- https://lists.debian.org/debian-lts-announce/2025/02/msg00002.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-27306