p PatchFirst

CVE-2024-27915

CVE-2024-27915 · Sulu grants access to pages regardless of role permissions

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Sulu is a PHP content management system. Starting in verson 2.2.0 and prior to version 2.4.17 and 2.5.13, access to pages is granted regardless of role permissions for webspaces which have a security system configured and permission check enabled. Webspaces without do not have this issue. The problem is patched in versions 2.4.17 and 2.5.13. Some workarounds are available. One may apply the patch to `vendor/symfony/security-http/HttpUtils.php` manually or avoid installing `symfony/security-http` versions greater equal than `v5.4.30` or `v6.3.6`.

CVSS 6.8 · Mittel · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: php

Betroffene Produkte und Versionen

  • sulu

    Softwareversionen
    • >= 2.2.0, < 2.4.17: Betroffen
    • >= 2.5.0-alpha1, < 2.5.13: Betroffen

    Keine Korrektur veröffentlicht

  • sulu/sulu Packagist

    Softwareversionen
    • 2.2.0
    • 2.2.1
    • 2.2.10
    • 2.2.11
    • 2.2.12
    • 2.2.13
    • 2.2.14
    • 2.2.15
    • 2.2.16
    • 2.2.17
    • 2.2.18
    • 2.2.19
    • 2.2.2
    • 2.2.3
    • 2.2.4
    • 2.2.5
    • 2.2.6
    • 2.2.7
    • 2.2.8
    • 2.2.9
    • 2.3.0
    • 2.3.0-RC1
    • 2.3.0-RC2
    • 2.3.1
    • 2.3.10
    • 2.3.11
    • 2.3.12
    • 2.3.13
    • 2.3.2
    • 2.3.3
    • 2.3.4
    • 2.3.5
    • 2.3.6
    • 2.3.7
    • 2.3.8
    • 2.3.9
    • 2.4.0
    • 2.4.0-RC1
    • 2.4.1
    • 2.4.10
    • 2.4.11
    • 2.4.12
    • 2.4.13
    • 2.4.14
    • 2.4.15
    • 2.4.16
    • 2.4.2
    • 2.4.3
    • 2.4.4
    • 2.4.5
    • 2.4.6
    • 2.4.7
    • 2.4.8
    • 2.4.9
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.2.0, < 2.4.17

    Auf 2.4.17 aktualisieren

  • sulu/sulu Packagist

    Softwareversionen
    • 2.5.0
    • 2.5.0-alpha1
    • 2.5.1
    • 2.5.10
    • 2.5.11
    • 2.5.12
    • 2.5.2
    • 2.5.3
    • 2.5.4
    • 2.5.5
    • 2.5.6
    • 2.5.7
    • 2.5.8
    • 2.5.9
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 2.5.0-alpha1, < 2.5.13

    Auf 2.5.13 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →