CVE-2024-28243
CVE-2024-28243 · KaTeX's maxExpand bypassed by \edef
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
KaTeX is a JavaScript library for TeX math rendering on the web. KaTeX users who render untrusted mathematical expressions could encounter malicious input using `\edef` that causes a near-infinite loop, despite setting `maxExpand` to avoid such loops. This can be used as an availability attack, where e.g. a client rendering another user's KaTeX input will be unable to use the site due to memory overflow, tying up the main thread, or stack overflow. Upgrade to KaTeX v0.16.10 to remove this vulnerability.
CVSS 6.5 · Mittel · EPSS 1,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
katex
- Softwareversionen
- >= 0.12.0, < 0.16.10: Betroffen
Keine Korrektur veröffentlicht
node-katex Debian:12
- Softwareversionen
- 0.16.10+~cs6.1.0-1
- 0.16.10+~cs6.1.0-2
- 0.16.10+~cs6.1.0-3
- 0.16.10+~cs6.1.0-4
- 0.16.10+~cs6.1.0-5
- 0.16.10+~cs6.1.0-6
- 0.16.10+~cs6.1.0-7
- 0.16.10+~cs6.1.0-8
- 0.16.10+~cs6.1.0-9
- 0.16.4+~cs6.1.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
node-katex Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.16.10+~cs6.1.0-1
Auf 0.16.10+~cs6.1.0-1 aktualisieren
node-katex Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.16.10+~cs6.1.0-1
Auf 0.16.10+~cs6.1.0-1 aktualisieren
katex npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 0.12.0, < 0.16.10
Auf 0.16.10 aktualisieren
node-katex Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 0.10.2+dfsg-8
- 0.10.2+dfsg-9
- 0.10.2+dfsg-10
- 0.13.11+~cs6.0.0-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.13.11+~cs6.0.0-2ubuntu0.1~esm1
Auf 0.13.11+~cs6.0.0-2ubuntu0.1~esm1 aktualisieren