CVE-2024-29025
CVE-2024-29025 · Netty HttpPostRequestDecoder can OOM
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Netty is an asynchronous event-driven network application framework for rapid development of maintainable high performance protocol servers & clients. The `HttpPostRequestDecoder` can be tricked to accumulate data. While the decoder can store items on the disk if configured so, there are no limits to the number of fields the form can have, an attacher can send a chunked post consisting of many small fields that will be accumulated in the `bodyListHttpData` list. The decoder cumulates bytes in the `undecodedChunk` buffer until it can decode a field, this field can cumulate data without limits. This vulnerability is fixed in 4.1.108.Final.
CVSS 5.3 · Mittel · EPSS 1,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
netty
- Softwareversionen
- < 4.1.108.Final: Betroffen
Keine Korrektur veröffentlicht
netty Debian:12
- Softwareversionen
- 1:4.1.48-7
- 1:4.1.48-7+deb12u1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:4.1.48-7+deb12u2
Auf 1:4.1.48-7+deb12u2 aktualisieren
netty Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:4.1.48-10
Auf 1:4.1.48-10 aktualisieren
netty Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:4.1.48-10
Auf 1:4.1.48-10 aktualisieren
netty Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 1:3.2.6.Final-2
- 1:4.0.32-1
- 1:4.0.33-1
- 1:4.0.34-1
- 1:4.0.34-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:4.0.34-1ubuntu0.1~esm2
Auf 1:4.0.34-1ubuntu0.1~esm2 aktualisieren
netty Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 1:4.1.7-4
- 1:4.1.7-4ubuntu0.1~esm1
- 1:4.1.7-4ubuntu0.1
- 1:4.1.7-4ubuntu0.1+esm1
- 1:4.1.7-4ubuntu0.1+esm2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:4.1.7-4ubuntu0.1+esm3
Auf 1:4.1.7-4ubuntu0.1+esm3 aktualisieren
netty Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 1:4.1.33-1
- 1:4.1.33-2
- 1:4.1.33-3
- 1:4.1.45-1
- 1:4.1.45-1ubuntu0.1~esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:4.1.45-1ubuntu0.1~esm2
Auf 1:4.1.45-1ubuntu0.1~esm2 aktualisieren
netty Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 1:4.1.48-4
- 1:4.1.48-4+deb11u1build0.22.04.1
- 1:4.1.48-4+deb11u2build0.22.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:4.1.48-4+deb11u2ubuntu0.1~esm1
Auf 1:4.1.48-4+deb11u2ubuntu0.1~esm1 aktualisieren
Originalquellen
- https://github.com/netty/netty/security/advisories/GHSA-5jpm-x58v-624v
- https://github.com/netty/netty/commit/0d0c6ed782d13d423586ad0c71737b2c7d02058c
- https://gist.github.com/vietj/f558b8ea81ec6505f1e9a6ca283c9ae3
- https://lists.debian.org/debian-lts-announce/2024/06/msg00015.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-29025