CVE-2024-34069
CVE-2024-34069 · Werkzeug's improper usage of a pathname and improper CSRF protection results in the remote command execution
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Werkzeug is a comprehensive WSGI web application library. The debugger in affected versions of Werkzeug can allow an attacker to execute code on a developer's machine under some circumstances. This requires the attacker to get the developer to interact with a domain and subdomain they control, and enter the debugger PIN, but if they are successful it allows access to the debugger even if it is only running on localhost. This also requires the attacker to guess a URL in the developer's application that will trigger the debugger. This vulnerability is fixed in 3.0.3.
CVSS 7.5 · Hoch · EPSS 3,4% · Öffentlicher Exploit · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
werkzeug
- Softwareversionen
- < 3.0.3: Betroffen
Keine Korrektur veröffentlicht
python-werkzeug Debian:12
- Softwareversionen
- 2.2.2-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.2.2-3+deb12u1
Auf 2.2.2-3+deb12u1 aktualisieren
python-werkzeug Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.0.3-1
Auf 3.0.3-1 aktualisieren
python-werkzeug Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.0.3-1
Auf 3.0.3-1 aktualisieren
werkzeug PyPI
- Softwareversionen
- 0.1
- 0.10
- 0.10.1
- 0.10.2
- 0.10.3
- 0.10.4
- 0.11
- 0.11.1
- 0.11.10
- 0.11.11
- 0.11.12
- 0.11.13
- 0.11.14
- 0.11.15
- 0.11.2
- 0.11.3
- 0.11.4
- 0.11.5
- 0.11.6
- 0.11.7
- 0.11.8
- 0.11.9
- 0.12
- 0.12.1
- 0.12.2
- 0.13
- 0.14
- 0.14.1
- 0.15.0
- 0.15.1
- 0.15.2
- 0.15.3
- 0.15.4
- 0.15.5
- 0.15.6
- 0.16.0
- 0.16.1
- 0.2
- 0.3
- 0.3.1
- 0.4
- 0.4.1
- 0.5
- 0.5.1
- 0.6
- 0.6.1
- 0.6.2
- 0.7
- 0.7.1
- 0.7.2
- 0.8
- 0.8.1
- 0.8.2
- 0.8.3
- 0.9
- 0.9.1
- 0.9.2
- 0.9.3
- 0.9.4
- 0.9.5
- 0.9.6
- 1.0.0
- 1.0.0rc1
- 1.0.1
- 2.0.0
- 2.0.0rc1
- 2.0.0rc2
- 2.0.0rc3
- 2.0.0rc4
- 2.0.0rc5
- 2.0.1
- 2.0.2
- 2.0.3
- 2.1.0
- 2.1.1
- 2.1.2
- 2.2.0
- 2.2.0a1
- 2.2.1
- 2.2.2
- 2.2.3
- 2.3.0
- 2.3.1
- 2.3.2
- 2.3.3
- 2.3.4
- 2.3.5
- 2.3.6
- 2.3.7
- 2.3.8
- 3.0.0
- 3.0.1
- 3.0.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.0.3
Auf 3.0.3 aktualisieren
python-werkzeug Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 0.10.4+dfsg1-1ubuntu1
- 0.10.4+dfsg1-1ubuntu1.1
- 0.10.4+dfsg1-1ubuntu1.2
- 0.10.4+dfsg1-1ubuntu1.2+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.10.4+dfsg1-1ubuntu1.2+esm2
Auf 0.10.4+dfsg1-1ubuntu1.2+esm2 aktualisieren
python-werkzeug Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 0.12.2+dfsg1-2
- 0.13+dfsg1-1
- 0.14.1+dfsg1-1
- 0.14.1+dfsg1-1ubuntu0.1
- 0.14.1+dfsg1-1ubuntu0.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.14.1+dfsg1-1ubuntu0.2+esm1
Auf 0.14.1+dfsg1-1ubuntu0.2+esm1 aktualisieren
python-werkzeug Ubuntu:20.04:LTS
- Softwareversionen
- 0.14.1+dfsg1-4
- 0.15.6+dfsg1-1
- 0.16.0+dfsg1-1
- 0.16.1+dfsg1-1ubuntu1
- 0.16.1+dfsg1-2
- 0.16.1+dfsg1-2ubuntu0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.16.1+dfsg1-2ubuntu0.2
Auf 0.16.1+dfsg1-2ubuntu0.2 aktualisieren
python-werkzeug Ubuntu:22.04:LTS
- Softwareversionen
- 1.0.1+dfsg1-2
- 2.0.2+dfsg1-1
- 2.0.2+dfsg1-1ubuntu0.22.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.0.2+dfsg1-1ubuntu0.22.04.2
Auf 2.0.2+dfsg1-1ubuntu0.22.04.2 aktualisieren
python-werkzeug Ubuntu:24.04:LTS
- Softwareversionen
- 2.2.2-3
- 3.0.1-1
- 3.0.1-2
- 3.0.1-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.0.1-3ubuntu0.1
Auf 3.0.1-3ubuntu0.1 aktualisieren
Originalquellen
- https://github.com/pallets/werkzeug/security/advisories/GHSA-2g68-c3qc-8985
- https://github.com/pallets/werkzeug/commit/3386395b24c7371db11a5b8eaac0c91da5362692
- https://lists.fedoraproject.org/archives/list/[email protected]/message/HFERFN7PINV4MOGMGA3DPIXJPDCYOEJZ/
- https://lists.fedoraproject.org/archives/list/[email protected]/message/H4SH32AM3CTPMAAEOIDAN7VU565LO4IR/
- https://security.netapp.com/advisory/ntap-20240614-0004/
- https://lists.debian.org/debian-lts-announce/2025/02/msg00026.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-34069