p PatchFirst

CVE-2024-3829

CVE-2024-3829 · Arbitrary File Read and Write during Snapshot Recovery in qdrant/qdrant

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

qdrant/qdrant version 1.9.0-dev is vulnerable to arbitrary file read and write during the snapshot recovery process. Attackers can exploit this vulnerability by manipulating snapshot files to include symlinks, leading to arbitrary file read by adding a symlink that points to a desired file on the filesystem and arbitrary file write by including a symlink and a payload file in the snapshot's directory structure. This vulnerability allows for the reading and writing of arbitrary files on the server, which could potentially lead to a full takeover of the system. The issue is fixed in version v1.9.0.

CVSS 9.8 · Kritisch · EPSS 0,9% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • qdrant/qdrant

    Softwareversionen
    • ≥ unspecified, < v1.9.0: Betroffen (custom)

    Auf v1.9.0 aktualisieren

  • qdrant-client PyPI

    Softwareversionen
    • 0.1.0
    • 0.1.1
    • 0.1.2
    • 0.1.3
    • 0.1.4
    • 0.1.5
    • 0.10.0
    • 0.10.1
    • 0.10.2
    • 0.10.3
    • 0.11.0
    • 0.11.1
    • 0.11.10
    • 0.11.3
    • 0.11.4
    • 0.11.5
    • 0.11.6
    • 0.11.7
    • 0.11.8
    • 0.11.9
    • 0.2.0
    • 0.3.0
    • 0.3.1
    • 0.3.10
    • 0.3.11
    • 0.3.12
    • 0.3.2
    • 0.3.3
    • 0.3.4
    • 0.3.5
    • 0.3.6
    • 0.3.7
    • 0.3.8
    • 0.3.9
    • 0.4.1
    • 0.5.0
    • 0.6.0
    • 0.6.1
    • 0.7.0
    • 0.7.1
    • 0.7.2
    • 0.7.3
    • 0.8.0
    • 0.8.3
    • 0.8.4
    • 0.8.5
    • 0.8.6
    • 0.8.7
    • 0.9.0
    • 0.9.1
    • 0.9.2
    • 0.9.3
    • 0.9.4
    • 0.9.5
    • 0.9.7
    • 1.0.0
    • 1.0.1
    • 1.0.2
    • 1.0.3
    • 1.0.4
    • 1.0.5
    • 1.1.0
    • 1.1.1
    • 1.1.2
    • 1.1.3
    • 1.1.4
    • 1.1.5
    • 1.1.6
    • 1.1.7
    • 1.2.0
    • 1.3.0
    • 1.3.1
    • 1.3.2
    • 1.4.0
    • 1.5.0
    • 1.5.1
    • 1.5.2
    • 1.5.3
    • 1.5.4
    • 1.6.0
    • 1.6.1
    • 1.6.2
    • 1.6.3
    • 1.6.4
    • 1.6.5
    • 1.6.6
    • 1.6.7
    • 1.6.8
    • 1.6.9
    • 1.7.0
    • 1.7.1
    • 1.7.2
    • 1.7.3
    • 1.8.0
    • 1.8.1
    • 1.8.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.9.0

    Auf 1.9.0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →