CVE-2024-38531
CVE-2024-38531 · Nix sandbox escape
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Nix is a package manager for Linux and other Unix systems that makes package management reliable and reproducible. A build process has access to and can change the permissions of the build directory. After creating a setuid binary in a globally accessible location, a malicious local user can assume the permissions of a Nix daemon worker and hijack all future builds. This issue was patched in version(s) 2.23.1, 2.22.2, 2.21.3, 2.20.7, 2.19.5 and 2.18.4.
CVSS 3.6 · Niedrig · EPSS 0,1% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
nix
- Softwareversionen
- >= 2.23.0, < 2.23.1: Betroffen
- >= 2.22.0, < 2.22.2: Betroffen
- >= 2.21.0, < 2.21.3: Betroffen
- >= 2.20.0, < 2.20.7: Betroffen
- >= 2.19.0, < 2.19.5: Betroffen
- >= 2.18.0, < 2.18.4: Betroffen
Keine Korrektur veröffentlicht
nix Debian:12
- Softwareversionen
- 2.16.1+dfsg-1
- 2.16.1+dfsg-2
- 2.16.1+dfsg-3
- 2.17.1+dfsg-1
- 2.18.1+dfsg-1
- 2.22.1+dfsg-1
- 2.23.3+dfsg-1
- 2.23.3+dfsg-2
- 2.24.12+dfsg-1
- 2.24.8+dfsg-1
- 2.24.9+dfsg-1
- 2.24.9+dfsg-2
- 2.25.4+dfsg-1
- 2.26.3+dfsg-1
- 2.32.5+dfsg-1
- 2.32.5+dfsg-2
- 2.34.3+dfsg-1
- 2.34.6+dfsg-1
- 2.34.8+dfsg-1
- 2.8.0-1.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
nix Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.23.3+dfsg-1
Auf 2.23.3+dfsg-1 aktualisieren
nix Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.23.3+dfsg-1
Auf 2.23.3+dfsg-1 aktualisieren
nix Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 2.3.10+dfsg1-1
- 2.3.10+dfsg1-1build1
- 2.6.0+dfsg-2
- 2.6.0+dfsg-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.6.0+dfsg-3ubuntu0.1~esm1
Auf 2.6.0+dfsg-3ubuntu0.1~esm1 aktualisieren
nix Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 2.16.1+dfsg-3ubuntu1
- 2.18.1+dfsg-1ubuntu1
- 2.18.1+dfsg-1ubuntu2
- 2.18.1+dfsg-1ubuntu4
- 2.18.1+dfsg-1ubuntu5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.18.1+dfsg-1ubuntu5+esm2
Auf 2.18.1+dfsg-1ubuntu5+esm2 aktualisieren