CVE-2024-41671
CVE-2024-41671 · twisted.web has disordered HTTP pipeline response
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Twisted is an event-based framework for internet applications, supporting Python 3.6+. The HTTP 1.0 and 1.1 server provided by twisted.web could process pipelined HTTP requests out-of-order, possibly resulting in information disclosure. This vulnerability is fixed in 24.7.0rc1.
CVSS 8.3 · Hoch · EPSS 0,9% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
twisted
- Softwareversionen
- <= 24.3.0: Betroffen
Keine Korrektur veröffentlicht
twisted Debian:12
- Softwareversionen
- 22.4.0-4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 22.4.0-4+deb12u1
Auf 22.4.0-4+deb12u1 aktualisieren
twisted Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 24.7.0-1
Auf 24.7.0-1 aktualisieren
twisted Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 24.7.0-1
Auf 24.7.0-1 aktualisieren
twisted PyPI
- Softwareversionen
- 1.0.1
- 1.0.3
- 1.0.4
- 1.0.5
- 1.0.6
- 1.0.7
- 1.1.0
- 1.1.1
- 1.2.0
- 10.0.0
- 10.1.0
- 10.2.0
- 11.0.0
- 11.1.0
- 12.0.0
- 12.1.0
- 12.2.0
- 12.3.0
- 13.0.0
- 13.1.0
- 13.2.0
- 14.0.0
- 14.0.1
- 14.0.2
- 15.0.0
- 15.1.0
- 15.2.0
- 15.2.1
- 15.3.0
- 15.4.0
- 15.5.0
- 16.0.0
- 16.1.0
- 16.1.1
- 16.2.0
- 16.3.0
- 16.3.1
- 16.3.2
- 16.4.0
- 16.4.1
- 16.5.0
- 16.5.0rc1
- 16.5.0rc2
- 16.6.0
- 16.6.0rc1
- 16.7.0rc1
- 16.7.0rc2
- 17.1.0
- 17.1.0rc1
- 17.5.0
- 17.9.0
- 17.9.0rc1
- 18.4.0
- 18.4.0rc1
- 18.7.0
- 18.7.0rc1
- 18.7.0rc2
- 18.9.0
- 18.9.0rc1
- 19.10.0
- 19.10.0rc1
- 19.2.0
- 19.2.0rc1
- 19.2.0rc2
- 19.2.1
- 19.7.0
- 19.7.0rc1
- 2.1.0
- 2.4.0
- 2.5.0
- 20.3.0
- 20.3.0rc1
- 21.2.0
- 21.2.0rc1
- 21.7.0
- 21.7.0rc1
- 21.7.0rc2
- 21.7.0rc3
- 22.1.0
- 22.1.0rc1
- 22.10.0
- 22.10.0rc1
- 22.2.0
- 22.2.0rc1
- 22.4.0
- 22.4.0rc1
- 22.8.0
- 22.8.0rc1
- 23.10.0
- 23.10.0rc1
- 23.8.0
- 23.8.0rc1
- 24.2.0rc1
- 24.3.0
- 8.0.0
- 8.0.1
- 8.1.0
- 8.2.0
- 9.0.0
- Betroffene Versionsbereiche
- ECOSYSTEM: < 24.7.0rc1
Auf 24.7.0rc1 aktualisieren
twisted Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 16.6.0-2ubuntu3
- 17.9.0-1
- 17.9.0-2
- 17.9.0-2ubuntu0.1
- 17.9.0-2ubuntu0.3
- 17.9.0-2ubuntu0.3+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 17.9.0-2ubuntu0.3+esm2
Auf 17.9.0-2ubuntu0.3+esm2 aktualisieren
twisted Ubuntu:20.04:LTS
- Softwareversionen
- 18.9.0-3ubuntu1
- 18.9.0-5
- 18.9.0-6
- 18.9.0-6build1
- 18.9.0-6ubuntu1
- 18.9.0-8
- 18.9.0-11
- 18.9.0-11ubuntu0.20.04.1
- 18.9.0-11ubuntu0.20.04.2
- 18.9.0-11ubuntu0.20.04.3
- 18.9.0-11ubuntu0.20.04.4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 18.9.0-11ubuntu0.20.04.5
Auf 18.9.0-11ubuntu0.20.04.5 aktualisieren
twisted Ubuntu:22.04:LTS
- Softwareversionen
- 20.3.0-7ubuntu1
- 20.3.0-7ubuntu3
- 22.1.0-2ubuntu2
- 22.1.0-2ubuntu2.1
- 22.1.0-2ubuntu2.3
- 22.1.0-2ubuntu2.4
- 22.1.0-2ubuntu2.5
- Betroffene Versionsbereiche
- ECOSYSTEM: < 22.1.0-2ubuntu2.6
Auf 22.1.0-2ubuntu2.6 aktualisieren
twisted Ubuntu:24.04:LTS
- Softwareversionen
- 22.4.0-4
- 22.4.0-4ubuntu1
- 23.10.0-2
- 24.3.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 24.3.0-1ubuntu0.1
Auf 24.3.0-1ubuntu0.1 aktualisieren
Originalquellen
- https://github.com/twisted/twisted/security/advisories/GHSA-c8m8-j448-xjx7
- https://github.com/twisted/twisted/commit/046a164f89a0f08d3239ecebd750360f8914df33
- https://github.com/twisted/twisted/commit/4a930de12fb67e88fefcb8822104152f42b27abc
- https://www.vicarius.io/vsociety/posts/disordered-http-pipeline-in-twistedweb-cve-2024-4167
- https://lists.debian.org/debian-lts-announce/2024/11/msg00028.html
- https://nvd.nist.gov/vuln/detail/CVE-2024-41671