p PatchFirst

CVE-2024-41964

CVE-2024-41964 · Insufficient permission checks in the language settings in Kirby CMS

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Kirby is a CMS targeting designers and editors. Kirby allows to restrict the permissions of specific user roles. Users of that role can only perform permitted actions. Permissions for creating and deleting languages have already existed and could be configured, but were not enforced by Kirby's frontend or backend code. A permission for updating existing languages has not existed before the patched versions. So disabling the languages.* wildcard permission for a role could not have prohibited updates to existing language definitions. The missing permission checks allowed attackers with Panel access to manipulate the language definitions. The problem has been patched in Kirby 3.6.6.6, Kirby 3.7.5.5, Kirby 3.8.4.4, Kirby 3.9.8.2, Kirby 3.10.1.1, and Kirby 4.3.1. Please update to one of these or a later version to fix the vulnerability. There are no known workarounds for this vulnerability.

CVSS 8.1 · Hoch · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: php

Betroffene Produkte und Versionen

  • kirby

    Softwareversionen
    • < 3.6.6.6: Betroffen
    • >= 3.7.0, < 3.7.5.5: Betroffen
    • >= 3.8.0, < 3.8.4.4: Betroffen
    • >= 3.9.0, < 3.9.8.2: Betroffen
    • >= 3.10.0, < 3.10.1.1: Betroffen
    • >= 4.0.0, < 4.3.1: Betroffen

    Keine Korrektur veröffentlicht

  • getkirby/cms Packagist

    Softwareversionen
    • 3.0.0
    • 3.0.1
    • 3.0.1-rc.1
    • 3.0.2
    • 3.0.2-rc.1
    • 3.0.3
    • 3.0.3-rc.1
    • 3.0.3-rc.2
    • 3.0.3-rc.3
    • 3.1.0
    • 3.1.0-rc.1
    • 3.1.1
    • 3.1.2
    • 3.1.2-rc.1
    • 3.1.3
    • 3.1.3-rc.1
    • 3.1.4
    • 3.1.4-rc.1
    • 3.2.0
    • 3.2.0-rc.1
    • 3.2.0-rc.2
    • 3.2.0-rc.3
    • 3.2.0-rc.4
    • 3.2.1
    • 3.2.1-rc.1
    • 3.2.2
    • 3.2.3
    • 3.2.3-rc.1
    • 3.2.4
    • 3.2.4-rc.1
    • 3.2.5
    • 3.2.5-rc.1
    • 3.2.5-rc.2
    • 3.3.0
    • 3.3.0-rc.1
    • 3.3.0-rc.2
    • 3.3.0-rc.3
    • 3.3.0-rc.4
    • 3.3.0-rc.5
    • 3.3.1
    • 3.3.1-rc.1
    • 3.3.2
    • 3.3.2-rc.1
    • 3.3.3
    • 3.3.3-rc.1
    • 3.3.4
    • 3.3.4-rc.1
    • 3.3.5
    • 3.3.5-rc.1
    • 3.3.6
    • 3.4.0
    • 3.4.0-rc.1
    • 3.4.0-rc.2
    • 3.4.0-rc.3
    • 3.4.1
    • 3.4.1-rc.1
    • 3.4.2
    • 3.4.3
    • 3.4.3-rc.1
    • 3.4.4
    • 3.4.4-rc.1
    • 3.4.5
    • 3.5.0
    • 3.5.0-rc.1
    • 3.5.0-rc.2
    • 3.5.0-rc.3
    • 3.5.0-rc.4
    • 3.5.0-rc.5
    • 3.5.0-rc.6
    • 3.5.0-rc.7
    • 3.5.1
    • 3.5.1-rc.1
    • 3.5.2
    • 3.5.2-rc.1
    • 3.5.3
    • 3.5.3.1
    • 3.5.4
    • 3.5.5
    • 3.5.5-rc.1
    • 3.5.6
    • 3.5.6-rc.1
    • 3.5.7
    • 3.5.7-rc.1
    • 3.5.7.1
    • 3.5.8
    • 3.5.8.1
    • 3.5.8.2
    • 3.5.8.3
    • 3.5.8.4
    • 3.6.0
    • 3.6.0-alpha.1
    • 3.6.0-alpha.2
    • 3.6.0-alpha.3
    • 3.6.0-alpha.4
    • 3.6.0-beta.1
    • 3.6.0-beta.2
    • 3.6.0-beta.3
    • 3.6.0-rc.1
    • 3.6.0-rc.2
    • 3.6.0-rc.3
    • 3.6.0-rc.4
    • 3.6.0-rc.5
    • 3.6.1
    • 3.6.1.1
    • 3.6.2
    • 3.6.2-rc.1
    • 3.6.2-rc.2
    • 3.6.2-rc.3
    • 3.6.3
    • 3.6.3-rc.1
    • 3.6.3-rc.2
    • 3.6.3.1
    • 3.6.4
    • 3.6.4-rc.1
    • 3.6.5
    • 3.6.5-rc.1
    • 3.6.6
    • 3.6.6-rc.1
    • 3.6.6.1
    • 3.6.6.2
    • 3.6.6.3
    • 3.6.6.4
    • 3.6.6.5
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.6.6.6

    Auf 3.6.6.6 aktualisieren

  • getkirby/cms Packagist

    Softwareversionen
    • 3.7.0
    • 3.7.0.1
    • 3.7.0.2
    • 3.7.1
    • 3.7.1-rc.1
    • 3.7.2
    • 3.7.2-rc.1
    • 3.7.2.1
    • 3.7.3
    • 3.7.3-rc.1
    • 3.7.4
    • 3.7.4-rc.1
    • 3.7.5
    • 3.7.5.1
    • 3.7.5.2
    • 3.7.5.3
    • 3.7.5.4
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 3.7.0, < 3.7.5.5

    Auf 3.7.5.5 aktualisieren

  • getkirby/cms Packagist

    Softwareversionen
    • 3.8.0
    • 3.8.1
    • 3.8.1-rc.1
    • 3.8.1.1
    • 3.8.2
    • 3.8.2-rc.1
    • 3.8.3
    • 3.8.3-rc.1
    • 3.8.3-rc.2
    • 3.8.4
    • 3.8.4.1
    • 3.8.4.2
    • 3.8.4.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 3.8.0, < 3.8.4.4

    Auf 3.8.4.4 aktualisieren

  • getkirby/cms Packagist

    Softwareversionen
    • 3.9.0
    • 3.9.1
    • 3.9.1-rc.1
    • 3.9.2
    • 3.9.2-rc.1
    • 3.9.3
    • 3.9.3-rc.1
    • 3.9.4
    • 3.9.4-rc.1
    • 3.9.5
    • 3.9.5-rc.1
    • 3.9.6
    • 3.9.6-rc.1
    • 3.9.6.1
    • 3.9.7
    • 3.9.7-rc.1
    • 3.9.8
    • 3.9.8-rc.1
    • 3.9.8.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 3.9.0, < 3.9.8.2

    Auf 3.9.8.2 aktualisieren

  • getkirby/cms Packagist

    Softwareversionen
    • 3.10.0
    • 3.10.0.1
    • 3.10.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 3.10.0, < 3.10.1.1

    Auf 3.10.1.1 aktualisieren

  • getkirby/cms Packagist

    Softwareversionen
    • 4.0.0
    • 4.0.1
    • 4.0.2
    • 4.0.3
    • 4.1.0
    • 4.1.0-rc.1
    • 4.1.0-rc.2
    • 4.1.0-rc.3
    • 4.1.1
    • 4.1.2
    • 4.2.0
    • 4.2.0-rc.1
    • 4.3.0
    • 4.3.0-rc.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≥ 4.0.0, < 4.3.1

    Auf 4.3.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →