CVE-2024-42516
CVE-2024-42516 · Apache HTTP Server: HTTP response splitting
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
HTTP response splitting in the core of Apache HTTP Server allows an attacker who can manipulate the Content-Type response headers of applications hosted or proxied by the server can split the HTTP response. This vulnerability was described as CVE-2023-38709 but the patch included in Apache HTTP Server 2.4.59 did not address the issue. Users are recommended to upgrade to version 2.4.64, which fixes this issue.
CVSS 7.5 · Hoch · EPSS 0,8% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · web
Betroffene Produkte und Versionen
apache httpd
- Softwareversionen
- ≥ 2.4.0, ≤ 2.4.63: Betroffen (semver)
Keine Korrektur veröffentlicht
apache2 Debian:12
- Softwareversionen
- 2.4.57-2
- 2.4.57-3
- 2.4.58-1
- 2.4.59-1
- 2.4.59-1~deb10u1
- 2.4.59-1~deb11u1
- 2.4.59-1~deb12u1
- 2.4.59-2
- 2.4.60-1
- 2.4.61-1
- 2.4.61-1~deb11u1
- 2.4.61-1~deb12u1
- 2.4.62-1
- 2.4.62-1~deb11u1
- 2.4.62-1~deb11u2
- 2.4.62-1~deb12u1
- 2.4.62-1~deb12u2
- 2.4.62-2
- 2.4.62-3
- 2.4.62-4
- 2.4.62-5
- 2.4.62-6
- 2.4.63-1
- 2.4.64-1
- 2.4.65-1~deb11u1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.4.65-1~deb12u1
Auf 2.4.65-1~deb12u1 aktualisieren
apache2 Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.4.64-1
Auf 2.4.64-1 aktualisieren
apache2 Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.4.64-1
Auf 2.4.64-1 aktualisieren
apache2 Ubuntu:Pro:14.04:LTS
- Softwareversionen
- 2.4.6-2ubuntu2
- 2.4.6-2ubuntu3
- 2.4.6-2ubuntu4
- 2.4.7-1ubuntu1
- 2.4.7-1ubuntu2
- 2.4.7-1ubuntu3
- 2.4.7-1ubuntu4
- 2.4.7-1ubuntu4.1
- 2.4.7-1ubuntu4.4
- 2.4.7-1ubuntu4.5
- 2.4.7-1ubuntu4.6
- 2.4.7-1ubuntu4.7
- 2.4.7-1ubuntu4.8
- 2.4.7-1ubuntu4.9
- 2.4.7-1ubuntu4.10
- 2.4.7-1ubuntu4.11
- 2.4.7-1ubuntu4.13
- 2.4.7-1ubuntu4.15
- 2.4.7-1ubuntu4.16
- 2.4.7-1ubuntu4.17
- 2.4.7-1ubuntu4.18
- 2.4.7-1ubuntu4.19
- 2.4.7-1ubuntu4.20
- 2.4.7-1ubuntu4.21
- 2.4.7-1ubuntu4.22
- 2.4.7-1ubuntu4.22+esm1
- 2.4.7-1ubuntu4.22+esm2
- 2.4.7-1ubuntu4.22+esm3
- 2.4.7-1ubuntu4.22+esm4
- 2.4.7-1ubuntu4.22+esm5
- 2.4.7-1ubuntu4.22+esm6
- 2.4.7-1ubuntu4.22+esm8
- 2.4.7-1ubuntu4.22+esm9
- 2.4.7-1ubuntu4.22+esm10
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.4.7-1ubuntu4.22+esm12
Auf 2.4.7-1ubuntu4.22+esm12 aktualisieren
apache2 Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 2.4.12-2ubuntu2
- 2.4.17-1ubuntu1
- 2.4.17-2ubuntu1
- 2.4.17-3ubuntu1
- 2.4.18-1ubuntu1
- 2.4.18-2ubuntu1
- 2.4.18-2ubuntu2
- 2.4.18-2ubuntu3
- 2.4.18-2ubuntu3.1
- 2.4.18-2ubuntu3.2
- 2.4.18-2ubuntu3.3
- 2.4.18-2ubuntu3.4
- 2.4.18-2ubuntu3.5
- 2.4.18-2ubuntu3.7
- 2.4.18-2ubuntu3.8
- 2.4.18-2ubuntu3.9
- 2.4.18-2ubuntu3.10
- 2.4.18-2ubuntu3.12
- 2.4.18-2ubuntu3.13
- 2.4.18-2ubuntu3.14
- 2.4.18-2ubuntu3.15
- 2.4.18-2ubuntu3.17
- 2.4.18-2ubuntu3.17+esm1
- 2.4.18-2ubuntu3.17+esm2
- 2.4.18-2ubuntu3.17+esm3
- 2.4.18-2ubuntu3.17+esm4
- 2.4.18-2ubuntu3.17+esm5
- 2.4.18-2ubuntu3.17+esm6
- 2.4.18-2ubuntu3.17+esm7
- 2.4.18-2ubuntu3.17+esm8
- 2.4.18-2ubuntu3.17+esm9
- 2.4.18-2ubuntu3.17+esm10
- 2.4.18-2ubuntu3.17+esm11
- 2.4.18-2ubuntu3.17+esm12
- 2.4.18-2ubuntu3.17+esm13
- 2.4.18-2ubuntu3.17+esm14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.4.18-2ubuntu3.17+esm16
Auf 2.4.18-2ubuntu3.17+esm16 aktualisieren
apache2 Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 2.4.27-2ubuntu3
- 2.4.29-1ubuntu1
- 2.4.29-1ubuntu2
- 2.4.29-1ubuntu3
- 2.4.29-1ubuntu4
- 2.4.29-1ubuntu4.1
- 2.4.29-1ubuntu4.2
- 2.4.29-1ubuntu4.3
- 2.4.29-1ubuntu4.4
- 2.4.29-1ubuntu4.5
- 2.4.29-1ubuntu4.6
- 2.4.29-1ubuntu4.7
- 2.4.29-1ubuntu4.8
- 2.4.29-1ubuntu4.10
- 2.4.29-1ubuntu4.11
- 2.4.29-1ubuntu4.12
- 2.4.29-1ubuntu4.13
- 2.4.29-1ubuntu4.14
- 2.4.29-1ubuntu4.16
- 2.4.29-1ubuntu4.17
- 2.4.29-1ubuntu4.18
- 2.4.29-1ubuntu4.19
- 2.4.29-1ubuntu4.20
- 2.4.29-1ubuntu4.21
- 2.4.29-1ubuntu4.22
- 2.4.29-1ubuntu4.23
- 2.4.29-1ubuntu4.24
- 2.4.29-1ubuntu4.25
- 2.4.29-1ubuntu4.26
- 2.4.29-1ubuntu4.27
- 2.4.29-1ubuntu4.27+esm1
- 2.4.29-1ubuntu4.27+esm2
- 2.4.29-1ubuntu4.27+esm3
- 2.4.29-1ubuntu4.27+esm4
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.4.29-1ubuntu4.27+esm6
Auf 2.4.29-1ubuntu4.27+esm6 aktualisieren
apache2 Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 2.4.41-1ubuntu1
- 2.4.41-4ubuntu1
- 2.4.41-4ubuntu2
- 2.4.41-4ubuntu3
- 2.4.41-4ubuntu3.1
- 2.4.41-4ubuntu3.3
- 2.4.41-4ubuntu3.4
- 2.4.41-4ubuntu3.5
- 2.4.41-4ubuntu3.6
- 2.4.41-4ubuntu3.7
- 2.4.41-4ubuntu3.8
- 2.4.41-4ubuntu3.9
- 2.4.41-4ubuntu3.10
- 2.4.41-4ubuntu3.11
- 2.4.41-4ubuntu3.12
- 2.4.41-4ubuntu3.13
- 2.4.41-4ubuntu3.14
- 2.4.41-4ubuntu3.15
- 2.4.41-4ubuntu3.16
- 2.4.41-4ubuntu3.17
- 2.4.41-4ubuntu3.19
- 2.4.41-4ubuntu3.20
- 2.4.41-4ubuntu3.21
- 2.4.41-4ubuntu3.23
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.4.41-4ubuntu3.23+esm2
Auf 2.4.41-4ubuntu3.23+esm2 aktualisieren
apache2 Ubuntu:22.04:LTS
- Softwareversionen
- 2.4.48-3.1ubuntu3
- 2.4.48-3.1ubuntu4
- 2.4.51-2ubuntu1
- 2.4.52-1ubuntu1
- 2.4.52-1ubuntu2
- 2.4.52-1ubuntu4
- 2.4.52-1ubuntu4.1
- 2.4.52-1ubuntu4.2
- 2.4.52-1ubuntu4.3
- 2.4.52-1ubuntu4.4
- 2.4.52-1ubuntu4.5
- 2.4.52-1ubuntu4.6
- 2.4.52-1ubuntu4.7
- 2.4.52-1ubuntu4.8
- 2.4.52-1ubuntu4.9
- 2.4.52-1ubuntu4.10
- 2.4.52-1ubuntu4.11
- 2.4.52-1ubuntu4.12
- 2.4.52-1ubuntu4.13
- 2.4.52-1ubuntu4.14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.4.52-1ubuntu4.15
Auf 2.4.52-1ubuntu4.15 aktualisieren
apache2 Ubuntu:24.04:LTS
- Softwareversionen
- 2.4.57-2ubuntu2
- 2.4.57-2ubuntu3
- 2.4.58-1ubuntu1
- 2.4.58-1ubuntu2
- 2.4.58-1ubuntu6
- 2.4.58-1ubuntu7
- 2.4.58-1ubuntu8
- 2.4.58-1ubuntu8.1
- 2.4.58-1ubuntu8.2
- 2.4.58-1ubuntu8.3
- 2.4.58-1ubuntu8.4
- 2.4.58-1ubuntu8.5
- 2.4.58-1ubuntu8.6
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.4.58-1ubuntu8.7
Auf 2.4.58-1ubuntu8.7 aktualisieren
apache2 Ubuntu:25.10
- Softwareversionen
- 2.4.63-1ubuntu1
- 2.4.63-1ubuntu3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.4.64-1ubuntu2
Auf 2.4.64-1ubuntu2 aktualisieren