p PatchFirst

CVE-2024-45598

CVE-2024-45598 · Cacti has a Local File Inclusion (LFI) Vulnerability via Poller Standard Error Log Path

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Cacti is an open source performance and fault management framework. Prior to 1.2.29, an administrator can change the `Poller Standard Error Log Path` parameter in either Installation Step 5 or in Configuration->Settings->Paths tab to a local file inside the server. Then simply going to Logs tab and selecting the name of the local file will show its content on the web UI. This vulnerability is fixed in 1.2.29.

CVSS 6.0 · Mittel · EPSS 3,1% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • cacti

    Softwareversionen
    • < 1.2.29: Betroffen

    Keine Korrektur veröffentlicht

  • cacti Debian:12

    Softwareversionen
    • 1.2.24+ds1-1
    • 1.2.24+ds1-1+deb12u1
    • 1.2.24+ds1-1+deb12u2
    • 1.2.24+ds1-1+deb12u3
    • 1.2.24+ds1-1+deb12u4
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.2.24+ds1-1+deb12u5

    Auf 1.2.24+ds1-1+deb12u5 aktualisieren

  • cacti Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.2.28+ds1-4

    Auf 1.2.28+ds1-4 aktualisieren

  • cacti Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.2.28+ds1-4

    Auf 1.2.28+ds1-4 aktualisieren

  • cacti Ubuntu:Pro:14.04:LTS

    Softwareversionen
    • 0.8.8b+dfsg-3
    • 0.8.8b+dfsg-5
    • 0.8.8b+dfsg-5ubuntu0.1
    • 0.8.8b+dfsg-5ubuntu0.2
    • 0.8.8b+dfsg-5ubuntu0.2+esm1
    • 0.8.8b+dfsg-5ubuntu0.2+esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • cacti Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 0.8.8f+ds1-2
    • 0.8.8f+ds1-3
    • 0.8.8f+ds1-4
    • 0.8.8f+ds1-4ubuntu1
    • 0.8.8f+ds1-4ubuntu2
    • 0.8.8f+ds1-4ubuntu3
    • 0.8.8f+ds1-4ubuntu4
    • 0.8.8f+ds1-4ubuntu4.16.04
    • 0.8.8f+ds1-4ubuntu4.16.04.1
    • 0.8.8f+ds1-4ubuntu4.16.04.2
    • 0.8.8f+ds1-4ubuntu4.16.04.2+esm1
    • 0.8.8f+ds1-4ubuntu4.16.04.2+esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • cacti Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 1.1.18+ds1-1
    • 1.1.27+ds1-2
    • 1.1.27+ds1-3
    • 1.1.28+ds1-2
    • 1.1.35+ds1-1
    • 1.1.36+ds1-1
    • 1.1.38+ds1-1
    • 1.1.38+ds1-1ubuntu0.1~esm1
    • 1.1.38+ds1-1ubuntu0.1~esm3
    • 1.1.38+ds1-1ubuntu0.1~esm4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • cacti Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 1.2.4+ds1-2ubuntu3
    • 1.2.9+ds1-1ubuntu1
    • 1.2.9+ds1-1ubuntu2
    • 1.2.10+ds1-1ubuntu1
    • 1.2.10+ds1-1ubuntu1+esm1
    • 1.2.10+ds1-1ubuntu1.1
    • 1.2.10+ds1-1ubuntu1.1+esm1
    • 1.2.10+ds1-1ubuntu1.1+esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • cacti Ubuntu:Pro:22.04:LTS

    Softwareversionen
    • 1.2.16+ds1-2ubuntu1
    • 1.2.19+ds1-2ubuntu1
    • 1.2.19+ds1-2ubuntu1+esm1
    • 1.2.19+ds1-2ubuntu1.1
    • 1.2.19+ds1-2ubuntu1.1+esm1
    • 1.2.19+ds1-2ubuntu1.1+esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • cacti Ubuntu:24.04:LTS

    Softwareversionen
    • 1.2.25+ds1-2
    • 1.2.26+ds1-1
    • 1.2.26+ds1-1ubuntu0.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • cacti Ubuntu:25.10

    Softwareversionen
    • 1.2.28+ds1-4ubuntu1
    • 1.2.30+ds1-1ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →