p PatchFirst

CVE-2024-45793

CVE-2024-45793 · Cross-site Scripting from in Confidant API call

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Confidant is a open source secret management service that provides user-friendly storage and access to secrets. The following endpoints are subject to a cross site scripting vulnerability: GET /v1/credentials, GET /v1/credentials/, GET /v1/archive/credentials/, GET /v1/archive/credentials, POST /v1/credentials, PUT /v1/credentials/, PUT /v1/credentials//<to_revision>, GET /v1/services, GET /v1/services/, GET /v1/archive/services/, GET /v1/archive/services, PUT /v1/services/, PUT /v1/services//<to_revision>. The attacker needs to be authenticated and have privileges to create new credentials, but could use this to show information and run scripts to other users into the same Confidant instance. This issue has been patched in version 6.6.2. All users are advised to upgrade. There are no known workarounds for this vulnerability.

CVSS 4.8 · Mittel · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • confidant

    Softwareversionen
    • < 6.6.2: Betroffen

    Keine Korrektur veröffentlicht

  • confidant PyPI

    Softwareversionen
    • 1.1.19
    • 1.1.20
    • 1.1.21
    • 1.10.1
    • 1.11.0
    • 1.2.0
    • 1.3.0
    • 1.4.0
    • 1.5.0
    • 1.5.1
    • 1.6.0
    • 1.8.0
    • 1.9.0
    • 4.0.0
    • 4.1.0
    • 4.2.0
    • 4.3.1
    • 4.4.0
    • 5.0.0
    • 5.0.1
    • 5.1.0
    • 5.2.0
    • 6.0.0
    • 6.1.0
    • 6.2.0
    • 6.3.0
    • 6.4.0
    • 6.5.0
    • 6.5.1
    • 6.5.2
    • 6.5.3
    • 6.6.0
    • 6.6.0a2
    • 6.6.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 6.6.2

    Auf 6.6.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →