p PatchFirst

CVE-2024-47603

CVE-2024-47603 · GHSL-2024-251: GStreamer NULL-pointer dereference in Matroska/WebM demuxer

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

GStreamer is a library for constructing graphs of media-handling components. A null pointer dereference vulnerability has been discovered in the gst_matroska_demux_update_tracks function within matroska-demux.c. The vulnerability occurs when the gst_caps_is_equal function is called with invalid caps values. If this happen, then in the function gst_buffer_get_size the call to GST_BUFFER_MEM_PTR can return a null pointer. Attempting to dereference the size field of this null pointer results in a null pointer dereference. This vulnerability is fixed in 1.24.10.

CVSS 6.8 · Mittel · EPSS 0,9% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • gstreamer

    Softwareversionen
    • < 1.24.10: Betroffen

    Keine Korrektur veröffentlicht

  • gst-plugins-good1.0 Debian:12

    Softwareversionen
    • 1.22.0-5
    • 1.22.0-5+deb12u1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.22.0-5+deb12u2

    Auf 1.22.0-5+deb12u2 aktualisieren

  • gst-plugins-good1.0 Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.24.10-1

    Auf 1.24.10-1 aktualisieren

  • gst-plugins-good1.0 Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.24.10-1

    Auf 1.24.10-1 aktualisieren

  • gst-plugins-good1.0 Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 1.6.0-1ubuntu1
    • 1.6.1-1ubuntu1
    • 1.6.2-1ubuntu1
    • 1.7.1-1ubuntu1
    • 1.7.2-1ubuntu1
    • 1.7.90-1ubuntu1
    • 1.7.91-1ubuntu1
    • 1.8.0-1ubuntu1
    • 1.8.1-1ubuntu0.1
    • 1.8.2-1ubuntu0.1
    • 1.8.2-1ubuntu0.2
    • 1.8.2-1ubuntu0.3
    • 1.8.3-1ubuntu0.3
    • 1.8.3-1ubuntu0.4
    • 1.8.3-1ubuntu0.5
    • 1.8.3-1ubuntu0.5+esm1
    • 1.8.3-1ubuntu0.5+esm2
    • 1.8.3-1ubuntu0.5+esm3
    • 1.8.3-1ubuntu0.5+esm4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • gst-plugins-good0.10 Ubuntu:16.04:LTS

    Softwareversionen
    • 0.10.31-3+nmu4ubuntu2~gcc5.1
    • 0.10.31-3+nmu4ubuntu2.16.04.1
    • 0.10.31-3+nmu4ubuntu2.16.04.2
    • 0.10.31-3+nmu4ubuntu2.16.04.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • gst-plugins-good1.0 Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 1.12.3-1ubuntu1
    • 1.12.4-1ubuntu1
    • 1.13.1-1ubuntu1
    • 1.13.91-1ubuntu1
    • 1.14.0-1ubuntu1
    • 1.14.1-1ubuntu1~ubuntu18.04.1
    • 1.14.4-1ubuntu1~ubuntu18.04.1
    • 1.14.5-0ubuntu1~18.04.1
    • 1.14.5-0ubuntu1~18.04.2
    • 1.14.5-0ubuntu1~18.04.3
    • 1.14.5-0ubuntu1~18.04.3+esm1
    • 1.14.5-0ubuntu1~18.04.3+esm2
    • 1.14.5-0ubuntu1~18.04.3+esm3
    • 1.14.5-0ubuntu1~18.04.3+esm4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • gst-plugins-good1.0 Ubuntu:20.04:LTS

    Softwareversionen
    • 1.16.1-1ubuntu1
    • 1.16.2-1ubuntu1
    • 1.16.2-1ubuntu2
    • 1.16.2-1ubuntu2.1
    • 1.16.3-0ubuntu1
    • 1.16.3-0ubuntu1.1
    • 1.16.3-0ubuntu1.2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.16.3-0ubuntu1.3

    Auf 1.16.3-0ubuntu1.3 aktualisieren

  • gst-plugins-good1.0 Ubuntu:22.04:LTS

    Softwareversionen
    • 1.18.5-1ubuntu2
    • 1.18.5-1ubuntu3
    • 1.20.0-2ubuntu1
    • 1.20.1-1ubuntu1
    • 1.20.3-0ubuntu1
    • 1.20.3-0ubuntu1.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.20.3-0ubuntu1.3

    Auf 1.20.3-0ubuntu1.3 aktualisieren

  • gst-plugins-good1.0 Ubuntu:24.04:LTS

    Softwareversionen
    • 1.22.6-1ubuntu1
    • 1.22.6-1ubuntu2
    • 1.22.8-3ubuntu1
    • 1.22.9-1ubuntu1
    • 1.24.0-1ubuntu5
    • 1.24.0-1ubuntu7
    • 1.24.1-2ubuntu1
    • 1.24.2-1ubuntu1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.24.2-1ubuntu1.1

    Auf 1.24.2-1ubuntu1.1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →