CVE-2024-51996
CVE-2024-51996 · Symphony has an Authentication Bypass via RememberMe
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Symphony process is a module for the Symphony PHP framework which executes commands in sub-processes. When consuming a persisted remember-me cookie, Symfony does not check if the username persisted in the database matches the username attached with the cookie, leading to authentication bypass. This vulnerability is fixed in 5.4.47, 6.4.15, and 7.1.8.
CVSS 7.5 · Hoch · EPSS 0,6% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · php
Betroffene Produkte und Versionen
symfony
- Softwareversionen
- >= 5.3.0, < 5.4.47: Betroffen
- >= 6.0.0-BETA1, < 6.4.15: Betroffen
- >= 7.0.0-BETA1, < 7.1.8: Betroffen
Keine Korrektur veröffentlicht
symfony Debian:12
- Softwareversionen
- 5.4.23+dfsg-1
- 5.4.23+dfsg-1+deb12u1
- 5.4.23+dfsg-1+deb12u2
- 5.4.23+dfsg-1+deb12u3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 5.4.23+dfsg-1+deb12u4
Auf 5.4.23+dfsg-1+deb12u4 aktualisieren
symfony Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.4.15+dfsg-1
Auf 6.4.15+dfsg-1 aktualisieren
symfony Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.4.15+dfsg-1
Auf 6.4.15+dfsg-1 aktualisieren
symfony/security-http Packagist
- Softwareversionen
- v5.3.0
- v5.3.1
- v5.3.10
- v5.3.11
- v5.3.13
- v5.3.14
- v5.3.2
- v5.3.3
- v5.3.4
- v5.3.6
- v5.3.7
- v5.3.8
- v5.4.0
- v5.4.0-BETA1
- v5.4.0-BETA2
- v5.4.0-RC1
- v5.4.10
- v5.4.11
- v5.4.12
- v5.4.13
- v5.4.15
- v5.4.17
- v5.4.19
- v5.4.2
- v5.4.20
- v5.4.21
- v5.4.22
- v5.4.23
- v5.4.26
- v5.4.28
- v5.4.3
- v5.4.30
- v5.4.31
- v5.4.35
- v5.4.36
- v5.4.38
- v5.4.39
- v5.4.40
- v5.4.41
- v5.4.43
- v5.4.44
- v5.4.45
- v5.4.46
- v5.4.5
- v5.4.8
- v5.4.9
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 5.3.0, < 5.4.47
Auf 5.4.47 aktualisieren
symfony/security-http Packagist
- Softwareversionen
- v6.0.0
- v6.0.0-BETA1
- v6.0.0-BETA2
- v6.0.0-RC1
- v6.0.1
- v6.0.10
- v6.0.11
- v6.0.12
- v6.0.13
- v6.0.14
- v6.0.15
- v6.0.17
- v6.0.19
- v6.0.2
- v6.0.20
- v6.0.3
- v6.0.5
- v6.0.7
- v6.0.8
- v6.0.9
- v6.1.0
- v6.1.0-BETA1
- v6.1.0-BETA2
- v6.1.0-RC1
- v6.1.1
- v6.1.11
- v6.1.12
- v6.1.2
- v6.1.3
- v6.1.4
- v6.1.5
- v6.1.6
- v6.1.7
- v6.1.9
- v6.2.0
- v6.2.0-BETA1
- v6.2.0-BETA3
- v6.2.0-RC1
- v6.2.10
- v6.2.11
- v6.2.13
- v6.2.2
- v6.2.5
- v6.2.6
- v6.2.7
- v6.2.8
- v6.3.0
- v6.3.0-BETA1
- v6.3.0-RC1
- v6.3.1
- v6.3.12
- v6.3.2
- v6.3.4
- v6.3.5
- v6.3.6
- v6.3.8
- v6.4.0
- v6.4.0-BETA1
- v6.4.0-BETA3
- v6.4.0-RC1
- v6.4.0-RC2
- v6.4.11
- v6.4.12
- v6.4.13
- v6.4.14
- v6.4.3
- v6.4.4
- v6.4.7
- v6.4.8
- v6.4.9
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 6.0.0-BETA1, < 6.4.15
Auf 6.4.15 aktualisieren
symfony/security-http Packagist
- Softwareversionen
- v7.0.0
- v7.0.0-BETA1
- v7.0.0-BETA3
- v7.0.0-RC1
- v7.0.0-RC2
- v7.0.1
- v7.0.3
- v7.0.4
- v7.0.7
- v7.0.8
- v7.0.9
- v7.1.0
- v7.1.0-BETA1
- v7.1.0-RC1
- v7.1.1
- v7.1.2
- v7.1.3
- v7.1.4
- v7.1.5
- v7.1.6
- v7.1.7
- Betroffene Versionsbereiche
- ECOSYSTEM: ≥ 7.0.0-BETA1, < 7.1.8
Auf 7.1.8 aktualisieren
symfony Ubuntu:22.04:LTS
- Softwareversionen
- 5.2.6+dfsg-1ubuntu7
- 5.4.4+dfsg-1ubuntu8
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
symfony Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 5.4.23+dfsg-1ubuntu1
- 5.4.35+dfsg-3ubuntu1
- 6.4.5+dfsg-3ubuntu2
- 6.4.5+dfsg-3ubuntu3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 6.4.5+dfsg-3ubuntu3+esm1
Auf 6.4.5+dfsg-3ubuntu3+esm1 aktualisieren
symfony Ubuntu:25.10
- Softwareversionen
- 6.4.18+dfsg-1ubuntu1
- 6.4.21+dfsg-2
- 6.4.21+dfsg-2ubuntu1
- 6.4.24+dfsg-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
symfony Ubuntu:26.04:LTS
- Softwareversionen
- 6.4.24+dfsg-1
- 7.4.5+dfsg-1ubuntu1
- 7.4.6+dfsg-2ubuntu1
- 7.4.7+dfsg-1ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht