p PatchFirst

CVE-2024-5206

CVE-2024-5206 · Sensitive Data Leakage in sklearn.feature_extraction.text.TfidfVectorizer in scikit-learn/scikit-learn

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A sensitive data leakage vulnerability was identified in scikit-learn's TfidfVectorizer, specifically in versions up to and including 1.4.1.post1, which was fixed in version 1.5.0. The vulnerability arises from the unexpected storage of all tokens present in the training data within the `stop_words_` attribute, rather than only storing the subset of tokens required for the TF-IDF technique to function. This behavior leads to the potential leakage of sensitive information, as the `stop_words_` attribute could contain tokens that were meant to be discarded and not stored, such as passwords or keys. The impact of this vulnerability varies based on the nature of the data being processed by the vectorizer.

CVSS 4.7 · Mittel · EPSS 0,2% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • scikit-learn/scikit-learn

    Softwareversionen
    • ≥ unspecified, < 1.5.0: Betroffen (custom)

    Auf 1.5.0 aktualisieren

  • scikit-learn Debian:12

    Softwareversionen
    • 1.2.1+dfsg-1
    • 1.4.1.post1+dfsg-1
    • 1.4.2+dfsg-1
    • 1.4.2+dfsg-2
    • 1.4.2+dfsg-3
    • 1.4.2+dfsg-4
    • 1.4.2+dfsg-5
    • 1.4.2+dfsg-6
    • 1.4.2+dfsg-7
    • 1.4.2+dfsg-8
    • 1.7.2+dfsg-1
    • 1.7.2+dfsg-2
    • 1.7.2+dfsg-3
    • 1.7.2+dfsg-4
    • 1.8.0+dfsg-1
    • 1.8.0+dfsg-2
    • 1.8.0+dfsg-3
    • 1.8.0+dfsg-4
    • 1.8.0+dfsg-5
    • 1.9.0+dfsg-1
    • 1.9.0+dfsg-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • scikit-learn Debian:13

    Softwareversionen
    • 1.4.2+dfsg-8
    • 1.7.2+dfsg-1
    • 1.7.2+dfsg-2
    • 1.7.2+dfsg-3
    • 1.7.2+dfsg-4
    • 1.8.0+dfsg-1
    • 1.8.0+dfsg-2
    • 1.8.0+dfsg-3
    • 1.8.0+dfsg-4
    • 1.8.0+dfsg-5
    • 1.9.0+dfsg-1
    • 1.9.0+dfsg-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • scikit-learn Debian:14

    Softwareversionen
    • 1.4.2+dfsg-8
    • 1.7.2+dfsg-1
    • 1.7.2+dfsg-2
    • 1.7.2+dfsg-3
    • 1.7.2+dfsg-4
    • 1.8.0+dfsg-1
    • 1.8.0+dfsg-2
    • 1.8.0+dfsg-3
    • 1.8.0+dfsg-4
    • 1.8.0+dfsg-5
    • 1.9.0+dfsg-1
    • 1.9.0+dfsg-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • scikit-learn PyPI

    Softwareversionen
    • 0.10
    • 0.11
    • 0.12
    • 0.12.1
    • 0.13
    • 0.13.1
    • 0.14
    • 0.14.1
    • 0.15.0
    • 0.15.1
    • 0.15.2
    • 0.16.0
    • 0.16.1
    • 0.17
    • 0.17.1
    • 0.18
    • 0.18.1
    • 0.18.2
    • 0.19.0
    • 0.19.1
    • 0.19.2
    • 0.20.0
    • 0.20.1
    • 0.20.2
    • 0.20.3
    • 0.20.4
    • 0.21.0
    • 0.21.1
    • 0.21.2
    • 0.21.3
    • 0.22
    • 0.22.1
    • 0.22.2
    • 0.22.2.post1
    • 0.23.0
    • 0.23.1
    • 0.23.2
    • 0.24.0
    • 0.24.1
    • 0.24.2
    • 0.9
    • 1.0
    • 1.0.1
    • 1.0.2
    • 1.1.0
    • 1.1.1
    • 1.1.2
    • 1.1.3
    • 1.2.0
    • 1.2.0rc1
    • 1.2.1
    • 1.2.2
    • 1.3.0
    • 1.3.0rc1
    • 1.3.1
    • 1.3.2
    • 1.4.0
    • 1.4.0rc1
    • 1.4.1.post1
    • 1.4.2
    • 1.5.0rc1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.5.0

    Auf 1.5.0 aktualisieren

  • scikit-learn PyPI

    Softwareversionen
    • 0.10
    • 0.11
    • 0.12
    • 0.12.1
    • 0.13
    • 0.13.1
    • 0.14
    • 0.14.1
    • 0.15.0
    • 0.15.1
    • 0.15.2
    • 0.16.0
    • 0.16.1
    • 0.17
    • 0.17.1
    • 0.18
    • 0.18.1
    • 0.18.2
    • 0.19.0
    • 0.19.1
    • 0.19.2
    • 0.20.0
    • 0.20.1
    • 0.20.2
    • 0.20.3
    • 0.20.4
    • 0.21.0
    • 0.21.1
    • 0.21.2
    • 0.21.3
    • 0.22
    • 0.22.1
    • 0.22.2
    • 0.22.2.post1
    • 0.23.0
    • 0.23.1
    • 0.23.2
    • 0.24.0
    • 0.24.1
    • 0.24.2
    • 0.9
    • 1.0
    • 1.0.1
    • 1.0.2
    • 1.1.0
    • 1.1.1
    • 1.1.2
    • 1.1.3
    • 1.2.0
    • 1.2.0rc1
    • 1.2.1
    • 1.2.2
    • 1.3.0
    • 1.3.0rc1
    • 1.3.1
    • 1.3.2
    • 1.4.0
    • 1.4.0rc1
    • 1.4.1.post1
    • 1.4.2
    • 1.5.0rc1
    • 0.19-branching
    • 0.17-branching
    • 0.15-branching
    • 0.13-branching
    • 0.12-branching
    • 0.11-branching
    • 0.11-beta
    • 0.3
    • 0.2
    • 0.2-beta
    • 0.1
    • 0.1-beta
    Betroffene Versionsbereiche
    • GIT: < 70ca21f106b603b611da73012c9ade7cd8e438b8
    • ECOSYSTEM: < 1.5.0

    Auf 1.5.0 aktualisieren

  • scikit-learn Ubuntu:14.04:LTS

    Softwareversionen
    • 0.13.1-1
    • 0.14.1-1
    • 0.14.1-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • scikit-learn Ubuntu:16.04:LTS

    Softwareversionen
    • 0.16.1-2
    • 0.17.0-4
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • scikit-learn Ubuntu:18.04:LTS

    Softwareversionen
    • 0.19.0-1build1
    • 0.19.1-1
    • 0.19.1-2
    • 0.19.1-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • scikit-learn Ubuntu:20.04:LTS

    Softwareversionen
    • 0.20.3+dfsg-0ubuntu2
    • 0.20.3+dfsg-0ubuntu3
    • 0.22.2.post1+dfsg-5
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • scikit-learn Ubuntu:22.04:LTS

    Softwareversionen
    • 0.23.2-5ubuntu2
    • 0.23.2-5ubuntu4
    • 0.23.2-5ubuntu6
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • scikit-learn Ubuntu:24.04:LTS

    Softwareversionen
    • 1.2.1+dfsg-1build1
    • 1.2.1+dfsg-1build2
    • 1.4.1.post1+dfsg-1
    • 1.4.1.post1+dfsg-1build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • scikit-learn Ubuntu:25.10

    Softwareversionen
    • 1.4.2+dfsg-8
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • scikit-learn Ubuntu:26.10

    Softwareversionen
    • 1.7.2+dfsg-4build1
    • 1.9.0+dfsg-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • scikit-learn Ubuntu:26.04:LTS

    Softwareversionen
    • 1.4.2+dfsg-8
    • 1.7.2+dfsg-3ubuntu1
    • 1.7.2+dfsg-4
    • 1.7.2+dfsg-4build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →