CVE-2024-53981
CVE-2024-53981 · python-multipart has a Denial of service (DoS) via deformation `multipart/form-data` boundary
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
python-multipart is a streaming multipart parser for Python. When parsing form data, python-multipart skips line breaks (CR \r or LF \n) in front of the first boundary and any tailing bytes after the last boundary. This happens one byte at a time and emits a log event each time, which may cause excessive logging for certain inputs. An attacker could abuse this by sending a malicious request with lots of data before the first or after the last boundary, causing high CPU load and stalling the processing thread for a significant amount of time. In case of ASGI application, this could stall the event loop and prevent other requests from being processed, resulting in a denial of service (DoS). This vulnerability is fixed in 0.0.18.
CVSS 7.5 · Hoch · EPSS 0,6% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
python-multipart
- Softwareversionen
- < 0.0.18: Betroffen
Keine Korrektur veröffentlicht
python-multipart Debian:12
- Softwareversionen
- 0.0.17-1
- 0.0.17-2
- 0.0.17-3
- 0.0.17-4
- 0.0.17-5
- 0.0.20-1
- 0.0.20-1.1
- 0.0.20-1.1~deb13u1
- 0.0.22-1
- 0.0.26-1
- 0.0.5-3
- 0.0.6-1
- 0.0.9-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
python-multipart Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.0.20-1
Auf 0.0.20-1 aktualisieren
python-multipart Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.0.20-1
Auf 0.0.20-1 aktualisieren
python-multipart PyPI
- Softwareversionen
- 0.0.1
- 0.0.10
- 0.0.11
- 0.0.12
- 0.0.13
- 0.0.14
- 0.0.15
- 0.0.16
- 0.0.17
- 0.0.2
- 0.0.3
- 0.0.4
- 0.0.5
- 0.0.6
- 0.0.7
- 0.0.8
- 0.0.9
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.0.18
Auf 0.0.18 aktualisieren
python-multipart Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 0.0.5-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.0.5-2ubuntu0.1~esm1
Auf 0.0.5-2ubuntu0.1~esm1 aktualisieren
python-multipart Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 0.0.5-3
- 0.0.6-1
- 0.0.9-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.0.9-1ubuntu0.1~esm1
Auf 0.0.9-1ubuntu0.1~esm1 aktualisieren