p PatchFirst

CVE-2024-56361

CVE-2024-56361 · Stored Cross-Site Scripting (XSS) in lgsl v7.0

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

LGSL (Live Game Server List) provides online status for games. Before 7.0.0, a stored cross-site scripting (XSS) vulnerability was identified in lgsl. The function lgsl_query_40 in lgsl_protocol.php has implemented an HTTP crawler. This function makes a request to the registered game server, and upon crawling the malicious /info endpoint with our payload, will render our javascript on the info page. This information is being displayed via lgsl_details.php. This vulnerability is fixed in 7.0.0.

CVSS 5.3 · Mittel · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: php

Betroffene Produkte und Versionen

  • lgsl

    Softwareversionen
    • < 7.0.0: Betroffen

    Keine Korrektur veröffentlicht

  • tltneon/lgsl Packagist

    Softwareversionen
    • v5.10.0
    • v5.10.1
    • v5.10.2
    • v5.10.3
    • v6.0.0
    • v6.0.1
    • v6.1.0
    • v6.1.1
    • v6.2.0
    • v6.2.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 7.0.0

    Auf 7.0.0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →