p PatchFirst

CVE-2024-6119

CVE-2024-6119 · Possible denial of service in X.509 name checks

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Issue summary: Applications performing certificate name checks (e.g., TLS clients checking server certificates) may attempt to read an invalid memory address resulting in abnormal termination of the application process. Impact summary: Abnormal termination of an application can a cause a denial of service. Applications performing certificate name checks (e.g., TLS clients checking server certificates) may attempt to read an invalid memory address when comparing the expected name with an `otherName` subject alternative name of an X.509 certificate. This may result in an exception that terminates the application program. Note that basic certificate chain validation (signatures, dates, ...) is not affected, the denial of service can occur only when the application also specifies an expected DNS name, Email address or IP address. TLS servers rarely solicit client certificates, and even when they do, they generally don't perform a name check against a reference identifier (expected identity), but rather extract the presented identity after checking the certificate chain. So TLS servers are generally not affected and the severity of the issue is Moderate. The FIPS modules in 3.3, 3.2, 3.1 and 3.0 are not affected by this issue.

CVSS 7.5 · Hoch · EPSS 66,6% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · network

Betroffene Produkte und Versionen

  • openssl

    Softwareversionen
    • ≥ 3.3.0, < 3.3.2: Betroffen (semver)
    • ≥ 3.2.0, < 3.2.3: Betroffen (semver)
    • ≥ 3.1.0, < 3.1.7: Betroffen (semver)
    • ≥ 3.0.0, < 3.0.15: Betroffen (semver)

    Auf 3.0.15 aktualisieren; Auf 3.1.7 aktualisieren; Auf 3.2.3 aktualisieren; Auf 3.3.2 aktualisieren

  • openssl Debian:12

    Softwareversionen
    • 3.0.10-1
    • 3.0.10-1~deb12u1
    • 3.0.11-1
    • 3.0.11-1~deb12u1
    • 3.0.11-1~deb12u2
    • 3.0.12-1
    • 3.0.12-2
    • 3.0.13-1~deb12u1
    • 3.0.13-1~deb12u2
    • 3.0.14-1~deb12u1
    • 3.0.9-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.0.14-1~deb12u2

    Auf 3.0.14-1~deb12u2 aktualisieren

  • openssl Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.3.2-1

    Auf 3.3.2-1 aktualisieren

  • openssl Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.3.2-1

    Auf 3.3.2-1 aktualisieren

  • nodejs Ubuntu:Pro:16.04:LTS

    Softwareversionen
    • 0.10.25~dfsg2-2ubuntu1
    • 4.2.2~dfsg-1
    • 4.2.3~dfsg-1
    • 4.2.4~dfsg-1ubuntu1
    • 4.2.4~dfsg-2
    • 4.2.6~dfsg-1ubuntu1
    • 4.2.6~dfsg-1ubuntu4
    • 4.2.6~dfsg-1ubuntu4.1
    • 4.2.6~dfsg-1ubuntu4.2
    • 4.2.6~dfsg-1ubuntu4.2+esm1
    • 4.2.6~dfsg-1ubuntu4.2+esm2
    • 4.2.6~dfsg-1ubuntu4.2+esm3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • nodejs Ubuntu:Pro:18.04:LTS

    Softwareversionen
    • 6.11.4~dfsg-1ubuntu1
    • 6.11.4~dfsg-1ubuntu2
    • 6.12.0~dfsg-1ubuntu1
    • 6.12.0~dfsg-2ubuntu1
    • 6.12.0~dfsg-2ubuntu2
    • 8.10.0~dfsg-2
    • 8.10.0~dfsg-2ubuntu0.2
    • 8.10.0~dfsg-2ubuntu0.3
    • 8.10.0~dfsg-2ubuntu0.4
    • 8.10.0~dfsg-2ubuntu0.4+esm1
    • 8.10.0~dfsg-2ubuntu0.4+esm2
    • 8.10.0~dfsg-2ubuntu0.4+esm3
    • 8.10.0~dfsg-2ubuntu0.4+esm4
    • 8.10.0~dfsg-2ubuntu0.4+esm5
    • 8.10.0~dfsg-2ubuntu0.4+esm6
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • openssl Ubuntu:22.04:LTS

    Softwareversionen
    • 1.1.1l-1ubuntu1
    • 3.0.0-1ubuntu1
    • 3.0.1-0ubuntu1
    • 3.0.2-0ubuntu1
    • 3.0.2-0ubuntu1.1
    • 3.0.2-0ubuntu1.2
    • 3.0.2-0ubuntu1.4
    • 3.0.2-0ubuntu1.5
    • 3.0.2-0ubuntu1.6
    • 3.0.2-0ubuntu1.7
    • 3.0.2-0ubuntu1.8
    • 3.0.2-0ubuntu1.9
    • 3.0.2-0ubuntu1.10
    • 3.0.2-0ubuntu1.12
    • 3.0.2-0ubuntu1.13
    • 3.0.2-0ubuntu1.14
    • 3.0.2-0ubuntu1.15
    • 3.0.2-0ubuntu1.16
    • 3.0.2-0ubuntu1.17
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.0.2-0ubuntu1.18

    Auf 3.0.2-0ubuntu1.18 aktualisieren

  • nodejs Ubuntu:Pro:22.04:LTS

    Softwareversionen
    • 12.22.5~dfsg-5ubuntu1
    • 12.22.7~dfsg-2ubuntu1
    • 12.22.7~dfsg-2ubuntu3
    • 12.22.9~dfsg-1ubuntu2
    • 12.22.9~dfsg-1ubuntu3
    • 12.22.9~dfsg-1ubuntu3.1
    • 12.22.9~dfsg-1ubuntu3.2
    • 12.22.9~dfsg-1ubuntu3.3
    • 12.22.9~dfsg-1ubuntu3.4
    • 12.22.9~dfsg-1ubuntu3.5
    • 12.22.9~dfsg-1ubuntu3.6
    • 12.22.9~dfsg-1ubuntu3.6+esm2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • openssl Ubuntu:Pro:FIPS-preview:22.04:LTS

    Softwareversionen
    • 3.0.2-0ubuntu1.10+Fips1
    • 3.0.2-0ubuntu1.12+Fips1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • openssl-fips Ubuntu:Pro:FIPS-preview:22.04:LTS

    Softwareversionen
    • 3.0.5-0ubuntu0.1+Fips2.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • openssl Ubuntu:Pro:FIPS-updates:22.04:LTS

    Softwareversionen
    • 3.0.2-0ubuntu1.10+Fips1
    • 3.0.2-0ubuntu1.12+Fips1
    • 3.0.2-0ubuntu1.14+Fips1
    • 3.0.2-0ubuntu1.15+Fips1
    • 3.0.2-0ubuntu1.16+Fips1
    • 3.0.2-0ubuntu1.17+Fips1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.0.2-0ubuntu1.18+Fips1

    Auf 3.0.2-0ubuntu1.18+Fips1 aktualisieren

  • openssl-fips Ubuntu:Pro:FIPS-updates:22.04:LTS

    Softwareversionen
    • 3.0.5-0ubuntu0.1+Fips2.1
    • 3.0.5-0ubuntu0.2+Fips1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • edk2 Ubuntu:24.04:LTS

    Softwareversionen
    • 2023.05-2
    • 2023.11-2
    • 2023.11-3
    • 2023.11-4
    • 2023.11-5
    • 2023.11-6
    • 2023.11-8
    • 2024.02-1
    • 2024.02-2
    • 2024.02-2ubuntu0.1
    • 2024.02-2ubuntu0.3
    • 2024.02-2ubuntu0.4
    • 2024.02-2ubuntu0.5
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 2024.02-2ubuntu0.6

    Auf 2024.02-2ubuntu0.6 aktualisieren

  • openssl Ubuntu:24.04:LTS

    Softwareversionen
    • 3.0.10-1ubuntu2
    • 3.0.10-1ubuntu2.1
    • 3.0.10-1ubuntu3
    • 3.0.10-1ubuntu4
    • 3.0.13-0ubuntu2
    • 3.0.13-0ubuntu3
    • 3.0.13-0ubuntu3.1
    • 3.0.13-0ubuntu3.2
    • 3.0.13-0ubuntu3.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.0.13-0ubuntu3.4

    Auf 3.0.13-0ubuntu3.4 aktualisieren

  • openssl-fips Ubuntu:Pro:FIPS-updates:24.04:LTS

    Softwareversionen
    • 3.0.13-0ubuntu3+Fips1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 3.0.13-0ubuntu3.6+Fips1

    Auf 3.0.13-0ubuntu3.6+Fips1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →