p PatchFirst

CVE-2024-8947

CVE-2024-8947 · MicroPython objarray.c use after free

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A vulnerability was found in MicroPython 1.22.2. It has been declared as critical. Affected by this vulnerability is an unknown functionality of the file py/objarray.c. The manipulation leads to use after free. The attack can be launched remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. Upgrading to version 1.23.0 is able to address this issue. The identifier of the patch is 4bed614e707c0644c06e117f848fa12605c711cd. It is recommended to upgrade the affected component. In micropython objarray component, when a bytes object is resized and copied into itself, it may reference memory that has already been freed.

CVSS 6.3 · Mittel · EPSS 1,0% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • micropython

    Softwareversionen
    • 1.22.2: Betroffen

    Keine Korrektur veröffentlicht

  • micropython Debian:13

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.24.0+ds-1

    Auf 1.24.0+ds-1 aktualisieren

  • micropython Debian:14

    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.24.0+ds-1

    Auf 1.24.0+ds-1 aktualisieren

  • micropython-copy PyPI

    Softwareversionen
    • 0.0.1
    • 0.0.2
    • 3.3.3-2
    • 3.3.3.post3
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≤ 3.3.3.post3

    Keine Korrektur veröffentlicht

  • micropython-io PyPI

    Softwareversionen
    • 0.0.1
    • 0.0.2
    • 0.0.3
    • 0.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≤ 0.1

    Keine Korrektur veröffentlicht

  • micropython-copy PyPI

    Softwareversionen
    • 0.0.1
    • 0.0.2
    • 3.3.3-2
    • 3.3.3.post3
    Betroffene Versionsbereiche
    • GIT: < 4bed614e707c0644c06e117f848fa12605c711cd
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • micropython-io PyPI

    Softwareversionen
    • 0.0.1
    • 0.0.2
    • 0.0.3
    • 0.1
    • v1.22.0
    • v1.23.0-preview
    • v1.22.0-preview
    • v1.21.0
    • v1.20.0
    • v1.19.1
    • v1.19
    • v1.18
    • v1.17
    • v1.16
    • v1.15
    • v1.14
    • v1.13
    • v1.12
    • v1.11
    • v1.10
    • v1.9.4
    • v1.9.3
    • v1.9.2
    • v1.9.1
    • v1.9
    • v1.8.7
    • v1.8.6
    • v1.8.5
    • v1.8.4
    • v1.8.3
    • v1.8.2
    • v1.8.1
    • v1.8
    • v1.7
    • v1.6
    • v1.5.2
    • v1.5.1
    • v1.5
    • v1.4.6
    • v1.4.5
    • v1.4.4
    • v1.4.3
    • v1.4.2
    • v1.4.1
    • v1.4
    • v1.3.10
    • v1.3.9
    • v1.3.8
    • v1.3.7
    • v1.3.6
    • v1.3.5
    • v1.3.4
    • v1.3.3
    • v1.3.2
    • v1.3.1
    • v1.3
    • v1.2
    • v1.1.1
    • v1.1
    • v1.0.1
    • v1.0
    • v1.0-rc1
    Betroffene Versionsbereiche
    • GIT: < 4bed614e707c0644c06e117f848fa12605c711cd
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • micropython Ubuntu:Pro:20.04:LTS

    Softwareversionen
    • 1.12-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.12-1ubuntu0.1~esm1

    Auf 1.12-1ubuntu0.1~esm1 aktualisieren

  • micropython Ubuntu:Pro:22.04:LTS

    Softwareversionen
    • 1.17+ds-1ubuntu1
    • 1.17+ds-1.1
    • 1.17+ds-1.1ubuntu2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.17+ds-1.1ubuntu2+esm1

    Auf 1.17+ds-1.1ubuntu2+esm1 aktualisieren

  • micropython Ubuntu:Pro:24.04:LTS

    Softwareversionen
    • 1.19.1+ds-1
    • 1.22.1+ds-1
    • 1.22.1+ds-1build1
    • 1.22.1+ds-1build2
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.22.1+ds-1ubuntu0.24.04.1~esm1

    Auf 1.22.1+ds-1ubuntu0.24.04.1~esm1 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →