p PatchFirst

CVE-2025-11374

CVE-2025-11374 · Consul's KV endpoint is vulnerable to denial of service

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Consul and Consul Enterprise’s (“Consul”) key/value endpoint is vulnerable to denial of service (DoS) due to incorrect Content Length header validation. This vulnerability, CVE-2025-11374, is fixed in Consul Community Edition 1.22.0 and Consul Enterprise 1.22.0, 1.21.6, 1.20.8 and 1.18.12.

CVSS 6.5 · Mittel · EPSS 0,4% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system

Betroffene Produkte und Versionen

  • consul

    Softwareversionen
    • ≥ 0, < 1.22.0: Betroffen (semver)

    Auf 1.22.0 aktualisieren

  • consul enterprise

    Softwareversionen
    • ≥ 0, < 1.22.0: Betroffen; ≥ 1.21.6: Nicht betroffen; ≥ 1.20.8: Nicht betroffen; ≥ 1.18.12: Nicht betroffen (semver)

    Auf 1.18.12 aktualisieren

  • consul Debian:11

    Softwareversionen
    • 1.10.12+dfsg1-1
    • 1.8.7+dfsg1-2
    • 1.8.7+dfsg1-3
    • 1.8.7+dfsg1-4
    • 1.8.7+dfsg1-5
    • 1.8.7+dfsg1-6
    • 1.9.17+dfsg2-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • consul Ubuntu:18.04:LTS

    Softwareversionen
    • 0.6.4~dfsg-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • consul Ubuntu:20.04:LTS

    Softwareversionen
    • 1.0.7~dfsg1-5ubuntu1
    • 1.4.4~dfsg1-2ubuntu2
    • 1.5.2+dfsg1-6
    • 1.5.2+dfsg1-10
    • 1.5.2+dfsg1-12
    • 1.5.2+dfsg2-14
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • consul Ubuntu:22.04:LTS

    Softwareversionen
    • 1.7.4+dfsg1-1
    • 1.8.7+dfsg1-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →