CVE-2025-2176
CVE-2025-2176 · libzvbi io-sim.c vbi_capture_sim_load_caption integer overflow
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
A vulnerability classified as critical has been found in libzvbi up to 0.2.43. This affects the function vbi_capture_sim_load_caption of the file src/io-sim.c. The manipulation leads to integer overflow. It is possible to initiate the attack remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 0.2.44 is able to address this issue. The identifier of the patch is ca1672134b3e2962cd392212c73f44f8f4cb489f. It is recommended to upgrade the affected component. The code maintainer was informed beforehand about the issues. She reacted very fast and highly professional.
CVSS 6.9 · Mittel · EPSS 0,7% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
libzvbi
- Softwareversionen
- 0.2.0: Betroffen
- 0.2.1: Betroffen
- 0.2.2: Betroffen
- 0.2.3: Betroffen
- 0.2.4: Betroffen
- 0.2.5: Betroffen
- 0.2.6: Betroffen
- 0.2.7: Betroffen
- 0.2.8: Betroffen
- 0.2.9: Betroffen
- 0.2.10: Betroffen
- 0.2.11: Betroffen
- 0.2.12: Betroffen
- 0.2.13: Betroffen
- 0.2.14: Betroffen
- 0.2.15: Betroffen
- 0.2.16: Betroffen
- 0.2.17: Betroffen
- 0.2.18: Betroffen
- 0.2.19: Betroffen
- 0.2.20: Betroffen
- 0.2.21: Betroffen
- 0.2.22: Betroffen
- 0.2.23: Betroffen
- 0.2.24: Betroffen
- 0.2.25: Betroffen
- 0.2.26: Betroffen
- 0.2.27: Betroffen
- 0.2.28: Betroffen
- 0.2.29: Betroffen
- 0.2.30: Betroffen
- 0.2.31: Betroffen
- 0.2.32: Betroffen
- 0.2.33: Betroffen
- 0.2.34: Betroffen
- 0.2.35: Betroffen
- 0.2.36: Betroffen
- 0.2.37: Betroffen
- 0.2.38: Betroffen
- 0.2.39: Betroffen
- 0.2.40: Betroffen
- 0.2.41: Betroffen
- 0.2.42: Betroffen
- 0.2.43: Betroffen
Keine Korrektur veröffentlicht
zvbi Debian:12
- Softwareversionen
- 0.2.41-1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.2.41-1+deb12u1
Auf 0.2.41-1+deb12u1 aktualisieren
zvbi Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.2.44-1
Auf 0.2.44-1 aktualisieren
zvbi Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.2.44-1
Auf 0.2.44-1 aktualisieren
zvbi Ubuntu:14.04:LTS
- Softwareversionen
- 0.2.33-7
- 0.2.35-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
zvbi Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 0.2.35-9
- 0.2.35-10
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.2.35-10ubuntu0.1~esm1
Auf 0.2.35-10ubuntu0.1~esm1 aktualisieren
zvbi Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 0.2.35-13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.2.35-13ubuntu0.1~esm1
Auf 0.2.35-13ubuntu0.1~esm1 aktualisieren
zvbi Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 0.2.35-16
- 0.2.35-17
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.2.35-17ubuntu0.1~esm1
Auf 0.2.35-17ubuntu0.1~esm1 aktualisieren
zvbi Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 0.2.35-18
- 0.2.35-19
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.2.35-19ubuntu0.1~esm1
Auf 0.2.35-19ubuntu0.1~esm1 aktualisieren
zvbi Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 0.2.41-2
- 0.2.42-1
- 0.2.42-1.1
- 0.2.42-1.2
- 0.2.42-2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 0.2.42-2ubuntu0.24.04.1~esm1
Auf 0.2.42-2ubuntu0.24.04.1~esm1 aktualisieren
Originalquellen
- https://vuldb.com/?id.299205
- https://vuldb.com/?ctiid.299205
- https://vuldb.com/?submit.512802
- https://github.com/zapping-vbi/zvbi/security/advisories/GHSA-g7cg-7gw9-v8cf
- https://github.com/zapping-vbi/zvbi/commit/ca1672134b3e2962cd392212c73f44f8f4cb489f
- https://github.com/zapping-vbi/zvbi/releases/tag/v0.2.44
- https://nvd.nist.gov/vuln/detail/CVE-2025-2176