CVE-2025-23217
CVE-2025-23217 · Mitmweb API Authentication Bypass Using Proxy Server
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
mitmproxy is a interactive TLS-capable intercepting HTTP proxy for penetration testers and software developers and mitmweb is a web-based interface for mitmproxy. In mitmweb 11.1.1 and below, a malicious client can use mitmweb's proxy server (bound to `*:8080` by default) to access mitmweb's internal API (bound to `127.0.0.1:8081` by default). In other words, while the cannot access the API directly, they can access the API through the proxy. An attacker may be able to escalate this SSRF-style access to remote code execution. The mitmproxy and mitmdump tools are unaffected. Only mitmweb is affected. This vulnerability has been fixed in mitmproxy 11.1.2 and above. Users are advised to upgrade. There are no known workarounds for this vulnerability.
CVSS 8.2 · Hoch · EPSS 0,9% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · python
Betroffene Produkte und Versionen
mitmproxy
- Softwareversionen
- < 11.1.2: Betroffen
Keine Korrektur veröffentlicht
mitmproxy Debian:12
- Softwareversionen
- 8.1.1-2
- 8.1.1-3
- 8.1.1-4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
mitmproxy Debian:14
- Softwareversionen
- 0.10-1
- 0.10-2
- 0.10.1-1
- 0.10.1-2
- 0.11.3-1
- 0.11.3-2
- 0.11.3-3
- 0.12.1-1
- 0.12.1-2
- 0.13-1
- 0.15-1
- 0.15-2
- 0.18.1-1
- 0.18.1-2
- 0.18.2-1
- 0.18.2-2
- 0.18.2-3
- 0.18.2-4
- 0.18.2-5
- 0.18.2-6
- 0.6-1
- 0.6-2
- 0.6-3
- 0.7-1
- 0.8-1
- 0.8-2
- 0.9.1-1
- 0.9.1-2
- 0.9.2-1
- 0.9.2-2
- 2.0.2-1
- 2.0.2-2
- 2.0.2-3
- 2.0.2-4
- 3.0.3-1
- 3.0.4-1
- 4.0.4-1
- 4.0.4-2
- 4.0.4-3
- 4.0.4-4
- 4.0.4-5
- 4.0.4-6
- 4.0.4-6.1
- 5.1.1-1
- 5.1.1-2
- 5.3.0-1
- 5.3.0-2
- 5.3.0-3
- 6.0.2-1
- 6.0.2-2
- 8.1.1-1
- 8.1.1-2
- 8.1.1-3
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.1.1-4
Auf 8.1.1-4 aktualisieren
mitmproxy PyPI
- Softwareversionen
- 0.10
- 0.10.1
- 0.11
- 0.11.1
- 0.11.2
- 0.11.3
- 0.12.0
- 0.12.1
- 0.13
- 0.14.0
- 0.15
- 0.16
- 0.17
- 0.18.1
- 0.18.2
- 0.18.3
- 0.8
- 0.8.1
- 0.9
- 0.9.1
- 0.9.2
- 1.0.0
- 1.0.1
- 1.0.2
- 10.0.0
- 10.1.0
- 10.1.1
- 10.1.2
- 10.1.3
- 10.1.4
- 10.1.5
- 10.1.6
- 10.2.0
- 10.2.1
- 10.2.2
- 10.2.3
- 10.2.4
- 10.3.0
- 10.3.1
- 10.4.0
- 10.4.1
- 10.4.2
- 11.0.0
- 11.0.1
- 11.0.2
- 11.1.0
- 2.0.0
- 2.0.1
- 2.0.2
- 3.0.0
- 3.0.1
- 3.0.2
- 3.0.3
- 3.0.4
- 4.0.0
- 4.0.1
- 4.0.3
- 4.0.4
- 5.0.0
- 5.0.1
- 5.1.0
- 5.1.1
- 5.2
- 5.3.0
- 6.0.0
- 6.0.1
- 6.0.2
- 7.0.0
- 7.0.1
- 7.0.2
- 7.0.3
- 7.0.4
- 8.0.0
- 8.1.0
- 8.1.1
- 9.0.0
- 9.0.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 11.1.2
Auf 11.1.2 aktualisieren
mitmproxy Ubuntu:16.04:LTS
- Softwareversionen
- 0.11.3-3
- 0.12.1-2
- 0.13-1
- 0.15-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
mitmproxy Ubuntu:18.04:LTS
- Softwareversionen
- 2.0.2-2
- 2.0.2-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
mitmproxy Ubuntu:20.04:LTS
- Softwareversionen
- 4.0.4-6
- 4.0.4-6.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
mitmproxy Ubuntu:22.04:LTS
- Softwareversionen
- 6.0.2-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
mitmproxy Ubuntu:24.04:LTS
- Softwareversionen
- 8.1.1-2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
mitmproxy Ubuntu:25.10
- Softwareversionen
- 8.1.1-2
- 8.1.1-3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
mitmproxy Ubuntu:26.10
- Softwareversionen
- 8.1.1-4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
mitmproxy Ubuntu:26.04:LTS
- Softwareversionen
- 8.1.1-3
- 8.1.1-4
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht