CVE-2025-26646
CVE-2025-26646 · .NET, Visual Studio, and Build Tools for Visual Studio Spoofing Vulnerability
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
External control of file name or path in .NET, Visual Studio, and Build Tools for Visual Studio allows an authorized attacker to perform spoofing over a network.
CVSS 8.0 · Hoch · EPSS 1,3% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
.net 8.0
- Softwareversionen
- ≥ 8.0.0, < 8.0.16: Betroffen (custom)
Auf 8.0.16 aktualisieren
.net 9.0
- Softwareversionen
- ≥ 9.0.0, < 9.0.5: Betroffen (custom)
Auf 9.0.5 aktualisieren
build tools for visual studio 2022
- Softwareversionen
- ≥ 17.0, < Fixed Version 17.13.7: Betroffen (custom)
Keine Korrektur veröffentlicht
microsoft visual studio 2022 version 17.10
- Softwareversionen
- ≥ 17.10.0, < 17.10.15: Betroffen (custom)
Auf 17.10.15 aktualisieren
microsoft visual studio 2022 version 17.12
- Softwareversionen
- ≥ 17.12.0, < 17.12.8: Betroffen (custom)
Auf 17.12.8 aktualisieren
microsoft visual studio 2022 version 17.13
- Softwareversionen
- ≥ 17.13.0, < 17.13.7: Betroffen (custom)
Auf 17.13.7 aktualisieren
microsoft visual studio 2022 version 17.8
- Softwareversionen
- ≥ 17.8.0, < 17.8.21: Betroffen (custom)
Auf 17.8.21 aktualisieren
dotnet6 Ubuntu:22.04:LTS
- Softwareversionen
- 6.0.108-0ubuntu1~22.04.1
- 6.0.109-0ubuntu1~22.04.1
- 6.0.110-0ubuntu1~22.04.1
- 6.0.111-0ubuntu1~22.04.1
- 6.0.113-0ubuntu1~22.04.1
- 6.0.116-0ubuntu1~22.04.1
- 6.0.118-0ubuntu1~22.04.1
- 6.0.119-0ubuntu1~22.04.1
- 6.0.120-0ubuntu1~22.04.1
- 6.0.121-0ubuntu1~22.04.1
- 6.0.122-0ubuntu1~22.04.1
- 6.0.123-0ubuntu1~22.04.1
- 6.0.124-0ubuntu1~22.04.1
- 6.0.125-0ubuntu1~22.04.1
- 6.0.126-0ubuntu1~22.04.1
- 6.0.127-0ubuntu1~22.04.1
- 6.0.128-0ubuntu1~22.04.2
- 6.0.132-0ubuntu1~22.04.1
- 6.0.133-0ubuntu1~22.04.1
- 6.0.135-0ubuntu1~22.04.1
- 6.0.136-0ubuntu1~22.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
dotnet7 Ubuntu:22.04:LTS
- Softwareversionen
- 7.0.105-0ubuntu1~22.04.1
- 7.0.107-0ubuntu1~22.04.1
- 7.0.108-0ubuntu1~22.04.1
- 7.0.109-0ubuntu1~22.04.1
- 7.0.110-0ubuntu1~22.04.1
- 7.0.111-0ubuntu1~22.04.1
- 7.0.112-0ubuntu1~22.04.1
- 7.0.113-0ubuntu1~22.04.1
- 7.0.114-0ubuntu1~22.04.1
- 7.0.115-0ubuntu1~22.04.1
- 7.0.116-0ubuntu1~22.04.1
- 7.0.117-0ubuntu1~22.04.1
- 7.0.117-0ubuntu1~22.04.2
- 7.0.119-0ubuntu1~22.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
dotnet8 Ubuntu:22.04:LTS
- Softwareversionen
- 8.0.102-8.0.2-0ubuntu1~22.04.1
- 8.0.103-8.0.3-0ubuntu1~22.04.1
- 8.0.103-8.0.3-0ubuntu1~22.04.2
- 8.0.105-8.0.5-0ubuntu1~22.04.1
- 8.0.107-8.0.7-0ubuntu1~22.04.1
- 8.0.108-8.0.8-0ubuntu1~22.04.1
- 8.0.110-8.0.10-0ubuntu1~22.04.1
- 8.0.111-8.0.11-0ubuntu1~22.04.1
- 8.0.112-8.0.12-0ubuntu1~22.04.1
- 8.0.114-8.0.14-0ubuntu1~22.04.1
- 8.0.115-8.0.15-0ubuntu1~22.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.0.116-8.0.16-0ubuntu1~22.04.1
Auf 8.0.116-8.0.16-0ubuntu1~22.04.1 aktualisieren
dotnet8 Ubuntu:24.04:LTS
- Softwareversionen
- 8.0.100-8.0.0~rc1-0ubuntu1
- 8.0.100-8.0.0~rc2-0ubuntu1
- 8.0.100-8.0.0~rc2-0ubuntu2
- 8.0.100-8.0.0-0ubuntu1
- 8.0.100-8.0.0-0ubuntu2
- 8.0.101-8.0.1-0ubuntu1
- 8.0.101-8.0.1-0ubuntu2
- 8.0.102-8.0.2-0ubuntu1
- 8.0.103-8.0.3-0ubuntu2
- 8.0.103-8.0.3-0ubuntu3
- 8.0.104-8.0.4-0ubuntu1
- 8.0.105-8.0.5-0ubuntu1~24.04.1
- 8.0.107-8.0.7-0ubuntu1~24.04.1
- 8.0.108-8.0.8-0ubuntu1~24.04.1
- 8.0.108-8.0.8-0ubuntu1~24.04.2
- 8.0.110-8.0.10-0ubuntu1~24.04.1
- 8.0.111-8.0.11-0ubuntu1~24.04.1
- 8.0.112-8.0.12-0ubuntu1~24.04.1
- 8.0.114-8.0.14-0ubuntu1~24.04.1
- 8.0.115-8.0.15-0ubuntu1~24.04.1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.0.116-8.0.16-0ubuntu1~24.04.1
Auf 8.0.116-8.0.16-0ubuntu1~24.04.1 aktualisieren
dotnet8 Ubuntu:25.10
- Softwareversionen
- 8.0.115-8.0.15-0ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 8.0.116-8.0.16-0ubuntu1
Auf 8.0.116-8.0.16-0ubuntu1 aktualisieren
dotnet9 Ubuntu:25.10
- Softwareversionen
- 9.0.105-9.0.4-0ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 9.0.106-9.0.5-0ubuntu1
Auf 9.0.106-9.0.5-0ubuntu1 aktualisieren