p PatchFirst

CVE-2025-3016

CVE-2025-3016 · Open Asset Import Library Assimp MDL File MDLMaterialLoader.cpp ParseTextureColorData resource consumption

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

A vulnerability classified as problematic was found in Open Asset Import Library Assimp 5.4.3. This vulnerability affects the function Assimp::MDLImporter::ParseTextureColorData of the file code/AssetLib/MDL/MDLMaterialLoader.cpp of the component MDL File Handler. The manipulation of the argument mWidth/mHeight leads to resource consumption. The attack can be initiated remotely. Upgrading to version 6.0 is able to address this issue. The name of the patch is 5d2a7482312db2e866439a8c05a07ce1e718bed1. It is recommended to apply a patch to fix this issue.

CVSS 5.3 · Mittel · EPSS 0,7% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: system · python

Betroffene Produkte und Versionen

  • assimp

    Softwareversionen
    • 5.4.3: Betroffen

    Keine Korrektur veröffentlicht

  • assimp Debian:12

    Softwareversionen
    • 5.2.5~ds0-1
    • 5.2.5~ds0-1.1
    • 5.3.1+ds-1
    • 5.3.1+ds-2
    • 5.4.0+ds-1
    • 5.4.1+ds-1
    • 5.4.2+ds-1
    • 5.4.3+ds-2
    • 5.4.3+ds-3
    • 6.0.2+ds-1
    • 6.0.3+ds-1
    • 6.0.4+ds-1
    • 6.0.4+ds-3
    • 6.0.5+ds-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • assimp Debian:13

    Softwareversionen
    • 5.4.3+ds-2
    • 5.4.3+ds-3
    • 6.0.2+ds-1
    • 6.0.3+ds-1
    • 6.0.4+ds-1
    • 6.0.4+ds-3
    • 6.0.5+ds-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • assimp Debian:14

    Softwareversionen
    • 5.4.3+ds-2
    • 5.4.3+ds-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 6.0.2+ds-1

    Auf 6.0.2+ds-1 aktualisieren

  • pyassimp PyPI

    Softwareversionen
    • 0.1
    • 3.3
    • 4.1.1
    • 4.1.2
    • 4.1.3
    • 4.1.4
    • 5.2.5
    Betroffene Versionsbereiche
    • ECOSYSTEM: ≤ 5.4.3

    Keine Korrektur veröffentlicht

  • assimp Ubuntu:16.04:LTS

    Softwareversionen
    • 3.0~dfsg-4ubuntu4
    • 3.1.1~dfsg-5
    • 3.2~dfsg-1
    • 3.2~dfsg-2
    • 3.2~dfsg-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • assimp Ubuntu:18.04:LTS

    Softwareversionen
    • 3.3.1~dfsg-5
    • 3.3.1~dfsg-5ubuntu1
    • 3.3.1~dfsg-5+build1
    • 4.0.1~dfsg-1~exp2
    • 4.0.1~dfsg-1
    • 4.1.0~dfsg-1
    • 4.1.0~dfsg-2
    • 4.1.0~dfsg-3
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • assimp Ubuntu:20.04:LTS

    Softwareversionen
    • 4.1.0~dfsg-5
    • 4.1.0~dfsg-5ubuntu1
    • 5.0.1~ds0-1build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • assimp Ubuntu:22.04:LTS

    Softwareversionen
    • 5.0.1~ds0-2
    • 5.0.1~ds0-3ubuntu1
    • 5.1.4~ds0-1
    • 5.1.5~ds0-1
    • 5.1.6~ds0-1
    • 5.2.0~ds0-2
    • 5.2.1~ds0-1
    • 5.2.2~ds0-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • assimp Ubuntu:24.04:LTS

    Softwareversionen
    • 5.2.5~ds0-1.1build1
    • 5.3.1+ds-1
    • 5.3.1+ds-2
    • 5.3.1+ds-2build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • assimp Ubuntu:25.10

    Softwareversionen
    • 5.4.3+ds-2
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • assimp Ubuntu:26.10

    Softwareversionen
    • 6.0.4+ds-1build1
    • 6.0.5+ds-1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

  • assimp Ubuntu:26.04:LTS

    Softwareversionen
    • 5.4.3+ds-2
    • 6.0.2+ds-1
    • 6.0.3+ds-1
    • 6.0.4+ds-1
    • 6.0.4+ds-1build1
    Betroffene Versionsbereiche
    • ECOSYSTEM: (−∞, +∞)

    Keine Korrektur veröffentlicht

Originalquellen

Prüfen Sie Ihren Server →