p PatchFirst

CVE-2025-31125

CVE-2025-31125 · Vite has a `server.fs.deny` bypassed for `inline` and `raw` with `?import` query

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Vite is a frontend tooling framework for javascript. Vite exposes content of non-allowed files using ?inline&import or ?raw?import. Only apps explicitly exposing the Vite dev server to the network (using --host or server.host config option) are affected. This vulnerability is fixed in 6.2.4, 6.1.3, 6.0.13, 5.4.16, and 4.5.11.

CVSS 5.3 · Mittel · EPSS 65,8% · Im KEV-Katalog · Öffentlicher Exploit · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • vite

    Softwareversionen
    • >= 6.2.0, < 6.2.4: Betroffen
    • >= 6.1.0, < 6.1.3: Betroffen
    • >= 6.0.0, < 6.0.13: Betroffen
    • >= 5.0.0, < 5.4.16: Betroffen
    • < 4.5.11: Betroffen

    Keine Korrektur veröffentlicht

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 6.2.0, < 6.2.4

    Auf 6.2.4 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 6.1.0, < 6.1.3

    Auf 6.1.3 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 6.0.0, < 6.0.13

    Auf 6.0.13 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 5.0.0, < 5.4.16

    Auf 5.4.16 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: < 4.5.11

    Auf 4.5.11 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →