p PatchFirst

CVE-2025-32395

CVE-2025-32395 · Vite has an `server.fs.deny` bypass with an invalid `request-target`

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Vite is a frontend tooling framework for javascript. Prior to 6.2.6, 6.1.5, 6.0.15, 5.4.18, and 4.5.13, the contents of arbitrary files can be returned to the browser if the dev server is running on Node or Bun. HTTP 1.1 spec (RFC 9112) does not allow # in request-target. Although an attacker can send such a request. For those requests with an invalid request-line (it includes request-target), the spec recommends to reject them with 400 or 301. The same can be said for HTTP 2. On Node and Bun, those requests are not rejected internally and is passed to the user land. For those requests, the value of http.IncomingMessage.url contains #. Vite assumed req.url won't contain # when checking server.fs.deny, allowing those kinds of requests to bypass the check. Only apps explicitly exposing the Vite dev server to the network (using --host or server.host config option) and running the Vite dev server on runtimes that are not Deno (e.g. Node, Bun) are affected. This vulnerability is fixed in 6.2.6, 6.1.5, 6.0.15, 5.4.18, and 4.5.13.

CVSS 6.0 · Mittel · EPSS 1,8% · Öffentlicher Exploit · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: node

Betroffene Produkte und Versionen

  • vite

    Softwareversionen
    • >= 6.2.0, < 6.2.6: Betroffen
    • >= 6.1.0, < 6.1.5: Betroffen
    • >= 6.0.0, < 6.0.15: Betroffen
    • >= 5.0.0, < 5.4.18: Betroffen
    • < 4.5.13: Betroffen

    Keine Korrektur veröffentlicht

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 6.2.0, < 6.2.6

    Auf 6.2.6 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 6.1.0, < 6.1.5

    Auf 6.1.5 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 6.0.0, < 6.0.15

    Auf 6.0.15 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: ≥ 5.0.0, < 5.4.18

    Auf 5.4.18 aktualisieren

  • vite npm

    Betroffene Versionsbereiche
    • SEMVER: < 4.5.13

    Auf 4.5.13 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →