CVE-2025-48057
CVE-2025-48057 · Icinga 2 certificate renewal might incorrectly renew an invalid certificate
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Icinga 2 is a monitoring system which checks the availability of network resources, notifies users of outages, and generates performance data for reporting. Prior to versions 2.12.12, 2.13.12, and 2.14.6, the VerifyCertificate() function can be tricked into incorrectly treating certificates as valid. This allows an attacker to send a malicious certificate request that is then treated as a renewal of an already existing certificate, resulting in the attacker obtaining a valid certificate that can be used to impersonate trusted nodes. This only occurs when Icinga 2 is built with OpenSSL older than version 1.1.0. This issue has been patched in versions 2.12.12, 2.13.12, and 2.14.6.
CVSS 9.3 · Kritisch · EPSS 0,5% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
icinga2
- Softwareversionen
- >= 2.14.0, < 2.14.6: Betroffen
- >= 2.13.0, < 2.13.12: Betroffen
- < 2.12.12: Betroffen
Keine Korrektur veröffentlicht
icinga2 Debian:12
- Softwareversionen
- 2.13.6-2
- 2.13.6-2+deb12u1
- 2.13.6-2+deb12u2
- 2.13.7-1
- 2.13.7-1~exp1
- 2.13.8-1
- 2.14.0-1~exp1
- 2.14.1-1
- 2.14.2-1
- 2.14.2-1+loong64
- 2.14.3-1
- 2.14.4-1
- 2.14.5-1
- 2.14.6-1
- 2.15.0-1
- 2.15.0-1~exp1
- 2.15.1-1
- 2.15.2-1
- 2.15.2-2
- 2.16.0-1
- 2.16.0-2
- 2.16.0-3~exp1
- 2.16.0-3~exp2
- 2.16.0-3~exp3
- 2.16.0-3~exp4
- 2.16.1-1
- 2.16.1-1~exp1
- 2.16.2-1
- 2.16.2-2
- 2.16.3-1
- 2.16.4-1
- 2.16.5-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
icinga2 Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.14.6-1
Auf 2.14.6-1 aktualisieren
icinga2 Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.14.6-1
Auf 2.14.6-1 aktualisieren
icinga2 Ubuntu:16.04:LTS
- Softwareversionen
- 2.3.8-1build1
- 2.3.11-1
- 2.4.0-1
- 2.4.1-1
- 2.4.1-2
- 2.4.1-2ubuntu1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
icinga2 Ubuntu:18.04:LTS
- Softwareversionen
- 2.7.0-1
- 2.8.1-0ubuntu2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
icinga2 Ubuntu:20.04:LTS
- Softwareversionen
- 2.10.5-1build1
- 2.11.2-1
- 2.11.2-1ubuntu1
- 2.11.2-1ubuntu2
- 2.11.2-1ubuntu3
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
icinga2 Ubuntu:22.04:LTS
- Softwareversionen
- 2.12.3-1
- 2.13.1-1
- 2.13.2-1
- 2.13.2-1build1
- 2.13.2-1build2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
icinga2 Ubuntu:24.04:LTS
- Softwareversionen
- 2.13.8-1
- 2.14.1-1
- 2.14.2-1
- 2.14.2-1build1
- 2.14.2-1build2
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
icinga2 Ubuntu:25.10
- Softwareversionen
- 2.14.5-1
- 2.14.6-1
- 2.15.0-1
- Betroffene Versionsbereiche
- ECOSYSTEM: (−∞, +∞)
Keine Korrektur veröffentlicht
Originalquellen
- https://github.com/Icinga/icinga2/security/advisories/GHSA-7vcf-f5v9-3wr6
- https://github.com/Icinga/icinga2/commit/34c93a2542bbe4e9886d15bc17ec929ead1aa152
- https://github.com/Icinga/icinga2/commit/4023128be42b18a011dda71ddee9ca79955b89cb
- https://github.com/Icinga/icinga2/commit/60f75f4a3d5cbb234eb3694ba7e9076a1a5b8776
- https://github.com/Icinga/icinga2/commit/9ad5683aab9eb392c6737ff46c830a945c9e240f
- https://github.com/Icinga/icinga2/commit/9b2c05d0cc09210bdeade77cf9a73859250fc48d
- https://nvd.nist.gov/vuln/detail/CVE-2025-48057