CVE-2025-48386
CVE-2025-48386 · Git allows a buffer overflow in 'wincred' credential helper
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
Git is a fast, scalable, distributed revision control system with an unusually rich command set that provides both high-level operations and full access to internals. The wincred credential helper uses a static buffer (target) as a unique key for storing and comparing against internal storage. This credential helper does not properly bounds check the available space remaining in the buffer before appending to it with wcsncat(), leading to potential buffer overflows. This vulnerability is fixed in v2.43.7, v2.44.4, v2.45.4, v2.46.4, v2.47.3, v2.48.2, v2.49.1, and v2.50.1.
CVSS 6.3 · Mittel · EPSS 0,4% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system
Betroffene Produkte und Versionen
git
- Softwareversionen
- < 2.43.7: Betroffen
- >= 2.44.0-rc0, < 2.44.4: Betroffen
- >= 2.45.0-rc0, < 2.45.4: Betroffen
- >= 2.46.0-rc0, < 2.46.4: Betroffen
- >= 2.47.0-rc0, < 2.47.3: Betroffen
- >= 2.48.0-rc0, < 2.48.2: Betroffen
- >= 2.49.0-rc0, < 2.49.1: Betroffen
- >= 2.50.0-rc0, < 2.50.1: Betroffen
Keine Korrektur veröffentlicht
git Ubuntu:Pro:16.04:LTS
- Softwareversionen
- 1:2.5.0-1
- 1:2.6.2-1
- 1:2.6.3-1
- 1:2.6.4-1
- 1:2.7.0~rc3-1
- 1:2.7.0-1
- 1:2.7.3-0ubuntu1
- 1:2.7.4-0ubuntu1
- 1:2.7.4-0ubuntu1.1
- 1:2.7.4-0ubuntu1.2
- 1:2.7.4-0ubuntu1.3
- 1:2.7.4-0ubuntu1.4
- 1:2.7.4-0ubuntu1.5
- 1:2.7.4-0ubuntu1.6
- 1:2.7.4-0ubuntu1.7
- 1:2.7.4-0ubuntu1.8
- 1:2.7.4-0ubuntu1.9
- 1:2.7.4-0ubuntu1.10
- 1:2.7.4-0ubuntu1.10+esm1
- 1:2.7.4-0ubuntu1.10+esm3
- 1:2.7.4-0ubuntu1.10+esm4
- 1:2.7.4-0ubuntu1.10+esm5
- 1:2.7.4-0ubuntu1.10+esm6
- 1:2.7.4-0ubuntu1.10+esm7
- 1:2.7.4-0ubuntu1.10+esm8
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:2.7.4-0ubuntu1.10+esm9
Auf 1:2.7.4-0ubuntu1.10+esm9 aktualisieren
git Ubuntu:Pro:18.04:LTS
- Softwareversionen
- 1:2.14.1-1ubuntu4
- 1:2.15.1-1ubuntu2
- 1:2.17.0-1ubuntu1
- 1:2.17.1-1ubuntu0.1
- 1:2.17.1-1ubuntu0.3
- 1:2.17.1-1ubuntu0.4
- 1:2.17.1-1ubuntu0.5
- 1:2.17.1-1ubuntu0.6
- 1:2.17.1-1ubuntu0.7
- 1:2.17.1-1ubuntu0.8
- 1:2.17.1-1ubuntu0.9
- 1:2.17.1-1ubuntu0.10
- 1:2.17.1-1ubuntu0.11
- 1:2.17.1-1ubuntu0.12
- 1:2.17.1-1ubuntu0.13
- 1:2.17.1-1ubuntu0.14
- 1:2.17.1-1ubuntu0.15
- 1:2.17.1-1ubuntu0.16
- 1:2.17.1-1ubuntu0.17
- 1:2.17.1-1ubuntu0.18
- 1:2.17.1-1ubuntu0.18+esm1
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:2.17.1-1ubuntu0.18+esm2
Auf 1:2.17.1-1ubuntu0.18+esm2 aktualisieren
git Ubuntu:Pro:20.04:LTS
- Softwareversionen
- 1:2.20.1-2ubuntu1
- 1:2.24.0-1ubuntu1
- 1:2.24.0-1ubuntu2
- 1:2.25.0-1ubuntu1
- 1:2.25.1-1ubuntu1
- 1:2.25.1-1ubuntu2
- 1:2.25.1-1ubuntu3
- 1:2.25.1-1ubuntu3.1
- 1:2.25.1-1ubuntu3.2
- 1:2.25.1-1ubuntu3.3
- 1:2.25.1-1ubuntu3.4
- 1:2.25.1-1ubuntu3.5
- 1:2.25.1-1ubuntu3.6
- 1:2.25.1-1ubuntu3.7
- 1:2.25.1-1ubuntu3.8
- 1:2.25.1-1ubuntu3.10
- 1:2.25.1-1ubuntu3.11
- 1:2.25.1-1ubuntu3.12
- 1:2.25.1-1ubuntu3.13
- 1:2.25.1-1ubuntu3.14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:2.25.1-1ubuntu3.14+esm1
Auf 1:2.25.1-1ubuntu3.14+esm1 aktualisieren
git Ubuntu:22.04:LTS
- Softwareversionen
- 1:2.32.0-1ubuntu1
- 1:2.33.1-1ubuntu1
- 1:2.34.1-1ubuntu1
- 1:2.34.1-1ubuntu1.1
- 1:2.34.1-1ubuntu1.2
- 1:2.34.1-1ubuntu1.4
- 1:2.34.1-1ubuntu1.5
- 1:2.34.1-1ubuntu1.6
- 1:2.34.1-1ubuntu1.8
- 1:2.34.1-1ubuntu1.9
- 1:2.34.1-1ubuntu1.10
- 1:2.34.1-1ubuntu1.11
- 1:2.34.1-1ubuntu1.12
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:2.34.1-1ubuntu1.13
Auf 1:2.34.1-1ubuntu1.13 aktualisieren
git Ubuntu:24.04:LTS
- Softwareversionen
- 1:2.40.1-1ubuntu1
- 1:2.43.0-1ubuntu1
- 1:2.43.0-1ubuntu5
- 1:2.43.0-1ubuntu6
- 1:2.43.0-1ubuntu7
- 1:2.43.0-1ubuntu7.1
- 1:2.43.0-1ubuntu7.2
- Betroffene Versionsbereiche
- ECOSYSTEM: < 1:2.43.0-1ubuntu7.3
Auf 1:2.43.0-1ubuntu7.3 aktualisieren