CVE-2025-48387
CVE-2025-48387 · tar-fs has issue where extract can write outside the specified dir with a specific tarball
Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.
tar-fs provides filesystem bindings for tar-stream. Versions prior to 3.0.9, 2.1.3, and 1.16.5 have an issue where an extract can write outside the specified dir with a specific tarball. This has been patched in versions 3.0.9, 2.1.3, and 1.16.5. As a workaround, use the ignore option to ignore non files/directories.
CVSS 8.7 · Hoch · EPSS 0,6% · Korrektur verfügbar
- Veröffentlicht
- Aktualisiert
Technologie-Stack: system · node
Betroffene Produkte und Versionen
tar-fs
- Softwareversionen
- < 1.16.5: Betroffen
- >= 2.0.0, < 2.1.3: Betroffen
- >= 3.0.0, < 3.0.9: Betroffen
Keine Korrektur veröffentlicht
node-tar-fs Debian:12
- Softwareversionen
- 2.1.1-6
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.1.3-0+deb12u1
Auf 2.1.3-0+deb12u1 aktualisieren
node-tar-fs Debian:13
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.0.9+~cs2.0.4-1
Auf 3.0.9+~cs2.0.4-1 aktualisieren
node-tar-fs Debian:14
- Betroffene Versionsbereiche
- ECOSYSTEM: < 3.0.9+~cs2.0.4-1
Auf 3.0.9+~cs2.0.4-1 aktualisieren
tar-fs npm
- Betroffene Versionsbereiche
- SEMVER: < 1.16.5
Auf 1.16.5 aktualisieren
tar-fs npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 2.0.0, < 2.1.3
Auf 2.1.3 aktualisieren
tar-fs npm
- Betroffene Versionsbereiche
- SEMVER: ≥ 3.0.0, < 3.0.9
Auf 3.0.9 aktualisieren
node-tar-fs Ubuntu:Pro:22.04:LTS
- Softwareversionen
- 2.1.1-2
- 2.1.1-4
- 2.1.1-6
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.1.1-6ubuntu0.22.04.1~esm1
Auf 2.1.1-6ubuntu0.22.04.1~esm1 aktualisieren
node-tar-fs Ubuntu:Pro:24.04:LTS
- Softwareversionen
- 2.1.1-6
- Betroffene Versionsbereiche
- ECOSYSTEM: < 2.1.1-6ubuntu0.24.04.1~esm1
Auf 2.1.1-6ubuntu0.24.04.1~esm1 aktualisieren
Originalquellen
- https://github.com/mafintosh/tar-fs/security/advisories/GHSA-8cj5-5rvv-wf4v
- https://github.com/google/security-research/security/advisories/GHSA-xrg4-qp5w-2c3w
- https://github.com/mafintosh/tar-fs/commit/647447b572bc135c41035e82ca7b894f02b17f0f
- https://lists.debian.org/debian-lts-announce/2025/06/msg00012.html
- https://nvd.nist.gov/vuln/detail/CVE-2025-48387