p PatchFirst

CVE-2025-48879

CVE-2025-48879 · OctoPrint Vulnerable to Denial of Service through malformed HTTP request

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

OctoPrint versions up until and including 1.11.1 contain a vulnerability that allows any unauthenticated attacker to send a manipulated broken multipart/form-data request to OctoPrint and through that make the web server component become unresponsive. The issue can be triggered by a broken multipart/form-data request lacking an end boundary to any of OctoPrint's endpoints implemented through the octoprint.server.util.tornado.UploadStorageFallbackHandler request handler. The request handler will get stuck in an endless busy loop, looking for a part of the request that will never come. As Tornado is single-threaded, that will effectively block the whole web server. The vulnerability has been patched in version 1.11.2.

CVSS 6.5 · Mittel · EPSS 0,3% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: python

Betroffene Produkte und Versionen

  • octoprint

    Softwareversionen
    • < 1.11.2: Betroffen

    Keine Korrektur veröffentlicht

  • octoprint PyPI

    Softwareversionen
    • 1.10.0
    • 1.10.0rc1
    • 1.10.0rc2
    • 1.10.0rc3
    • 1.10.0rc4
    • 1.10.1
    • 1.10.2
    • 1.10.3
    • 1.11.0
    • 1.11.0rc1
    • 1.11.0rc2
    • 1.11.0rc3
    • 1.11.0rc4
    • 1.11.0rc5
    • 1.11.0rc6
    • 1.11.0rc7
    • 1.11.1
    • 1.3.11
    • 1.3.12
    • 1.3.12rc1
    • 1.3.12rc3
    • 1.4.0
    • 1.4.0rc1
    • 1.4.0rc2
    • 1.4.0rc3
    • 1.4.0rc4
    • 1.4.0rc5
    • 1.4.0rc6
    • 1.4.1
    • 1.4.1rc1
    • 1.4.1rc2
    • 1.4.1rc3
    • 1.4.1rc4
    • 1.4.2
    • 1.5.0
    • 1.5.0rc1
    • 1.5.0rc2
    • 1.5.0rc3
    • 1.5.1
    • 1.5.2
    • 1.5.3
    • 1.6.0
    • 1.6.0rc1
    • 1.6.0rc2
    • 1.6.0rc3
    • 1.6.1
    • 1.7.0
    • 1.7.0rc1
    • 1.7.0rc2
    • 1.7.0rc3
    • 1.7.1
    • 1.7.2
    • 1.7.3
    • 1.8.0
    • 1.8.0rc1
    • 1.8.0rc2
    • 1.8.0rc3
    • 1.8.0rc4
    • 1.8.0rc5
    • 1.8.1
    • 1.8.2
    • 1.8.3
    • 1.8.4
    • 1.8.5
    • 1.8.6
    • 1.8.7
    • 1.9.0
    • 1.9.0rc1
    • 1.9.0rc2
    • 1.9.0rc3
    • 1.9.0rc4
    • 1.9.0rc5
    • 1.9.0rc6
    • 1.9.1
    • 1.9.2
    • 1.9.3
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.11.2

    Auf 1.11.2 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →