p PatchFirst

CVE-2025-48883

CVE-2025-48883 · Chrome PHP is missing encoding in `CssSelector`

Diese Seite enthält Fakten aus öffentlichen Sicherheitsquellen. Lesen Sie vor dem Aktualisieren die Originalmeldung.

Chrome PHP allows users to start playing with chrome/chromium in headless mode from PHP. Prior to version 1.14.0, CSS Selector expressions are not properly encoded, which can lead to XSS (cross-site scripting) vulnerabilities. This is patched in v1.14.0. As a workaround, users can apply encoding manually to their selectors if they are unable to upgrade.

CVSS 5.3 · Mittel · EPSS 0,5% · Korrektur verfügbar

Veröffentlicht
Aktualisiert

Technologie-Stack: php

Betroffene Produkte und Versionen

  • chrome

    Softwareversionen
    • < 1.14.0: Betroffen

    Keine Korrektur veröffentlicht

  • chrome-php/chrome Packagist

    Softwareversionen
    • v0.1.0
    • v0.1.1
    • v0.1.2
    • v0.1.3
    • v0.1.4
    • v0.10.0
    • v0.11.0
    • v0.11.1
    • v0.11.2
    • v0.2.0
    • v0.2.1
    • v0.2.2
    • v0.2.3
    • v0.2.4
    • v0.3.0
    • v0.4.0
    • v0.5.0
    • v0.6.0
    • v0.7.0
    • v0.8.0
    • v0.8.1
    • v0.9.0
    • v1.0.0
    • v1.0.1
    • v1.1.0
    • v1.1.1
    • v1.10.0
    • v1.10.1
    • v1.11.0
    • v1.12.0
    • v1.12.1
    • v1.13.0
    • v1.2.0
    • v1.2.1
    • v1.3.0
    • v1.3.1
    • v1.4.0
    • v1.4.1
    • v1.5.0
    • v1.6.0
    • v1.6.1
    • v1.6.2
    • v1.7.0
    • v1.7.1
    • v1.7.2
    • v1.8.0
    • v1.8.1
    • v1.9.0
    • v1.9.1
    Betroffene Versionsbereiche
    • ECOSYSTEM: < 1.14.0

    Auf 1.14.0 aktualisieren

Originalquellen

Prüfen Sie Ihren Server →